summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2025-04-01 12:56:37 -0400
committerArmin Kuster <akuster808@gmail.com>2025-04-13 14:07:57 -0400
commite610e7c72e8d8e5bdc270b01922488b1bdce8f6b (patch)
treee5d61fd5957d4d9c01b13e56bd0377634c8bd82b
parentd31c2619da9f2b21b129d54a91d27088107f9026 (diff)
downloadmeta-security-e610e7c72e8d8e5bdc270b01922488b1bdce8f6b.tar.gz
suricata: fix build error introduced by upstream commit
7a2b9acef2 cargo: pass PACKAGECONFIG_CONFARGS to cargo build error: unexpected argument '--with-libcap_ng-includes' found | | Usage: cargo build --verbose... --target [<TRIPLE>] --release --manifest-path <PATH> --offline Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--recipes-ids/suricata/suricata_7.0.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-ids/suricata/suricata_7.0.0.bb b/recipes-ids/suricata/suricata_7.0.0.bb
index 6e6c426..910e21e 100644
--- a/recipes-ids/suricata/suricata_7.0.0.bb
+++ b/recipes-ids/suricata/suricata_7.0.0.bb
@@ -73,6 +73,18 @@ do_configure:prepend () {
73 73
74CFLAGS += "-Wno-error=incompatible-pointer-types" 74CFLAGS += "-Wno-error=incompatible-pointer-types"
75 75
76# Commit 7a2b9acef2 cargo: pass PACKAGECONFIG_CONFARGS to cargo build
77# breaks building this recipe. Providing a copy of the original function
78# Armin 2025/04/01
79#
80oe_cargo_build () {
81 export RUSTFLAGS="${RUSTFLAGS}"
82 bbnote "Using rust targets from ${RUST_TARGET_PATH}"
83 bbnote "cargo = $(which ${CARGO})"
84 bbnote "${CARGO} build ${CARGO_BUILD_FLAGS}$@"
85 "${CARGO}" build ${CARGO_BUILD_FLAGS}"$@"
86}
87
76do_compile () { 88do_compile () {
77 # we do this to bypass the make provided by this pkg 89 # we do this to bypass the make provided by this pkg
78 # patches Makefile to skip the subdir 90 # patches Makefile to skip the subdir