summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2025-03-27 19:38:53 +0800
committerArmin Kuster <akuster808@gmail.com>2025-04-13 14:07:57 -0400
commit3fcb9c6b208134274274f18e568389b33361772b (patch)
treef1de253ba41ff16b75db1ab8a42522c7996ae5b1 /dynamic-layers/meta-python
parente3a61e6e81194b1fbfd09be0f5559e2ec2c55b8b (diff)
downloadmeta-security-3fcb9c6b208134274274f18e568389b33361772b.tar.gz
python3-xmldiff: upgrade 2.6.3 -> 2.7.0
Changes: 2.7.0 (2024-05-13) * Changed the comparison to make accurate and standard more accurate, although fast gets less accurate as a result. * Changed usage of deprecated pkg_resources package to importlib.metadata. * A use_replace flag was added to the XMLFormatter by Thomas Pfitzinger. It changes text replacement from delete and insert tags to a replace tag. It’s not currently accessaible thtough the CLI, the question is it is better to add a new formatter name, or an option to pass in formatter flags. - Added option to XMLFormatter to use replace tags - in _make_diff_tags after diffing, neighboring delete/insert diffs are joined to a replace tag - the deleted text is added as an attribute (“old-text”) - the inserted text is the element’s text Refer: https://pypi.org/project/xmldiff/2.7.0/ Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'dynamic-layers/meta-python')
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/python/python3-xmldiff_2.7.0.bb (renamed from dynamic-layers/meta-python/recipes-devtools/python/python3-xmldiff_2.6.3.bb)9
1 files changed, 8 insertions, 1 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/python/python3-xmldiff_2.6.3.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-xmldiff_2.7.0.bb
index 811cf36..9d38065 100644
--- a/dynamic-layers/meta-python/recipes-devtools/python/python3-xmldiff_2.6.3.bb
+++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-xmldiff_2.7.0.bb
@@ -2,7 +2,7 @@ DESCRIPTION="Creates diffs of XML files"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=0d0e9e3949e163c3edd1e097b8b0ed62" 3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=0d0e9e3949e163c3edd1e097b8b0ed62"
4 4
5SRC_URI[sha256sum] = "19b030b3fa37d1f0b5c5ad9ada9059884c3bf2c751c5dd8f1eb4ed49cfe3fc60" 5SRC_URI[sha256sum] = "c0910b1f800366dd7ec62923e5d06e8b06a1bd9120569a1c27f4f2446b9c68a2"
6 6
7PYPI_PACKAGE = "xmldiff" 7PYPI_PACKAGE = "xmldiff"
8 8
@@ -11,3 +11,10 @@ inherit pypi python_setuptools_build_meta
11DEPENDS += " \ 11DEPENDS += " \
12 python3-setuptools-scm-native \ 12 python3-setuptools-scm-native \
13" 13"
14
15RDEPENDS:${PN} += " \
16 python3-json \
17 python3-email \
18 python3-lxml \
19 python3-difflib \
20"