summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2024-07-28 17:02:40 -0400
committerArmin Kuster <akuster808@gmail.com>2024-07-29 20:07:01 -0400
commitfce3cf312d3344777986147e624a9f40bdaabb0d (patch)
tree0c42c9b0177b7e9a6803502e2d31df5837316ae0 /dynamic-layers/meta-python
parent9d38b8754ff13724e308acae660bf4df905dfaec (diff)
downloadmeta-security-fce3cf312d3344777986147e624a9f40bdaabb0d.tar.gz
python3-fail2ban: convert WORKDIR->UNPACKDIR
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'dynamic-layers/meta-python')
-rw-r--r--dynamic-layers/meta-python/recipes-security/fail2ban/python3-fail2ban_1.0.2.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/dynamic-layers/meta-python/recipes-security/fail2ban/python3-fail2ban_1.0.2.bb b/dynamic-layers/meta-python/recipes-security/fail2ban/python3-fail2ban_1.0.2.bb
index bf5f87d..e284d82 100644
--- a/dynamic-layers/meta-python/recipes-security/fail2ban/python3-fail2ban_1.0.2.bb
+++ b/dynamic-layers/meta-python/recipes-security/fail2ban/python3-fail2ban_1.0.2.bb
@@ -24,7 +24,7 @@ inherit systemd
24 24
25SYSTEMD_SERVICE:${PN} = "fail2ban.service" 25SYSTEMD_SERVICE:${PN} = "fail2ban.service"
26 26
27S = "${WORKDIR}/git" 27S = "${UNPACKDIR}/git"
28 28
29do_compile () { 29do_compile () {
30 cd ${S} 30 cd ${S}
@@ -40,7 +40,7 @@ do_install:append () {
40 rm -f ${D}/${bindir}/fail2ban-python 40 rm -f ${D}/${bindir}/fail2ban-python
41 install -d ${D}/${sysconfdir}/fail2ban 41 install -d ${D}/${sysconfdir}/fail2ban
42 install -d ${D}/${sysconfdir}/init.d 42 install -d ${D}/${sysconfdir}/init.d
43 install -m 0755 ${WORKDIR}/initd ${D}${sysconfdir}/init.d/fail2ban-server 43 install -m 0755 ${UNPACKDIR}/initd ${D}${sysconfdir}/init.d/fail2ban-server
44 44
45 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 45 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
46 install -d ${D}${systemd_system_unitdir} 46 install -d ${D}${systemd_system_unitdir}