summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/networking-layer
diff options
context:
space:
mode:
authorgael.portay+rtone@gmail.com <gael.portay+rtone@gmail.com>2024-10-25 10:22:39 +0200
committerArmin Kuster <akuster808@gmail.com>2024-11-24 20:19:50 -0500
commitdcb1a9142549b542fe8f7908d267e4338f20c65d (patch)
treec6eccf487655ac17c61a8f54da9ceaa6b6b0847e /dynamic-layers/networking-layer
parent8221b0e5caf63263b6f36987b1ffbb4ef29f3ecb (diff)
downloadmeta-security-dcb1a9142549b542fe8f7908d267e4338f20c65d.tar.gz
sssd: fix path to python3 interpreter
The project uses /usr/bin/python as the path to the python3 interpreter in the shebang of the python3 script /usr/sbin/sss_obfuscate[1]. OpenEmbedded uses /usr/bin/python3, and thus, it causes bitbake to raise the QA issue attached below. This fixes the path to the python3 interpreter by sed'ing the shebang at do_install if the python3 is set in the PACKAGECONFIG. Fixes: NOTE: Executing Tasks ERROR: sssd-2.9.2-r0 do_package_qa: QA Issue: /usr/sbin/sss_obfuscate contained in package sssd-python requires /usr/bin/python, but no providers found in RDEPENDS:sssd-python? [file-rdeps] ERROR: sssd-2.9.2-r0 do_package_qa: Fatal QA errors were found, failing task. [1]: https://github.com/SSSD/sssd/blob/2.5.2/src/tools/sss_obfuscate#L1 Signed-off-by: Gaƫl PORTAY <gael.portay+rtone@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'dynamic-layers/networking-layer')
-rw-r--r--dynamic-layers/networking-layer/recipes-security/sssd/sssd_2.9.2.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/dynamic-layers/networking-layer/recipes-security/sssd/sssd_2.9.2.bb b/dynamic-layers/networking-layer/recipes-security/sssd/sssd_2.9.2.bb
index e5cd4d8..f35d0c8 100644
--- a/dynamic-layers/networking-layer/recipes-security/sssd/sssd_2.9.2.bb
+++ b/dynamic-layers/networking-layer/recipes-security/sssd/sssd_2.9.2.bb
@@ -107,6 +107,10 @@ do_install () {
107 echo "d ${SSSD_UID}:${SSSD_GID} 0755 ${localstatedir}/log/${BPN} none" > ${D}${sysconfdir}/default/volatiles/99_${BPN} 107 echo "d ${SSSD_UID}:${SSSD_GID} 0755 ${localstatedir}/log/${BPN} none" > ${D}${sysconfdir}/default/volatiles/99_${BPN}
108 fi 108 fi
109 109
110 if ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'true', 'false', d)}; then
111 sed '1s,/usr/bin/python,/usr/bin/python3,' -i ${D}${sbindir}/sss_obfuscate
112 fi
113
110 # Remove /run as it is created on startup 114 # Remove /run as it is created on startup
111 rm -rf ${D}/run 115 rm -rf ${D}/run
112 116