diff options
5 files changed, 15 insertions, 15 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/python/python3-flask-script_2.0.6.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-flask-script_2.0.6.bb index 377ad02..ba0f974 100644 --- a/dynamic-layers/meta-python/recipes-devtools/python/python3-flask-script_2.0.6.bb +++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-flask-script_2.0.6.bb | |||
@@ -10,5 +10,5 @@ PYPI_PACKAGE = "Flask-Script" | |||
10 | inherit pypi setuptools3 | 10 | inherit pypi setuptools3 |
11 | 11 | ||
12 | RDEPENDS:${PN} += "\ | 12 | RDEPENDS:${PN} += "\ |
13 | ${PYTHON_PN}-flask \ | 13 | python3-flask \ |
14 | " | 14 | " |
diff --git a/dynamic-layers/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb index 963fcfe..9acdf54 100644 --- a/dynamic-layers/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb +++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb | |||
@@ -3,13 +3,13 @@ LICENSE = "MIT" | |||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=ab173cade7965b411528464589a08382" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=ab173cade7965b411528464589a08382" |
4 | 4 | ||
5 | RDEPENDS:${PN} += "\ | 5 | RDEPENDS:${PN} += "\ |
6 | ${PYTHON_PN}-ctypes \ | 6 | python3-ctypes \ |
7 | ${PYTHON_PN}-fcntl \ | 7 | python3-fcntl \ |
8 | ${PYTHON_PN}-io \ | 8 | python3-io \ |
9 | ${PYTHON_PN}-logging \ | 9 | python3-logging \ |
10 | ${PYTHON_PN}-misc \ | 10 | python3-misc \ |
11 | ${PYTHON_PN}-shell \ | 11 | python3-shell \ |
12 | ${PYTHON_PN}-threading \ | 12 | python3-threading \ |
13 | " | 13 | " |
14 | 14 | ||
15 | SRC_URI[md5sum] = "8e580fa1ff3971f94a6f81672b76c406" | 15 | SRC_URI[md5sum] = "8e580fa1ff3971f94a6f81672b76c406" |
diff --git a/dynamic-layers/meta-python/recipes-security/fail2ban/python3-fail2ban_1.0.2.bb b/dynamic-layers/meta-python/recipes-security/fail2ban/python3-fail2ban_1.0.2.bb index 135e97c..bf5f87d 100644 --- a/dynamic-layers/meta-python/recipes-security/fail2ban/python3-fail2ban_1.0.2.bb +++ b/dynamic-layers/meta-python/recipes-security/fail2ban/python3-fail2ban_1.0.2.bb | |||
@@ -54,7 +54,7 @@ do_install:append () { | |||
54 | do_install_ptest:append () { | 54 | do_install_ptest:append () { |
55 | install -d ${D}${PTEST_PATH} | 55 | install -d ${D}${PTEST_PATH} |
56 | install -d ${D}${PTEST_PATH}/bin | 56 | install -d ${D}${PTEST_PATH}/bin |
57 | sed -i -e 's/##PYTHON##/${PYTHON_PN}/g' ${D}${PTEST_PATH}/run-ptest | 57 | sed -i -e 's/##PYTHON##/python3/g' ${D}${PTEST_PATH}/run-ptest |
58 | install -D ${S}/bin/* ${D}${PTEST_PATH}/bin | 58 | install -D ${S}/bin/* ${D}${PTEST_PATH}/bin |
59 | rm -f ${D}${PTEST_PATH}/bin/fail2ban-python | 59 | rm -f ${D}${PTEST_PATH}/bin/fail2ban-python |
60 | } | 60 | } |
diff --git a/meta-tpm/recipes-tpm2/tpm2-pkcs11/tpm2-pkcs11_1.9.0.bb b/meta-tpm/recipes-tpm2/tpm2-pkcs11/tpm2-pkcs11_1.9.0.bb index e0def0f..9dea957 100644 --- a/meta-tpm/recipes-tpm2/tpm2-pkcs11/tpm2-pkcs11_1.9.0.bb +++ b/meta-tpm/recipes-tpm2/tpm2-pkcs11/tpm2-pkcs11_1.9.0.bb | |||
@@ -24,9 +24,9 @@ do_compile:append() { | |||
24 | do_install:append() { | 24 | do_install:append() { |
25 | cd ${S}/tools | 25 | cd ${S}/tools |
26 | export PYTHONPATH="${D}${PYTHON_SITEPACKAGES_DIR}" | 26 | export PYTHONPATH="${D}${PYTHON_SITEPACKAGES_DIR}" |
27 | ${PYTHON_PN} setup.py install --root="${D}" --prefix="${prefix}" --install-lib="${PYTHON_SITEPACKAGES_DIR}" --optimize=1 --skip-build | 27 | python3 setup.py install --root="${D}" --prefix="${prefix}" --install-lib="${PYTHON_SITEPACKAGES_DIR}" --optimize=1 --skip-build |
28 | 28 | ||
29 | sed -i -e "s:${PYTHON}:${USRBINPATH}/env ${PYTHON_PN}:g" "${D}${bindir}"/tpm2_ptool | 29 | sed -i -e "s:${PYTHON}:${USRBINPATH}/env python3:g" "${D}${bindir}"/tpm2_ptool |
30 | } | 30 | } |
31 | 31 | ||
32 | PACKAGES =+ "${PN}-tools" | 32 | PACKAGES =+ "${PN}-tools" |
@@ -44,4 +44,4 @@ FILES:${PN} += "\ | |||
44 | INSANE_SKIP:${PN} += "dev-so" | 44 | INSANE_SKIP:${PN} += "dev-so" |
45 | 45 | ||
46 | RDEPENDS:${PN} = "p11-kit tpm2-tools " | 46 | RDEPENDS:${PN} = "p11-kit tpm2-tools " |
47 | RDEPENDS:${PN}-tools = "${PYTHON_PN}-pyyaml ${PYTHON_PN}-cryptography ${PYTHON_PN}-pyasn1-modules" | 47 | RDEPENDS:${PN}-tools = "python3-pyyaml python3-cryptography python3-pyasn1-modules" |
diff --git a/recipes-ids/suricata/suricata_7.0.0.bb b/recipes-ids/suricata/suricata_7.0.0.bb index a52f081..a01b3d9 100644 --- a/recipes-ids/suricata/suricata_7.0.0.bb +++ b/recipes-ids/suricata/suricata_7.0.0.bb | |||
@@ -104,9 +104,9 @@ do_install () { | |||
104 | # Remove /var/run as it is created on startup | 104 | # Remove /var/run as it is created on startup |
105 | rm -rf ${D}${localstatedir}/run | 105 | rm -rf ${D}${localstatedir}/run |
106 | 106 | ||
107 | sed -i -e "s:#!.*$:#!${USRBINPATH}/env ${PYTHON_PN}:g" ${D}${bindir}/suricatasc | 107 | sed -i -e "s:#!.*$:#!${USRBINPATH}/env python3:g" ${D}${bindir}/suricatasc |
108 | sed -i -e "s:#!.*$:#!${USRBINPATH}/env ${PYTHON_PN}:g" ${D}${bindir}/suricatactl | 108 | sed -i -e "s:#!.*$:#!${USRBINPATH}/env python3:g" ${D}${bindir}/suricatactl |
109 | sed -i -e "s:#!.*$:#!${USRBINPATH}/env ${PYTHON_PN}:g" ${D}${libdir}/suricata/python/suricata/sc/suricatasc.py | 109 | sed -i -e "s:#!.*$:#!${USRBINPATH}/env python3:g" ${D}${libdir}/suricata/python/suricata/sc/suricatasc.py |
110 | } | 110 | } |
111 | 111 | ||
112 | pkg_postinst_ontarget:${PN} () { | 112 | pkg_postinst_ontarget:${PN} () { |