diff options
Diffstat (limited to 'dynamic-layers/meta-python/recipes-devtools/python')
6 files changed, 37 insertions, 15 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/python/python3-flask-script_2.0.6.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-flask-script_2.0.6.bb index ba0f974..46cdc8e 100644 --- a/dynamic-layers/meta-python/recipes-devtools/python/python3-flask-script_2.0.6.bb +++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-flask-script_2.0.6.bb | |||
@@ -7,7 +7,11 @@ SRC_URI[sha256sum] = "6425963d91054cfcc185807141c7314a9c5ad46325911bd24dcb489bd0 | |||
7 | 7 | ||
8 | PYPI_PACKAGE = "Flask-Script" | 8 | PYPI_PACKAGE = "Flask-Script" |
9 | 9 | ||
10 | inherit pypi setuptools3 | 10 | inherit pypi python_setuptools_build_meta |
11 | |||
12 | DEPENDS += " \ | ||
13 | python3-setuptools-scm-native \ | ||
14 | " | ||
11 | 15 | ||
12 | RDEPENDS:${PN} += "\ | 16 | RDEPENDS:${PN} += "\ |
13 | python3-flask \ | 17 | python3-flask \ |
diff --git a/dynamic-layers/meta-python/recipes-devtools/python/python3-json2html_1.3.0.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-json2html_1.3.0.bb index 638c56f..3d7e897 100644 --- a/dynamic-layers/meta-python/recipes-devtools/python/python3-json2html_1.3.0.bb +++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-json2html_1.3.0.bb | |||
@@ -6,4 +6,8 @@ SRC_URI[sha256sum] = "8951a53662ae9cfd812685facdba693fc950ffc1c1fd1a8a2d3cf4c346 | |||
6 | 6 | ||
7 | PYPI_PACKAGE = "json2html" | 7 | PYPI_PACKAGE = "json2html" |
8 | 8 | ||
9 | inherit pypi setuptools3 | 9 | inherit pypi python_setuptools_build_meta |
10 | |||
11 | DEPENDS += " \ | ||
12 | python3-setuptools-scm-native \ | ||
13 | " | ||
diff --git a/dynamic-layers/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb index ff1b611..9aaa7c9 100644 --- a/dynamic-layers/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb +++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb | |||
@@ -2,6 +2,19 @@ DESCRIPTION = "Python pyinotify: Linux filesystem events monitoring" | |||
2 | LICENSE = "MIT" | 2 | LICENSE = "MIT" |
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=ab173cade7965b411528464589a08382" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=ab173cade7965b411528464589a08382" |
4 | 4 | ||
5 | SRC_URI[md5sum] = "8e580fa1ff3971f94a6f81672b76c406" | ||
6 | SRC_URI[sha256sum] = "9c998a5d7606ca835065cdabc013ae6c66eb9ea76a00a1e3bc6e0cfe2b4f71f4" | ||
7 | |||
8 | SRC_URI += " \ | ||
9 | file://0001-Make-asyncore-support-optional-for-Python-3.patch \ | ||
10 | " | ||
11 | |||
12 | inherit pypi python_setuptools_build_meta | ||
13 | |||
14 | DEPENDS += " \ | ||
15 | python3-setuptools-scm-native \ | ||
16 | " | ||
17 | |||
5 | RDEPENDS:${PN} += "\ | 18 | RDEPENDS:${PN} += "\ |
6 | python3-ctypes \ | 19 | python3-ctypes \ |
7 | python3-fcntl \ | 20 | python3-fcntl \ |
@@ -11,12 +24,3 @@ RDEPENDS:${PN} += "\ | |||
11 | python3-shell \ | 24 | python3-shell \ |
12 | python3-threading \ | 25 | python3-threading \ |
13 | " | 26 | " |
14 | |||
15 | SRC_URI[md5sum] = "8e580fa1ff3971f94a6f81672b76c406" | ||
16 | SRC_URI[sha256sum] = "9c998a5d7606ca835065cdabc013ae6c66eb9ea76a00a1e3bc6e0cfe2b4f71f4" | ||
17 | |||
18 | SRC_URI += " \ | ||
19 | file://0001-Make-asyncore-support-optional-for-Python-3.patch \ | ||
20 | " | ||
21 | |||
22 | inherit pypi setuptools3 | ||
diff --git a/dynamic-layers/meta-python/recipes-devtools/python/python3-segno_1.5.2.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-segno_1.5.2.bb index f8a6552..e24f322 100644 --- a/dynamic-layers/meta-python/recipes-devtools/python/python3-segno_1.5.2.bb +++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-segno_1.5.2.bb | |||
@@ -4,6 +4,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=8e8db3765a57bcb968140e0a353c1a35" | |||
4 | 4 | ||
5 | SRC_URI[sha256sum] = "983424b296e62189d70fc73460cd946cf56dcbe82b9bda18c066fc1b24371cdc" | 5 | SRC_URI[sha256sum] = "983424b296e62189d70fc73460cd946cf56dcbe82b9bda18c066fc1b24371cdc" |
6 | 6 | ||
7 | #PYPI_PACKAGE = "Flask-Script" | 7 | inherit pypi python_setuptools_build_meta |
8 | 8 | ||
9 | inherit pypi setuptools3 | 9 | DEPENDS += " \ |
10 | python3-setuptools-scm-native \ | ||
11 | " | ||
diff --git a/dynamic-layers/meta-python/recipes-devtools/python/python3-xmldiff_2.6.3.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-xmldiff_2.6.3.bb index 517ed87..811cf36 100644 --- a/dynamic-layers/meta-python/recipes-devtools/python/python3-xmldiff_2.6.3.bb +++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-xmldiff_2.6.3.bb | |||
@@ -6,4 +6,8 @@ SRC_URI[sha256sum] = "19b030b3fa37d1f0b5c5ad9ada9059884c3bf2c751c5dd8f1eb4ed49cf | |||
6 | 6 | ||
7 | PYPI_PACKAGE = "xmldiff" | 7 | PYPI_PACKAGE = "xmldiff" |
8 | 8 | ||
9 | inherit pypi setuptools3 | 9 | inherit pypi python_setuptools_build_meta |
10 | |||
11 | DEPENDS += " \ | ||
12 | python3-setuptools-scm-native \ | ||
13 | " | ||
diff --git a/dynamic-layers/meta-python/recipes-devtools/python/python3-yamlpath_3.8.0.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-yamlpath_3.8.0.bb index 5d88951..8d5f33e 100644 --- a/dynamic-layers/meta-python/recipes-devtools/python/python3-yamlpath_3.8.0.bb +++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-yamlpath_3.8.0.bb | |||
@@ -6,4 +6,8 @@ SRC_URI[sha256sum] = "81d5b8baba60c255b519ccd31a691f9bc064223ff196709d41119bde81 | |||
6 | 6 | ||
7 | PYPI_PACKAGE = "yamlpath" | 7 | PYPI_PACKAGE = "yamlpath" |
8 | 8 | ||
9 | inherit pypi setuptools3 | 9 | inherit pypi python_setuptools_build_meta |
10 | |||
11 | DEPENDS += " \ | ||
12 | python3-setuptools-scm-native \ | ||
13 | " | ||