summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorJeremy Puhlman <jpuhlman@mvista.com>2020-01-30 15:28:40 -0800
committerJoe MacDonald <joe_macdonald@mentor.com>2020-01-30 21:46:58 -0500
commitf32f21de44f2b5280c2a339b0917f61f698de66c (patch)
tree3ec828577d3b6b299009cc82cf2b8afb1b23e0e9 /dynamic-layers
parent6e18bc43d259c3322d76ef995655dc539a5eb5c2 (diff)
downloadmeta-selinux-f32f21de44f2b5280c2a339b0917f61f698de66c.tar.gz
python: move appends to a dynamic-layer
Signed-off-by: Jeremy Puhlman <jpuhlman@mvista.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/python2-layer/recipes-devtools/python/files/sitecustomize.py26
-rw-r--r--dynamic-layers/python2-layer/recipes-devtools/python/python_%.bbappend1
-rw-r--r--dynamic-layers/python2-layer/recipes-devtools/python/python_selinux.inc5
3 files changed, 32 insertions, 0 deletions
diff --git a/dynamic-layers/python2-layer/recipes-devtools/python/files/sitecustomize.py b/dynamic-layers/python2-layer/recipes-devtools/python/files/sitecustomize.py
new file mode 100644
index 0000000..d2b71fa
--- /dev/null
+++ b/dynamic-layers/python2-layer/recipes-devtools/python/files/sitecustomize.py
@@ -0,0 +1,26 @@
1# OpenEmbedded sitecustomize.py (C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
2# GPLv2 or later
3# Version: 20081123
4# Features:
5# * set proper default encoding
6# Features removed for SELinux:
7# * enable readline completion in the interactive interpreter
8# * load command line history on startup
9# * save command line history on exit
10
11import os
12
13def __enableDefaultEncoding():
14 import sys
15 try:
16 sys.setdefaultencoding( "utf8" )
17 except LookupError:
18 pass
19
20import sys
21try:
22 import rlcompleter, readline
23except ImportError:
24 pass
25else:
26 __enableDefaultEncoding()
diff --git a/dynamic-layers/python2-layer/recipes-devtools/python/python_%.bbappend b/dynamic-layers/python2-layer/recipes-devtools/python/python_%.bbappend
new file mode 100644
index 0000000..7719d3b
--- /dev/null
+++ b/dynamic-layers/python2-layer/recipes-devtools/python/python_%.bbappend
@@ -0,0 +1 @@
require ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', '${BPN}_selinux.inc', '', d)}
diff --git a/dynamic-layers/python2-layer/recipes-devtools/python/python_selinux.inc b/dynamic-layers/python2-layer/recipes-devtools/python/python_selinux.inc
new file mode 100644
index 0000000..bb54a90
--- /dev/null
+++ b/dynamic-layers/python2-layer/recipes-devtools/python/python_selinux.inc
@@ -0,0 +1,5 @@
1# If selinux enabled, disable handlers to rw command history file
2FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3
4inherit selinux
5