diff options
author | Yi Zhao <yi.zhao@windriver.com> | 2023-12-16 16:21:30 +0800 |
---|---|---|
committer | Joe MacDonald <joe@deserted.net> | 2023-12-18 11:06:30 -0500 |
commit | 62b9c816a5000dc01b28e78213bde26b58cbca9d (patch) | |
tree | 15c1874f9ce12e9751b83584da40bf32629779f4 /recipes-security/selinux/libselinux/0002-Do-not-use-PYCEXT-and-rely-on-the-installed-file-nam.patch | |
parent | 1b43d4d92102ac8aa11fc5da566f28035232ec05 (diff) | |
download | meta-selinux-62b9c816a5000dc01b28e78213bde26b58cbca9d.tar.gz |
libselinux: upgrade 3.5 -> 3.6
* Refresh patches.
* Merge libselinux and libselinux-python.
The previous libselinux recipe was split into libselinux and
libselinux-python due to loop dependency[1]. Now this error is gone,
we can merge these two recipes into one again.
[1] https://git.yoctoproject.org/meta-selinux/commit/?id=7bb1507928f2e0f54ff8eac4135e15e821cdb1e2
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'recipes-security/selinux/libselinux/0002-Do-not-use-PYCEXT-and-rely-on-the-installed-file-nam.patch')
-rw-r--r-- | recipes-security/selinux/libselinux/0002-Do-not-use-PYCEXT-and-rely-on-the-installed-file-nam.patch | 8 |
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-security/selinux/libselinux/0002-Do-not-use-PYCEXT-and-rely-on-the-installed-file-nam.patch b/recipes-security/selinux/libselinux/0002-Do-not-use-PYCEXT-and-rely-on-the-installed-file-nam.patch index cd5510d..7ebe64f 100644 --- a/recipes-security/selinux/libselinux/0002-Do-not-use-PYCEXT-and-rely-on-the-installed-file-nam.patch +++ b/recipes-security/selinux/libselinux/0002-Do-not-use-PYCEXT-and-rely-on-the-installed-file-nam.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 1454521f2b9f2cbc3c40177aae9c260ec8966ae0 Mon Sep 17 00:00:00 2001 | 1 | From 303d8dfe53fcd02ea5818f976369cdb629bc1114 Mon Sep 17 00:00:00 2001 |
2 | From: Thomas Petazzoni <thomas.petazzoni@bootlin.com> | 2 | From: Thomas Petazzoni <thomas.petazzoni@bootlin.com> |
3 | Date: Fri, 25 Oct 2019 13:37:14 +0200 | 3 | Date: Fri, 25 Oct 2019 13:37:14 +0200 |
4 | Subject: [PATCH] Do not use PYCEXT, and rely on the installed file name | 4 | Subject: [PATCH] Do not use PYCEXT, and rely on the installed file name |
@@ -27,7 +27,7 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com> | |||
27 | 1 file changed, 1 insertion(+), 2 deletions(-) | 27 | 1 file changed, 1 insertion(+), 2 deletions(-) |
28 | 28 | ||
29 | diff --git a/src/Makefile b/src/Makefile | 29 | diff --git a/src/Makefile b/src/Makefile |
30 | index 983f8af..3d777bb 100644 | 30 | index 265f1be..47e51d6 100644 |
31 | --- a/src/Makefile | 31 | --- a/src/Makefile |
32 | +++ b/src/Makefile | 32 | +++ b/src/Makefile |
33 | @@ -15,7 +15,6 @@ INCLUDEDIR ?= $(PREFIX)/include | 33 | @@ -15,7 +15,6 @@ INCLUDEDIR ?= $(PREFIX)/include |
@@ -38,9 +38,9 @@ index 983f8af..3d777bb 100644 | |||
38 | RUBYINC ?= $(shell $(RUBY) -e 'puts "-I" + RbConfig::CONFIG["rubyarchhdrdir"] + " -I" + RbConfig::CONFIG["rubyhdrdir"]') | 38 | RUBYINC ?= $(shell $(RUBY) -e 'puts "-I" + RbConfig::CONFIG["rubyarchhdrdir"] + " -I" + RbConfig::CONFIG["rubyhdrdir"]') |
39 | RUBYLIBS ?= $(shell $(RUBY) -e 'puts "-L" + RbConfig::CONFIG["libdir"] + " -L" + RbConfig::CONFIG["archlibdir"] + " " + RbConfig::CONFIG["LIBRUBYARG_SHARED"]') | 39 | RUBYLIBS ?= $(shell $(RUBY) -e 'puts "-L" + RbConfig::CONFIG["libdir"] + " -L" + RbConfig::CONFIG["archlibdir"] + " " + RbConfig::CONFIG["LIBRUBYARG_SHARED"]') |
40 | RUBYINSTALL ?= $(shell $(RUBY) -e 'puts RbConfig::CONFIG["vendorarchdir"]') | 40 | RUBYINSTALL ?= $(shell $(RUBY) -e 'puts RbConfig::CONFIG["vendorarchdir"]') |
41 | @@ -189,7 +188,7 @@ install: all | 41 | @@ -193,7 +192,7 @@ install: all |
42 | install-pywrap: pywrap | 42 | install-pywrap: pywrap |
43 | $(PYTHON) -m pip install --prefix=$(PREFIX) --root $(DESTDIR) --ignore-installed --no-deps $(PYTHON_SETUP_ARGS) . | 43 | CFLAGS="$(CPPFLAGS) $(CFLAGS) $(SWIG_CFLAGS)" $(PYTHON) -m pip install --prefix=$(PREFIX) --root $(DESTDIR) --ignore-installed --no-deps $(PYTHON_SETUP_ARGS) . |
44 | install -m 644 $(SWIGPYOUT) $(DESTDIR)$(PYTHONLIBDIR)/selinux/__init__.py | 44 | install -m 644 $(SWIGPYOUT) $(DESTDIR)$(PYTHONLIBDIR)/selinux/__init__.py |
45 | - ln -sf --relative $(DESTDIR)$(PYTHONLIBDIR)/selinux/_selinux$(PYCEXT) $(DESTDIR)$(PYTHONLIBDIR)/_selinux$(PYCEXT) | 45 | - ln -sf --relative $(DESTDIR)$(PYTHONLIBDIR)/selinux/_selinux$(PYCEXT) $(DESTDIR)$(PYTHONLIBDIR)/_selinux$(PYCEXT) |
46 | + ln -sf --relative $(DESTDIR)$(PYTHONLIBDIR)/selinux/_selinux*.so $(DESTDIR)$(PYTHONLIBDIR)/ | 46 | + ln -sf --relative $(DESTDIR)$(PYTHONLIBDIR)/selinux/_selinux*.so $(DESTDIR)$(PYTHONLIBDIR)/ |