summaryrefslogtreecommitdiffstats
path: root/recipes-security/selinux/selinux-python/fix-sepolicy-install-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/selinux/selinux-python/fix-sepolicy-install-path.patch')
-rw-r--r--recipes-security/selinux/selinux-python/fix-sepolicy-install-path.patch23
1 files changed, 7 insertions, 16 deletions
diff --git a/recipes-security/selinux/selinux-python/fix-sepolicy-install-path.patch b/recipes-security/selinux/selinux-python/fix-sepolicy-install-path.patch
index 30a19eb..527e02c 100644
--- a/recipes-security/selinux/selinux-python/fix-sepolicy-install-path.patch
+++ b/recipes-security/selinux/selinux-python/fix-sepolicy-install-path.patch
@@ -1,36 +1,27 @@
1From e57022e3577770188ad3570005b7107a09cf3bb9 Mon Sep 17 00:00:00 2001 1From e8fdfdf96a84209118deff7782cf82f8187af6c5 Mon Sep 17 00:00:00 2001
2From: Xin Ouyang <Xin.Ouyang@windriver.com> 2From: Xin Ouyang <Xin.Ouyang@windriver.com>
3Date: Mon, 23 Sep 2013 21:17:59 +0800 3Date: Mon, 23 Sep 2013 21:17:59 +0800
4Subject: [PATCH] policycoreutils: fix install path for new pymodule sepolicy 4Subject: [PATCH] policycoreutils: fix install path for new pymodule sepolicy
5 5
6Uptream-Status: Pending 6Upstream-Status: Inappropriate [embedded specific]
7 7
8Signed-off-by: Xin Ouyang <Xin.Ouyang@windriver.com> 8Signed-off-by: Xin Ouyang <Xin.Ouyang@windriver.com>
9Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> 9Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
10Signed-off-by: Yi Zhao <yi.zhao@windriver.com> 10Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
11--- 11---
12 sepolicy/Makefile | 4 +++- 12 sepolicy/Makefile | 2 +-
13 1 file changed, 3 insertions(+), 1 deletion(-) 13 1 file changed, 1 insertion(+), 1 deletion(-)
14 14
15diff --git a/sepolicy/Makefile b/sepolicy/Makefile 15diff --git a/sepolicy/Makefile b/sepolicy/Makefile
16index 69f29fa..a18d1c3 100644 16index 69f29fa..b474d80 100644
17--- a/sepolicy/Makefile 17--- a/sepolicy/Makefile
18+++ b/sepolicy/Makefile 18+++ b/sepolicy/Makefile
19@@ -9,6 +9,8 @@ BASHCOMPLETIONDIR ?= $(PREFIX)/share/bash-completion/completions 19@@ -27,7 +27,7 @@ test:
20 CFLAGS ?= -Wall -Werror -Wextra -W
21 override CFLAGS += -DPACKAGE="policycoreutils" -DSHARED -shared
22
23+PYLIBVER ?= $(shell python -c 'import sys;print "python%d.%d" % sys.version_info[0:2]')
24+
25 BASHCOMPLETIONS=sepolicy-bash-completion.sh
26
27 all: python-build
28@@ -27,7 +29,7 @@ test:
29 @$(PYTHON) test_sepolicy.py -v 20 @$(PYTHON) test_sepolicy.py -v
30 21
31 install: 22 install:
32- $(PYTHON) setup.py install --prefix=$(PREFIX) `test -n "$(DESTDIR)" && echo --root $(DESTDIR)` 23- $(PYTHON) setup.py install --prefix=$(PREFIX) `test -n "$(DESTDIR)" && echo --root $(DESTDIR)`
33+ $(PYTHON) setup.py install --prefix=$(PREFIX) --install-lib $(DESTDIR)$(LIBDIR)/$(PYLIBVER)/site-packages 24+ $(PYTHON) setup.py install --prefix=$(PREFIX) --root=$(DESTDIR) --install-lib=$(PYTHONLIBDIR) --no-compile
34 [ -d $(DESTDIR)$(BINDIR) ] || mkdir -p $(DESTDIR)$(BINDIR) 25 [ -d $(DESTDIR)$(BINDIR) ] || mkdir -p $(DESTDIR)$(BINDIR)
35 install -m 755 sepolicy.py $(DESTDIR)$(BINDIR)/sepolicy 26 install -m 755 sepolicy.py $(DESTDIR)$(BINDIR)/sepolicy
36 (cd $(DESTDIR)$(BINDIR); ln -sf sepolicy sepolgen) 27 (cd $(DESTDIR)$(BINDIR); ln -sf sepolicy sepolgen)