diff options
author | Chirag Shilwant <c-shilwant@ti.com> | 2025-04-28 19:11:52 +0530 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2025-04-29 10:08:00 -0500 |
commit | 3fb8a8bd6da7d8c086ba819da89395946dbe5d78 (patch) | |
tree | dbd04d487c302578e25b72e0e0e1dd0b5767f2d2 | |
parent | ef8770216a80d9f5903c427496053d84d8700182 (diff) | |
download | meta-ti-master-wip.tar.gz |
recipes-bsp: Add DM_FIRMWARE override for am62axxmaster-wip
* With [0], the EdgeAI DM R5 firmware for am62axx will now be
maintained at ti-linux-firmware. Until now, the same firmware was
maintained on psdk_fw [1] with a different name & fetched in TI SDK
via meta-edgeai [2]
* Hence, add a am62axx specific override for DM_FIRMWARE inorder to
match the firmware name as maintained in "ti-dm/am62axx" of
ti-linux-firmware.
[0]: https://git.ti.com/cgit/processor-firmware/ti-linux-firmware/commit/?h=ti-linux-firmware&id=eee26bfeb6469af30e5309ba8859e9b65670fcc3
[1]: https://git.ti.com/cgit/processor-sdk/psdk_fw/
[2]: https://git.ti.com/cgit/edgeai/meta-edgeai/tree/recipes-tisdk/ti-psdk-rtos/ti-edgeai-firmware.bb?h=EDGEAI_CICD_20250417
Signed-off-by: Chirag Shilwant <c-shilwant@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r-- | meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb | 1 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc | 1 |
2 files changed, 2 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb b/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb index 638138f4..a7d15e30 100644 --- a/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb +++ b/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb | |||
@@ -39,6 +39,7 @@ DM_FW_DIR = "ti-dm/${PLAT_SFX}" | |||
39 | INSTALL_DM_FW_DIR = "${nonarch_base_libdir}/firmware/${DM_FW_DIR}" | 39 | INSTALL_DM_FW_DIR = "${nonarch_base_libdir}/firmware/${DM_FW_DIR}" |
40 | 40 | ||
41 | DM_FIRMWARE = "ipc_echo_testb_mcu1_0_release_strip.xer5f" | 41 | DM_FIRMWARE = "ipc_echo_testb_mcu1_0_release_strip.xer5f" |
42 | DM_FIRMWARE:am62axx = "dm_edgeai_mcu1_0_release_strip.out" | ||
42 | 43 | ||
43 | DM_FW_LIST = "" | 44 | DM_FW_LIST = "" |
44 | DM_FW_LIST:j721e = "${DM_FIRMWARE}" | 45 | DM_FW_LIST:j721e = "${DM_FIRMWARE}" |
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc index e337f84f..57bf7a4e 100644 --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc | |||
@@ -45,6 +45,7 @@ DEPENDS:append:j721s2 = " ti-hsm-demo-fw" | |||
45 | DEPENDS:append:j784s4 = " ti-hsm-demo-fw" | 45 | DEPENDS:append:j784s4 = " ti-hsm-demo-fw" |
46 | 46 | ||
47 | DM_FIRMWARE = "ipc_echo_testb_mcu1_0_release_strip.xer5f" | 47 | DM_FIRMWARE = "ipc_echo_testb_mcu1_0_release_strip.xer5f" |
48 | DM_FIRMWARE:am62axx = "dm_edgeai_mcu1_0_release_strip.out" | ||
48 | 49 | ||
49 | PLAT_SFX = "" | 50 | PLAT_SFX = "" |
50 | PLAT_SFX:j721e = "j721e" | 51 | PLAT_SFX:j721e = "j721e" |