diff options
author | Ryan Eatmon <reatmon@ti.com> | 2025-02-07 09:38:18 -0600 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2025-02-07 13:37:47 -0600 |
commit | 3e325510c4f6ab60881e8011e4c46c10f641c72b (patch) | |
tree | 355dd1c5e24e2cf6c6e716a4bcd2e9006ef1b8ba | |
parent | d590ddc71edd22c637493efaa7cdf293a2b086e9 (diff) | |
download | meta-ti-3e325510c4f6ab60881e8011e4c46c10f641c72b.tar.gz |
Revert "u-boot: Fix implicit declaration compile error"
This reverts commit eeb68bcae31b60273331245cb849fa6635b74352.
This patch was accepted to the ti-u-boot repo, so this patch is no
longer needed.
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r-- | meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2025.01.bb | 2 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/u-boot/u-boot/0001-remoteproc-k3-m4-Fix-implicit-definition-of-ti_secur.patch | 32 |
2 files changed, 0 insertions, 34 deletions
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2025.01.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2025.01.bb index c041ffe8..5e56d2db 100644 --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2025.01.bb +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2025.01.bb | |||
@@ -6,6 +6,4 @@ PR = "r0" | |||
6 | 6 | ||
7 | BRANCH = "ti-u-boot-2025.01" | 7 | BRANCH = "ti-u-boot-2025.01" |
8 | 8 | ||
9 | SRC_URI += "file://0001-remoteproc-k3-m4-Fix-implicit-definition-of-ti_secur.patch" | ||
10 | |||
11 | SRCREV = "4e9c90ad8b12cc5b4fdd1308bc3ac3e4fc869aab" | 9 | SRCREV = "4e9c90ad8b12cc5b4fdd1308bc3ac3e4fc869aab" |
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot/0001-remoteproc-k3-m4-Fix-implicit-definition-of-ti_secur.patch b/meta-ti-bsp/recipes-bsp/u-boot/u-boot/0001-remoteproc-k3-m4-Fix-implicit-definition-of-ti_secur.patch deleted file mode 100644 index c6b15651..00000000 --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot/0001-remoteproc-k3-m4-Fix-implicit-definition-of-ti_secur.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From f9c2ae13a80f3b0f309214c6b57bc3a705b71398 Mon Sep 17 00:00:00 2001 | ||
2 | From: Ryan Eatmon <reatmon@ti.com> | ||
3 | Date: Mon, 3 Feb 2025 16:54:24 -0600 | ||
4 | Subject: [tiU25.01]] remoteproc: k3-m4: Fix implicit definition of | ||
5 | ti_secure_image_post_process | ||
6 | |||
7 | Add missing include to make sure that ti_secure_image_post_process() is | ||
8 | not implicitly declared. | ||
9 | |||
10 | Signed-off-by: Ryan Eatmon <reatmon@ti.com> | ||
11 | |||
12 | Upstream-Status: Pending | ||
13 | |||
14 | --- | ||
15 | drivers/remoteproc/ti_k3_m4_rproc.c | 1 + | ||
16 | 1 file changed, 1 insertion(+) | ||
17 | |||
18 | diff --git a/drivers/remoteproc/ti_k3_m4_rproc.c b/drivers/remoteproc/ti_k3_m4_rproc.c | ||
19 | index 5a5ae2fa81d..516c817385e 100644 | ||
20 | --- a/drivers/remoteproc/ti_k3_m4_rproc.c | ||
21 | +++ b/drivers/remoteproc/ti_k3_m4_rproc.c | ||
22 | @@ -20,6 +20,7 @@ | ||
23 | #include <linux/sizes.h> | ||
24 | #include <linux/soc/ti/ti_sci_protocol.h> | ||
25 | #include "ti_sci_proc.h" | ||
26 | +#include <mach/security.h> | ||
27 | |||
28 | /** | ||
29 | * struct k3_m4_mem - internal memory structure | ||
30 | -- | ||
31 | 2.17.1 | ||
32 | |||