diff options
author | Yunguo Wei <yunguo.wei@windriver.com> | 2016-05-30 15:34:26 +0800 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2016-05-30 14:19:39 -0400 |
commit | 01aa8f18196d76d4554649c47348fb68277574c5 (patch) | |
tree | e8aa13a6bad886b5c9de84f8d56695b6a1714002 | |
parent | 313b06bfade57c1088de0924075a00c21f32769a (diff) | |
download | meta-virtualization-01aa8f18196d76d4554649c47348fb68277574c5.tar.gz |
docker: override GOROOT at build time
Usually $GOROOT is set by go tool, but if sstate is specified, $GOROOT
is set to the path in the first project. If docker is built in the
another project(with same SSTATE_DIR) later, and the first project is removed,
the following error will be seen:
| go: cannot find GOROOT directory:
/path/to/previous/project/bitbake_build/tmp/sysroots/x86_64-linux/usr/lib/x86_64-wrs-linux/go
This commit is overriding $GOROOT stored in the go tool in sstate cache,
making sure it is set to the correct path in current project.
See more information here: https://golang.org/doc/install#install
Signed-off-by: Yunguo Wei <yunguo.wei@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r-- | recipes-containers/docker/docker_git.bb | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb index 89a0aa43..46321b4b 100644 --- a/recipes-containers/docker/docker_git.bb +++ b/recipes-containers/docker/docker_git.bb | |||
@@ -79,6 +79,7 @@ do_compile() { | |||
79 | mkdir -p .gopath/src/"$(dirname "${DOCKER_PKG}")" | 79 | mkdir -p .gopath/src/"$(dirname "${DOCKER_PKG}")" |
80 | ln -sf ../../../.. .gopath/src/"${DOCKER_PKG}" | 80 | ln -sf ../../../.. .gopath/src/"${DOCKER_PKG}" |
81 | export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" | 81 | export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" |
82 | export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go" | ||
82 | cd - | 83 | cd - |
83 | 84 | ||
84 | # Pass the needed cflags/ldflags so that cgo | 85 | # Pass the needed cflags/ldflags so that cgo |