diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-10-21 18:59:33 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-10-21 19:17:56 -0400 |
commit | 0429ecbcd86d0fb6679a1b453d9db4ba0562269e (patch) | |
tree | 9980b88d0be9a375ae06af01f44894ba28f0fbd1 | |
parent | abf248bd38bc25ff67fd30b0f0ebd5c9764324b0 (diff) | |
download | meta-virtualization-0429ecbcd86d0fb6679a1b453d9db4ba0562269e.tar.gz |
podman: add rdepend on nsenter
Podman requires nsenter (for obvious reasons) .. and while this
dependency is normally satisfied on images (via busybox), it is
possible to build a minimal container image that excludes
busybox .. and hence will not have nsenter present.
Rather than making this a hard rdepends on util-linux-nsenter,
we use a variable: VIRTUAL-RUNTIME_base-utils-nsenter, which
can either be set to busybox or util-linux-nsenter (the current
default).
The VIRTUAL-RUNTIME_base-utils- format follows similarly named
OEcore providers and variables .. which the exception that there
is no entry in the preferred providers file there, and there's
no package created called busybox-nsenter (but perhaps there
could be in the future).
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/podman/podman_git.bb | 6 |
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-containers/podman/podman_git.bb b/recipes-containers/podman/podman_git.bb index 0261ffa9..a77f23b5 100644 --- a/recipes-containers/podman/podman_git.bb +++ b/recipes-containers/podman/podman_git.bb | |||
@@ -109,6 +109,10 @@ FILES:${PN} += " \ | |||
109 | 109 | ||
110 | SYSTEMD_SERVICE:${PN} = "podman.service podman.socket" | 110 | SYSTEMD_SERVICE:${PN} = "podman.service podman.socket" |
111 | 111 | ||
112 | RDEPENDS:${PN} += "conmon virtual-runc iptables cni skopeo" | 112 | # The other option for this is "busybox", since meta-virt ensures |
113 | # that busybox is configured with nsenter | ||
114 | VIRTUAL-RUNTIME_base-utils-nsenter ?= "util-linux-nsenter" | ||
115 | |||
116 | RDEPENDS:${PN} += "conmon virtual-runc iptables cni skopeo ${VIRTUAL-RUNTIME_base-utils-nsenter}" | ||
113 | RRECOMMENDS:${PN} += "slirp4netns kernel-module-xt-masquerade kernel-module-xt-comment" | 117 | RRECOMMENDS:${PN} += "slirp4netns kernel-module-xt-masquerade kernel-module-xt-comment" |
114 | RCONFLICTS:${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'docker', 'docker', '', d)}" | 118 | RCONFLICTS:${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'docker', 'docker', '', d)}" |