diff options
author | Ming Liu <ming.liu@toradex.com> | 2020-06-26 18:15:02 +0200 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-07-01 12:43:16 -0400 |
commit | 04f1f54b0446b4409225318eb98fa003bdbdf39d (patch) | |
tree | 0fcf29de5716d6444578b3f197424025207691ec | |
parent | a1d06c7470c7a1e57c88fc2479559ace4b67db26 (diff) | |
download | meta-virtualization-04f1f54b0446b4409225318eb98fa003bdbdf39d.tar.gz |
python3-docker: uprev 4.2.0 > 4.2.1
Merge python-docker.inc to python3-docker_4.2.1.bb since we have
dropped python-docker recipe.
Signed-off-by: Ming Liu <ming.liu@toradex.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-devtools/python/python-docker.inc | 15 | ||||
-rw-r--r-- | recipes-devtools/python/python3-docker_4.2.0.bb | 3 | ||||
-rw-r--r-- | recipes-devtools/python/python3-docker_4.2.1.bb | 19 |
3 files changed, 19 insertions, 18 deletions
diff --git a/recipes-devtools/python/python-docker.inc b/recipes-devtools/python/python-docker.inc deleted file mode 100644 index 884fb64e..00000000 --- a/recipes-devtools/python/python-docker.inc +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | SUMMARY = "A Python library for the Docker Engine API." | ||
2 | HOMEPAGE = "https://github.com/docker/docker-py" | ||
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=34f3846f940453127309b920eeb89660" | ||
5 | |||
6 | SRC_URI[md5sum] = "19f803f6a7113301daa5d82a2d1d0c30" | ||
7 | SRC_URI[sha256sum] = "ddae66620ab5f4bce769f64bcd7934f880c8abe6aa50986298db56735d0f722e" | ||
8 | |||
9 | RDEPENDS_${PN} += " \ | ||
10 | ${PYTHON_PN}-misc \ | ||
11 | ${PYTHON_PN}-six \ | ||
12 | ${PYTHON_PN}-docker-pycreds \ | ||
13 | ${PYTHON_PN}-requests \ | ||
14 | ${PYTHON_PN}-websocket-client \ | ||
15 | " | ||
diff --git a/recipes-devtools/python/python3-docker_4.2.0.bb b/recipes-devtools/python/python3-docker_4.2.0.bb deleted file mode 100644 index 052cbe8a..00000000 --- a/recipes-devtools/python/python3-docker_4.2.0.bb +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | inherit pypi setuptools3 | ||
2 | DEPENDS += "${PYTHON_PN}-pip-native" | ||
3 | require python-docker.inc | ||
diff --git a/recipes-devtools/python/python3-docker_4.2.1.bb b/recipes-devtools/python/python3-docker_4.2.1.bb new file mode 100644 index 00000000..32b24eb3 --- /dev/null +++ b/recipes-devtools/python/python3-docker_4.2.1.bb | |||
@@ -0,0 +1,19 @@ | |||
1 | SUMMARY = "A Python library for the Docker Engine API." | ||
2 | HOMEPAGE = "https://github.com/docker/docker-py" | ||
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=34f3846f940453127309b920eeb89660" | ||
5 | |||
6 | SRC_URI[md5sum] = "65111a1e4a2ab83d2ba104cdb17f1326" | ||
7 | SRC_URI[sha256sum] = "380a20d38fbfaa872e96ee4d0d23ad9beb0f9ed57ff1c30653cbeb0c9c0964f2" | ||
8 | |||
9 | DEPENDS += "${PYTHON_PN}-pip-native" | ||
10 | |||
11 | RDEPENDS_${PN} += " \ | ||
12 | ${PYTHON_PN}-misc \ | ||
13 | ${PYTHON_PN}-six \ | ||
14 | ${PYTHON_PN}-docker-pycreds \ | ||
15 | ${PYTHON_PN}-requests \ | ||
16 | ${PYTHON_PN}-websocket-client \ | ||
17 | " | ||
18 | |||
19 | inherit pypi setuptools3 | ||