summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan.rossi@xilinx.com>2015-01-06 10:27:58 +1000
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-02-20 21:17:04 -0500
commit06a8cc10d8fd08b572c55aabc61e47cd19c0d842 (patch)
tree98813fb402c1e3584056c7877931a2e3d67ecf2d
parent46504b199990be817d194b06c86b77e77bda7e2a (diff)
downloadmeta-virtualization-06a8cc10d8fd08b572c55aabc61e47cd19c0d842.tar.gz
xen-*image-minimal: Setup conditional based on MACHINE_FEATURES
* Conditionally add packages to the image depending on whether the machine supports the respective feature Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
-rw-r--r--recipes-extended/images/xen-guest-image-minimal.bb2
-rw-r--r--recipes-extended/images/xen-image-minimal.bb4
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes-extended/images/xen-guest-image-minimal.bb b/recipes-extended/images/xen-guest-image-minimal.bb
index bcac4d79..f13940ce 100644
--- a/recipes-extended/images/xen-guest-image-minimal.bb
+++ b/recipes-extended/images/xen-guest-image-minimal.bb
@@ -4,7 +4,7 @@ inherit core-image
4 4
5IMAGE_INSTALL += " \ 5IMAGE_INSTALL += " \
6 packagegroup-core-boot \ 6 packagegroup-core-boot \
7 kernel-module-xen-acpi-processor \ 7 ${@bb.utils.contains('MACHINE_FEATURES', 'acpi', 'kernel-module-xen-acpi-processor', '', d)} \
8 " 8 "
9 9
10IMAGE_INSTALL += "${@base_contains('DISTRO_FEATURES', 'x11', ' xf86-video-fbdev', '', d)}" 10IMAGE_INSTALL += "${@base_contains('DISTRO_FEATURES', 'x11', ' xf86-video-fbdev', '', d)}"
diff --git a/recipes-extended/images/xen-image-minimal.bb b/recipes-extended/images/xen-image-minimal.bb
index 13917c5c..aed0526c 100644
--- a/recipes-extended/images/xen-image-minimal.bb
+++ b/recipes-extended/images/xen-image-minimal.bb
@@ -5,12 +5,12 @@ INITRD_IMAGE = "core-image-minimal-initramfs"
5IMAGE_INSTALL += " \ 5IMAGE_INSTALL += " \
6 packagegroup-core-boot \ 6 packagegroup-core-boot \
7 packagegroup-core-ssh-openssh \ 7 packagegroup-core-ssh-openssh \
8 kernel-module-xen-acpi-processor \ 8 ${@bb.utils.contains('MACHINE_FEATURES', 'acpi', 'kernel-module-xen-acpi-processor', '', d)} \
9 kernel-module-xen-blkback \ 9 kernel-module-xen-blkback \
10 kernel-module-xen-gntalloc \ 10 kernel-module-xen-gntalloc \
11 kernel-module-xen-gntdev \ 11 kernel-module-xen-gntdev \
12 kernel-module-xen-netback \ 12 kernel-module-xen-netback \
13 kernel-module-xen-pciback \ 13 ${@bb.utils.contains('MACHINE_FEATURES', 'pci', 'kernel-module-xen-pciback', '', d)} \
14 kernel-module-xen-wdt \ 14 kernel-module-xen-wdt \
15 xen-base \ 15 xen-base \
16 xen-qemu \ 16 xen-qemu \