summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2017-07-13 10:09:03 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-07-13 13:53:57 -0400
commit11fac209f2bb0e3b2a51a6c5304cbaa4cfeadcbe (patch)
treedd5b41a8ca7393aad51d355f0ea97da9faa5b26f
parentd2dbd7d8d25b96d5ec58c693c50eb6159b8e4c96 (diff)
downloadmeta-virtualization-11fac209f2bb0e3b2a51a6c5304cbaa4cfeadcbe.tar.gz
runc-docker: Add --console-socket=/dev/null
This allows for setting up a detached session where you do not want to set the terminal to false in the config.json. More or less this is a runtime override. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/runc/runc-docker/0001-runc-Add-console-socket-dev-null.patch33
-rw-r--r--recipes-containers/runc/runc-docker_git.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes-containers/runc/runc-docker/0001-runc-Add-console-socket-dev-null.patch b/recipes-containers/runc/runc-docker/0001-runc-Add-console-socket-dev-null.patch
new file mode 100644
index 00000000..f49adfbf
--- /dev/null
+++ b/recipes-containers/runc/runc-docker/0001-runc-Add-console-socket-dev-null.patch
@@ -0,0 +1,33 @@
1From 3fff2a3505fba1d1ff0074edff15708a77f6cfa9 Mon Sep 17 00:00:00 2001
2From: Jason Wessel <jason.wessel@windriver.com>
3Date: Wed, 12 Jul 2017 13:35:03 -0700
4Subject: [PATCH] runc: Add --console-socket=/dev/null
5
6This allows for setting up a detached session where you do not want to
7set the terminal to false in the config.json. More or less this is a
8runtime override.
9
10Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
11---
12 utils_linux.go | 5 +++++
13 1 file changed, 5 insertions(+)
14
15diff --git a/utils_linux.go b/utils_linux.go
16index 8085f7fe..e6d31b35 100644
17--- a/utils_linux.go
18+++ b/utils_linux.go
19@@ -227,6 +227,11 @@ type runner struct {
20 }
21
22 func (r *runner) run(config *specs.Process) (int, error) {
23+ if (r.consoleSocket == "/dev/null") {
24+ r.detach = false
25+ r.consoleSocket = ""
26+ config.Terminal = false
27+ }
28 if err := r.checkTerminal(config); err != nil {
29 r.destroy()
30 return -1, err
31--
322.11.0
33
diff --git a/recipes-containers/runc/runc-docker_git.bb b/recipes-containers/runc/runc-docker_git.bb
index 194d6612..f412c84b 100644
--- a/recipes-containers/runc/runc-docker_git.bb
+++ b/recipes-containers/runc/runc-docker_git.bb
@@ -7,6 +7,7 @@ SRC_URI = "git://github.com/docker/runc.git;nobranch=1;name=runc-docker \
7 file://0001-Update-to-runtime-spec-198f23f827eea397d4331d7eb048d.patch \ 7 file://0001-Update-to-runtime-spec-198f23f827eea397d4331d7eb048d.patch \
8 file://0002-Remove-Platform-as-no-longer-in-OCI-spec.patch \ 8 file://0002-Remove-Platform-as-no-longer-in-OCI-spec.patch \
9 file://0003-Update-memory-specs-to-use-int64-not-uint64.patch \ 9 file://0003-Update-memory-specs-to-use-int64-not-uint64.patch \
10 file://0001-runc-Add-console-socket-dev-null.patch \
10 " 11 "
11 12
12RUNC_VERSION = "1.0.0-rc3" 13RUNC_VERSION = "1.0.0-rc3"