diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2019-03-21 09:01:32 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2019-03-21 09:49:12 -0400 |
commit | 1c424ca4012f43d3f0f94f62118fa7b6bafdf52f (patch) | |
tree | ad045ef77cbed3c38ec8b32146e7b6cb3765b43a | |
parent | 9ce802c52a5325a2caa3b83db03e47bf1ade7bcb (diff) | |
download | meta-virtualization-1c424ca4012f43d3f0f94f62118fa7b6bafdf52f.tar.gz |
docker-ce: fixup redepends and clean rsuggests
With the 5.0 kernel and docker 18.09 you can run into issues
pulling from docker hub due to an invalid/unknown certificate.
We fix that by adding ca-certifcates as a runtime dependency.
There can also be isuses setting up the network bridge, so we
add bridge-utils to the rdepends.
Finally, no one wants rt-tests and lxc when installing docker,
so we drop them from the rsuggests.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/docker/docker-ce_git.bb | 3 |
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-containers/docker/docker-ce_git.bb b/recipes-containers/docker/docker-ce_git.bb index 8e972939..a0d774ad 100644 --- a/recipes-containers/docker/docker-ce_git.bb +++ b/recipes-containers/docker/docker-ce_git.bb | |||
@@ -65,11 +65,12 @@ DEPENDS_append_class-target = " lvm2" | |||
65 | RDEPENDS_${PN} = "util-linux util-linux-unshare iptables \ | 65 | RDEPENDS_${PN} = "util-linux util-linux-unshare iptables \ |
66 | ${@bb.utils.contains('DISTRO_FEATURES', 'aufs', 'aufs-util', '', d)} \ | 66 | ${@bb.utils.contains('DISTRO_FEATURES', 'aufs', 'aufs-util', '', d)} \ |
67 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '', 'cgroup-lite', d)} \ | 67 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '', 'cgroup-lite', d)} \ |
68 | bridge-utils \ | ||
69 | ca-certificates \ | ||
68 | " | 70 | " |
69 | RDEPENDS_${PN} += "virtual/containerd virtual/runc" | 71 | RDEPENDS_${PN} += "virtual/containerd virtual/runc" |
70 | 72 | ||
71 | RRECOMMENDS_${PN} = "kernel-module-dm-thin-pool kernel-module-nf-nat" | 73 | RRECOMMENDS_${PN} = "kernel-module-dm-thin-pool kernel-module-nf-nat" |
72 | RSUGGESTS_${PN} = "lxc rt-tests" | ||
73 | DOCKER_PKG="github.com/docker/docker" | 74 | DOCKER_PKG="github.com/docker/docker" |
74 | 75 | ||
75 | inherit systemd update-rc.d | 76 | inherit systemd update-rc.d |