diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-09-06 10:28:21 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-09-06 10:57:17 -0400 |
commit | 263e4d3d4e36ccdbd660ba252f5eee6309a130cf (patch) | |
tree | bd51595be193bdc54369e9ec75c2718429deaf0b | |
parent | 798aeaee78224f861383c7faf35ef906306ad00f (diff) | |
download | meta-virtualization-263e4d3d4e36ccdbd660ba252f5eee6309a130cf.tar.gz |
virtual/runc: don't rprovide virtual/
Similar to the oe-core commit:
commit 93ac180d8c389f16964bce8bd5538d9389e970e6
Author: Michael Opdenacker <michael.opdenacker@bootlin.com>
Date: Wed Sep 1 11:20:20 2021 +0200
meta: stop using "virtual/" in RPROVIDES and RDEPENDS
Fixes [YOCTO #14538]
Recipes shouldn't use the "virtual/" string in RPROVIDES and RDEPENDS.
That's confusing because "virtual/" has no special meaning in
RPROVIDES and RDEPENDS (unlike in PROVIDES and DEPENDS).
Instead, using "virtual-" instead of "virtual/"
as already done in the glibc recipe.
We stop rproviding virtual/runc to keep the namespace clean.
There aren't many users of this virtual provides, but we keep
it around (for now) to maintain compatibility.
At the same time we convert the RPROVIDES to virtual-runc, to keep
it available and consistent with oe-core use virtual-libc, etc.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/containerd/containerd-opencontainers_git.bb | 2 | ||||
-rw-r--r-- | recipes-containers/cri-o/cri-o_git.bb | 2 | ||||
-rw-r--r-- | recipes-containers/docker/docker.inc | 2 | ||||
-rw-r--r-- | recipes-containers/podman/podman_git.bb | 2 | ||||
-rw-r--r-- | recipes-containers/runc/runc.inc | 2 | ||||
-rw-r--r-- | recipes-core/packagegroups/packagegroup-container.bb | 2 |
6 files changed, 6 insertions, 6 deletions
diff --git a/recipes-containers/containerd/containerd-opencontainers_git.bb b/recipes-containers/containerd/containerd-opencontainers_git.bb index 03885821..2169f121 100644 --- a/recipes-containers/containerd/containerd-opencontainers_git.bb +++ b/recipes-containers/containerd/containerd-opencontainers_git.bb | |||
@@ -122,6 +122,6 @@ INSANE_SKIP:${PN} += "ldflags already-stripped" | |||
122 | 122 | ||
123 | COMPATIBLE_HOST = "^(?!(qemu)?mips).*" | 123 | COMPATIBLE_HOST = "^(?!(qemu)?mips).*" |
124 | 124 | ||
125 | RDEPENDS:${BPN} += " virtual/runc" | 125 | RDEPENDS:${BPN} += " virtual-runc" |
126 | 126 | ||
127 | CVE_PRODUCT = "containerd" | 127 | CVE_PRODUCT = "containerd" |
diff --git a/recipes-containers/cri-o/cri-o_git.bb b/recipes-containers/cri-o/cri-o_git.bb index 34599e7f..306f23e8 100644 --- a/recipes-containers/cri-o/cri-o_git.bb +++ b/recipes-containers/cri-o/cri-o_git.bb | |||
@@ -50,7 +50,7 @@ PNBLACKLIST[cri-o] ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'security', bb | |||
50 | 50 | ||
51 | PACKAGES =+ "${PN}-config" | 51 | PACKAGES =+ "${PN}-config" |
52 | 52 | ||
53 | RDEPENDS:${PN} += " virtual/containerd virtual/runc" | 53 | RDEPENDS:${PN} += " virtual/containerd virtual-runc" |
54 | RDEPENDS:${PN} += " e2fsprogs-mke2fs conmon util-linux iptables conntrack-tools" | 54 | RDEPENDS:${PN} += " e2fsprogs-mke2fs conmon util-linux iptables conntrack-tools" |
55 | 55 | ||
56 | inherit systemd | 56 | inherit systemd |
diff --git a/recipes-containers/docker/docker.inc b/recipes-containers/docker/docker.inc index d22aae1e..3c3a0ca7 100644 --- a/recipes-containers/docker/docker.inc +++ b/recipes-containers/docker/docker.inc | |||
@@ -27,7 +27,7 @@ RDEPENDS:${PN} = "util-linux util-linux-unshare iptables \ | |||
27 | bridge-utils \ | 27 | bridge-utils \ |
28 | ca-certificates \ | 28 | ca-certificates \ |
29 | " | 29 | " |
30 | RDEPENDS:${PN} += "virtual/containerd virtual/runc" | 30 | RDEPENDS:${PN} += "virtual/containerd virtual-runc" |
31 | 31 | ||
32 | RRECOMMENDS:${PN} = "kernel-module-dm-thin-pool kernel-module-nf-nat kernel-module-nf-conntrack-netlink kernel-module-xt-addrtype kernel-module-xt-masquerade" | 32 | RRECOMMENDS:${PN} = "kernel-module-dm-thin-pool kernel-module-nf-nat kernel-module-nf-conntrack-netlink kernel-module-xt-addrtype kernel-module-xt-masquerade" |
33 | 33 | ||
diff --git a/recipes-containers/podman/podman_git.bb b/recipes-containers/podman/podman_git.bb index ab9aef12..3f6896be 100644 --- a/recipes-containers/podman/podman_git.bb +++ b/recipes-containers/podman/podman_git.bb | |||
@@ -109,6 +109,6 @@ FILES:${PN} += " \ | |||
109 | 109 | ||
110 | SYSTEMD_SERVICE:${PN} = "podman.service podman.socket" | 110 | SYSTEMD_SERVICE:${PN} = "podman.service podman.socket" |
111 | 111 | ||
112 | RDEPENDS:${PN} += "conmon virtual/runc iptables cni skopeo" | 112 | RDEPENDS:${PN} += "conmon virtual-runc iptables cni skopeo" |
113 | RRECOMMENDS:${PN} += "slirp4netns kernel-module-xt-masquerade kernel-module-xt-comment" | 113 | RRECOMMENDS:${PN} += "slirp4netns kernel-module-xt-masquerade kernel-module-xt-comment" |
114 | RCONFLICTS:${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'docker', 'docker', '', d)}" | 114 | RCONFLICTS:${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'docker', 'docker', '', d)}" |
diff --git a/recipes-containers/runc/runc.inc b/recipes-containers/runc/runc.inc index 486ee176..c8e74273 100644 --- a/recipes-containers/runc/runc.inc +++ b/recipes-containers/runc/runc.inc | |||
@@ -26,7 +26,7 @@ PACKAGECONFIG ??= "static \ | |||
26 | 26 | ||
27 | 27 | ||
28 | PROVIDES += "virtual/runc" | 28 | PROVIDES += "virtual/runc" |
29 | RPROVIDES:${PN} = "virtual/runc" | 29 | RPROVIDES:${PN} = "virtual-runc" |
30 | 30 | ||
31 | GO_IMPORT = "import" | 31 | GO_IMPORT = "import" |
32 | 32 | ||
diff --git a/recipes-core/packagegroups/packagegroup-container.bb b/recipes-core/packagegroups/packagegroup-container.bb index 82d4a2e7..5d87e8ec 100644 --- a/recipes-core/packagegroups/packagegroup-container.bb +++ b/recipes-core/packagegroups/packagegroup-container.bb | |||
@@ -35,7 +35,7 @@ RDEPENDS:packagegroup-podman = " \ | |||
35 | " | 35 | " |
36 | 36 | ||
37 | RDEPENDS:packagegroup-oci = " \ | 37 | RDEPENDS:packagegroup-oci = " \ |
38 | virtual/runc \ | 38 | virtual-runc \ |
39 | oci-systemd-hook \ | 39 | oci-systemd-hook \ |
40 | oci-runtime-tools \ | 40 | oci-runtime-tools \ |
41 | oci-image-tools \ | 41 | oci-image-tools \ |