summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-02-24 13:50:05 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-02-24 13:50:05 -0500
commit2eda91539fcdbd755010b8be165d7fd937485fd3 (patch)
treede008c9f09157123cb1b1d00c43e81cf9f08544b
parentec73ce93c925c802f76b467b051cf6cc6a1ab335 (diff)
downloadmeta-virtualization-2eda91539fcdbd755010b8be165d7fd937485fd3.tar.gz
crun: update to 0.18
Bumping to the release, which pulls in the 808420e release: distribute CHECKSUMS file c2b0064 build-aux: provide arm build without systemd 7cc03f7 .gitignore: update file f5274bd NEWS: tag 0.18 94e8364 src: add missing definitions baed691 libocispec: sync from upstream 8d0ebf6 Add arm64 static binary build b66d5d9 tests: fix make check in a user namespace e10205e linux: remove temporary mount logic 7819f4c linux: use targetfd for move_mount 891cd3c linux: use safe_openat for masked/readonly paths 6c5577f linux: use new function 9aa264d utils: add function to safely create and open 436daef src: add function to cleanup container struct c955ece src: pull function out 7bd51a0 build: check for linux/openat2.h dcb1914 utils: add function to remove initial slashes a1c958c utils: memoize check result 25c6f07 container: rename function to get_root_in_the_userns f08bd31 src: fix leak of the descriptors buffer df88061 tests: disable more Podman flaky tests 052bab7 utils: set HOME to root if the user not found efe35f1 linux: ignore ENOSYS on keyctl 1b65163 tests: enable asan sanitizer a0f322a tests: build init always statically a656698 configure.ac: allow to disable dl support 6adb26b tests: disable hooks_stdin for oci-validation 06199c7 tests: update to podman 3.0 bc888b9 tests: disable podman pull test f1373f9 tests: install crun under /usr/bin 257f442 Fix permission error when using both user namespaces & NOTIFY_SOCKET 617a212 cgroup: skip +cpu on EINVAL in cgroup root b6ac8de linux: use safe_openat for tmpcopyup 2d1f910 utils: avoid reopening the root during lookup 3ce74e8 utils: fix symlink lookup cbb67ae container: set working directory for libkrun df01709 seccomp: custom annotation to load raw bpf b229dca linux: refactor allocate_tmp_mounts 68bb50f linux: disable temporary mounts with [r]slave d6ae36b libocispec: update from upstream 487e792 github: enable clang-format checks 61d6844 src: run make clang-format 1d559d0 clang-format: change ColumnLimit to 0 643d05b linux: disable temporary mounts with [r]shared de6082f cgroup: fix conversion from blkio to io 1db8312 Update nix pin with `make nixpkgs` 540444c Makefile.am: crun depends on libocispec.la 1df96e5 linux: fix build without CLONE_NEWCGROUP Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/crun/crun_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-containers/crun/crun_git.bb b/recipes-containers/crun/crun_git.bb
index e4f886c4..18d0c722 100644
--- a/recipes-containers/crun/crun_git.bb
+++ b/recipes-containers/crun/crun_git.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4PRIORITY = "optional" 4PRIORITY = "optional"
5 5
6SRCREV_crun = "0e9229ae34caaebcb86f1fde18de3acaf18c6d9a" 6SRCREV_crun = "858ff2f605983ed420b09fd716c9c8e0cee5c174"
7SRCREV_libocispec = "ece5f6aede6488396f9c84bc985df09f95204e1d" 7SRCREV_libocispec = "ece5f6aede6488396f9c84bc985df09f95204e1d"
8SRCREV_ispec = "79b036d80240ae530a8de15e1d21c7ab9292c693" 8SRCREV_ispec = "79b036d80240ae530a8de15e1d21c7ab9292c693"
9SRCREV_rspec = "7413a7f753e1bd9a6a9c6dc7f96f55888cbbd476" 9SRCREV_rspec = "7413a7f753e1bd9a6a9c6dc7f96f55888cbbd476"
@@ -15,7 +15,7 @@ SRC_URI = "git://github.com/containers/crun.git;branch=master;name=crun \
15 git://github.com/opencontainers/image-spec.git;branch=master;name=ispec;destsuffix=git/libocispec/image-spec \ 15 git://github.com/opencontainers/image-spec.git;branch=master;name=ispec;destsuffix=git/libocispec/image-spec \
16 " 16 "
17 17
18PV = "0.17+git${SRCREV_crun}" 18PV = "0.18+git${SRCREV_crun}"
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21inherit autotools-brokensep pkgconfig 21inherit autotools-brokensep pkgconfig