diff options
author | Mark Asselstine <mark.asselstine@windriver.com> | 2017-02-08 12:53:27 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2017-02-09 09:14:27 -0500 |
commit | 2ef58c264b21d36255c2754abef43e0bee764ae8 (patch) | |
tree | da33d2e3983236716c57d0a1fc79075a53731f42 | |
parent | d475adc71ba14740e1fe9c19493df7275d0737c4 (diff) | |
download | meta-virtualization-2ef58c264b21d36255c2754abef43e0bee764ae8.tar.gz |
go-cross: add ${TARGET_ARCH} to PN
Since we are building a cross tool which produces something which is
ARCH specific we should stick to the <toolname>-cross-<arch> naming
convention. A variant of this patch has been floating around for a
while but with the changes around per recipe sysroots, distributed
builds, shared builds... we are best served to adopt this convention
now.
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r-- | recipes-containers/containerd/containerd_git.bb | 2 | ||||
-rw-r--r-- | recipes-containers/docker/docker_git.bb | 2 | ||||
-rw-r--r-- | recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb | 2 | ||||
-rw-r--r-- | recipes-containers/riddler/riddler_git.bb | 2 | ||||
-rw-r--r-- | recipes-containers/runc/runc_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/go-cross/go-cross.inc | 3 | ||||
-rw-r--r-- | recipes-networking/netns/netns_git.bb | 2 |
7 files changed, 9 insertions, 6 deletions
diff --git a/recipes-containers/containerd/containerd_git.bb b/recipes-containers/containerd/containerd_git.bb index a5062e0b..c2573556 100644 --- a/recipes-containers/containerd/containerd_git.bb +++ b/recipes-containers/containerd/containerd_git.bb | |||
@@ -18,7 +18,7 @@ S = "${WORKDIR}/git" | |||
18 | CONTAINERD_VERSION = "0.2.2" | 18 | CONTAINERD_VERSION = "0.2.2" |
19 | PV = "${CONTAINERD_VERSION}+git${SRCREV}" | 19 | PV = "${CONTAINERD_VERSION}+git${SRCREV}" |
20 | 20 | ||
21 | DEPENDS = "go-cross \ | 21 | DEPENDS = "go-cross-${TARGET_ARCH} \ |
22 | " | 22 | " |
23 | 23 | ||
24 | RRECOMMENDS_${PN} = "lxc docker" | 24 | RRECOMMENDS_${PN} = "lxc docker" |
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb index 6805d786..75da1861 100644 --- a/recipes-containers/docker/docker_git.bb +++ b/recipes-containers/docker/docker_git.bb | |||
@@ -37,7 +37,7 @@ DOCKER_VERSION = "1.13.0" | |||
37 | PV = "${DOCKER_VERSION}+git${SRCREV}" | 37 | PV = "${DOCKER_VERSION}+git${SRCREV}" |
38 | 38 | ||
39 | DEPENDS = " \ | 39 | DEPENDS = " \ |
40 | go-cross \ | 40 | go-cross-${TARGET_ARCH} \ |
41 | go-cli \ | 41 | go-cli \ |
42 | go-pty \ | 42 | go-pty \ |
43 | go-context \ | 43 | go-context \ |
diff --git a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb index dac2d133..7e5af380 100644 --- a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb +++ b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb | |||
@@ -2,7 +2,7 @@ HOMEPAGE = "https://github.com/opencontainers/runtime-tools" | |||
2 | SUMMARY = "oci-runtime-tool is a collection of tools for working with the OCI runtime specification" | 2 | SUMMARY = "oci-runtime-tool is a collection of tools for working with the OCI runtime specification" |
3 | LICENSE = "GPLv2" | 3 | LICENSE = "GPLv2" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b355a61a394a504dacde901c958f662c" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b355a61a394a504dacde901c958f662c" |
5 | DEPENDS = "go-cross" | 5 | DEPENDS = "go-cross-${TARGET_ARCH}" |
6 | 6 | ||
7 | SRC_URI = "git://github.com/opencontainers/runtime-tools.git" | 7 | SRC_URI = "git://github.com/opencontainers/runtime-tools.git" |
8 | 8 | ||
diff --git a/recipes-containers/riddler/riddler_git.bb b/recipes-containers/riddler/riddler_git.bb index 361e9d24..49e8aa01 100644 --- a/recipes-containers/riddler/riddler_git.bb +++ b/recipes-containers/riddler/riddler_git.bb | |||
@@ -2,7 +2,7 @@ HOMEPAGE = "https://github.com/jfrazelle/riddler" | |||
2 | SUMMARY = "Convert `docker inspect` to opencontainers (OCI compatible) runc spec." | 2 | SUMMARY = "Convert `docker inspect` to opencontainers (OCI compatible) runc spec." |
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1" |
5 | DEPENDS = "go-cross" | 5 | DEPENDS = "go-cross-${TARGET_ARCH}" |
6 | 6 | ||
7 | SRC_URI = "git://github.com/jfrazelle/riddler;branch=master" | 7 | SRC_URI = "git://github.com/jfrazelle/riddler;branch=master" |
8 | SRCREV = "23befa0b232877b5b502b828e24161d801bd67f6" | 8 | SRCREV = "23befa0b232877b5b502b828e24161d801bd67f6" |
diff --git a/recipes-containers/runc/runc_git.bb b/recipes-containers/runc/runc_git.bb index ed9a32e4..23c0094d 100644 --- a/recipes-containers/runc/runc_git.bb +++ b/recipes-containers/runc/runc_git.bb | |||
@@ -18,7 +18,7 @@ S = "${WORKDIR}/git" | |||
18 | RUNC_VERSION = "1.0.0-rc1" | 18 | RUNC_VERSION = "1.0.0-rc1" |
19 | PV = "${RUNC_VERSION}+git${SRCREV}" | 19 | PV = "${RUNC_VERSION}+git${SRCREV}" |
20 | 20 | ||
21 | DEPENDS = "go-cross \ | 21 | DEPENDS = "go-cross-${TARGET_ARCH} \ |
22 | " | 22 | " |
23 | RRECOMMENDS_${PN} = "lxc docker" | 23 | RRECOMMENDS_${PN} = "lxc docker" |
24 | 24 | ||
diff --git a/recipes-devtools/go-cross/go-cross.inc b/recipes-devtools/go-cross/go-cross.inc index 857fbd54..a7117bcd 100644 --- a/recipes-devtools/go-cross/go-cross.inc +++ b/recipes-devtools/go-cross/go-cross.inc | |||
@@ -1,5 +1,8 @@ | |||
1 | inherit cross | 1 | inherit cross |
2 | 2 | ||
3 | # Produces target arch specific code so we should reflect this in the PN | ||
4 | PN = "go-cross-${TARGET_ARCH}" | ||
5 | |||
3 | # libgcc is required for the target specific libraries to build properly | 6 | # libgcc is required for the target specific libraries to build properly |
4 | DEPENDS += "go-initial-native libgcc virtual/${TARGET_PREFIX}gcc" | 7 | DEPENDS += "go-initial-native libgcc virtual/${TARGET_PREFIX}gcc" |
5 | 8 | ||
diff --git a/recipes-networking/netns/netns_git.bb b/recipes-networking/netns/netns_git.bb index 073022e5..247b37d6 100644 --- a/recipes-networking/netns/netns_git.bb +++ b/recipes-networking/netns/netns_git.bb | |||
@@ -2,7 +2,7 @@ HOMEPAGE = "https://github.com/jfrazelle/netns" | |||
2 | SUMMARY = "Runc hook for setting up default bridge networking." | 2 | SUMMARY = "Runc hook for setting up default bridge networking." |
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1" |
5 | DEPENDS = "go-cross" | 5 | DEPENDS = "go-cross-${TARGET_ARCH}" |
6 | 6 | ||
7 | SRC_URI = "git://github.com/jfrazelle/netns;branch=master" | 7 | SRC_URI = "git://github.com/jfrazelle/netns;branch=master" |
8 | SRCREV = "2804050eeab661bfa75c3aa06bdcf60273b02ca7" | 8 | SRCREV = "2804050eeab661bfa75c3aa06bdcf60273b02ca7" |