summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2019-12-26 12:57:36 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-12-29 22:09:03 -0500
commit30e3de60e7f803e332f78ee8c41179cf0336c27c (patch)
tree4fd1962bbc6fed7f8880fa8b7452206827688c2b
parent5fb77ae4c4e1015e40257f9e59e16c497e30c53c (diff)
downloadmeta-virtualization-30e3de60e7f803e332f78ee8c41179cf0336c27c.tar.gz
nagios-nrpe: fix compile error when packageconfig ssl enabled
It fails to compile nagios-nrpe when packageconfig ssl enabled: | ./nrpe.c:45:12: fatal error: ../include/dh.h: No such file or directory | 45 | # include "../include/dh.h" | | ^~~~~~~~~~~~~~~~~ | compilation terminated. Header file include/dh.h is created by native openssl called by configure script. If no native openssl exists, no header file is created. Add openssl-native to dependency for packageconfig ssl. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-extended/nagios/nagios-nrpe_3.2.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-extended/nagios/nagios-nrpe_3.2.1.bb b/recipes-extended/nagios/nagios-nrpe_3.2.1.bb
index 04917f73..9e1f02c2 100644
--- a/recipes-extended/nagios/nagios-nrpe_3.2.1.bb
+++ b/recipes-extended/nagios/nagios-nrpe_3.2.1.bb
@@ -39,7 +39,7 @@ EXTRA_OECONF_SSL = "--with-ssl=${STAGING_DIR_HOST} \
39 --with-ssl-lib=${STAGING_DIR_HOST}${libdir} \ 39 --with-ssl-lib=${STAGING_DIR_HOST}${libdir} \
40" 40"
41 41
42PACKAGECONFIG[ssl] = "${EXTRA_OECONF_SSL},--disable-ssl,openssl," 42PACKAGECONFIG[ssl] = "${EXTRA_OECONF_SSL},--disable-ssl,openssl-native openssl,"
43PACKAGECONFIG[cmdargs] = "--enable-command-args,--disable-command-args,," 43PACKAGECONFIG[cmdargs] = "--enable-command-args,--disable-command-args,,"
44PACKAGECONFIG[bashcomp] = "--enable-bash-command-substitution,--disable-bash-command-substitution,," 44PACKAGECONFIG[bashcomp] = "--enable-bash-command-substitution,--disable-bash-command-substitution,,"
45 45