diff options
author | Bruce Ashfield <bruce.ashfield@xilinx.com> | 2019-12-17 17:34:23 -0800 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-03-11 12:20:04 -0400 |
commit | 40f158dbf8d017a5d2c6c5ce13f476adb9b10589 (patch) | |
tree | 6deec659b27bf622a0e7a15dd4014f28be74c552 | |
parent | 4ff05c1bc7313743b572b116b37c893b69c68971 (diff) | |
download | meta-virtualization-40f158dbf8d017a5d2c6c5ce13f476adb9b10589.tar.gz |
busybox: vmsep distro feature modifications
If "vmsep" is in distro features, we need to configure busybox
as a static build. This allows for it to be used as party of an
initrd.
We also ensure that the installer support is added to busybox, so
it can be installed to the initrd via: busybox --install
Signed-off-by: Bruce Ashfield <bruce.ashfield@xilinx.com>
-rw-r--r-- | recipes-core/busybox/busybox/static.cfg | 4 | ||||
-rw-r--r-- | recipes-core/busybox/busybox_%.bbappend | 2 | ||||
-rw-r--r-- | recipes-core/busybox/busybox_vmsep.inc | 8 |
3 files changed, 14 insertions, 0 deletions
diff --git a/recipes-core/busybox/busybox/static.cfg b/recipes-core/busybox/busybox/static.cfg new file mode 100644 index 00000000..72079a1c --- /dev/null +++ b/recipes-core/busybox/busybox/static.cfg | |||
@@ -0,0 +1,4 @@ | |||
1 | CONFIG_STATIC=y | ||
2 | CONFIG_INSTALL=y | ||
3 | CONFIG_FEATURE_INSTALLER=y | ||
4 | |||
diff --git a/recipes-core/busybox/busybox_%.bbappend b/recipes-core/busybox/busybox_%.bbappend index 617caccb..3d39bba3 100644 --- a/recipes-core/busybox/busybox_%.bbappend +++ b/recipes-core/busybox/busybox_%.bbappend | |||
@@ -1 +1,3 @@ | |||
1 | require ${@bb.utils.contains('DISTRO_FEATURES', 'virtualization', '${BPN}_virtualization.inc', '', d)} | 1 | require ${@bb.utils.contains('DISTRO_FEATURES', 'virtualization', '${BPN}_virtualization.inc', '', d)} |
2 | require ${@bb.utils.contains('DISTRO_FEATURES', 'vmsep', '${BPN}_vmsep.inc', '', d)} | ||
3 | |||
diff --git a/recipes-core/busybox/busybox_vmsep.inc b/recipes-core/busybox/busybox_vmsep.inc new file mode 100644 index 00000000..b70a065c --- /dev/null +++ b/recipes-core/busybox/busybox_vmsep.inc | |||
@@ -0,0 +1,8 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/busybox:" | ||
2 | SRC_URI += " \ | ||
3 | file://static.cfg \ | ||
4 | " | ||
5 | |||
6 | # we do this to get the target binary available to recipes that | ||
7 | # depend on busybox | ||
8 | SYSROOT_DIRS += "/bin" | ||