summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2025-04-20 14:46:19 +0200
committerBruce Ashfield <bruce.ashfield@gmail.com>2025-04-20 21:44:19 +0000
commit428af39f51afbcab89d9a5e9b2b204c751704cfd (patch)
tree766f8abf07c11094e5a395f129378e12107724f7
parent1c98d66d20a1c381715c6ab927a7ac8c8c4c0b1a (diff)
downloadmeta-virtualization-428af39f51afbcab89d9a5e9b2b204c751704cfd.tar.gz
yq: drop uneeded do_compile_prependmaster-next
remove the do_compile:prepend(). It is not needed and removing it allows yq to be built after devtooling it. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-devtools/yq/yq_git.bb16
1 files changed, 1 insertions, 15 deletions
diff --git a/recipes-devtools/yq/yq_git.bb b/recipes-devtools/yq/yq_git.bb
index 9682ec95..363769b9 100644
--- a/recipes-devtools/yq/yq_git.bb
+++ b/recipes-devtools/yq/yq_git.bb
@@ -84,24 +84,10 @@ SRC_URI += "git://github.com/inconshreveable/mousetrap;name=mousetrap;protocol=h
84PV = "4.45.1+git" 84PV = "4.45.1+git"
85 85
86GO_IMPORT = "github.com/mikefarah/yq" 86GO_IMPORT = "github.com/mikefarah/yq"
87export GO111MODULE = "off"
87 88
88inherit go ptest 89inherit go ptest
89 90
90do_compile:prepend() {
91 # arrange for some of the golang built ins to be found
92 (
93 cd ${WORKDIR}/build/src/
94 ln -sf ${STAGING_DIR_TARGET}/${prefix}/lib/go/src/cmd/vendor/golang.org .
95
96 cd ${WORKDIR}/build/
97 ln -sf ${UNPACKDIR}/build/vendor .
98 )
99
100 # arrange for the fetched dependencies to be found
101 export GOPATH="${GOPATH}:${WORKDIR}/build/vendor/"
102 export GO111MODULE=off
103}
104
105do_install_ptest() { 91do_install_ptest() {
106 install -d ${D}${PTEST_PATH}/tests 92 install -d ${D}${PTEST_PATH}/tests
107 cp -r ${S}/src/${GO_IMPORT}/scripts/* ${D}${PTEST_PATH}/tests 93 cp -r ${S}/src/${GO_IMPORT}/scripts/* ${D}${PTEST_PATH}/tests