diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-10-06 14:16:24 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-10-06 14:16:24 -0400 |
commit | 47425c21c7314a258752004eb75c72f724c3c2e0 (patch) | |
tree | 54fc27abf8e0ecba44d3135890c8769ed3a01477 | |
parent | d898bd1ca5de7e7084f3473106300b9ffef06761 (diff) | |
download | meta-virtualization-47425c21c7314a258752004eb75c72f724c3c2e0.tar.gz |
config: make kernel meta data include more specific
Rather than only matching on the major/minor version, we should also
check that the SRC_URI contains a "type=kmeta", to indicate that a
kernel-meta data repository is available.
This allows fragment enabled kernels, that don't want to use the
main kernel meta data repository to not throw an error (when their
version matches one of the reference kernels).
This can potentially mask runtime issues (since kernel configuration
options may not be present in the final kernel), but it makes the
layer more usable, so we take the tradeoff.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-kernel/linux/linux-%.bbappend | 4 |
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-%.bbappend b/recipes-kernel/linux/linux-%.bbappend index 2a2335bc..bcd358df 100644 --- a/recipes-kernel/linux/linux-%.bbappend +++ b/recipes-kernel/linux/linux-%.bbappend | |||
@@ -4,7 +4,9 @@ | |||
4 | LINUX_MAJOR = "${@(d.getVar('LINUX_VERSION') or "x.y").split('.')[0]}" | 4 | LINUX_MAJOR = "${@(d.getVar('LINUX_VERSION') or "x.y").split('.')[0]}" |
5 | LINUX_MINOR = "${@(d.getVar('LINUX_VERSION') or "x.y").split('.')[1]}" | 5 | LINUX_MINOR = "${@(d.getVar('LINUX_VERSION') or "x.y").split('.')[1]}" |
6 | 6 | ||
7 | include ${@bb.utils.contains('DISTRO_FEATURES', 'virtualization', 'linux-yocto_${LINUX_MAJOR}.${LINUX_MINOR}_virtualization.inc', '', d)} | 7 | KERNEL_META_TYPE ?= "${@bb.utils.contains('SRC_URI', 'type=kmeta', 'yocto', '', d)}" |
8 | |||
9 | include ${@bb.utils.contains('DISTRO_FEATURES', 'virtualization', 'linux-${KERNEL_META_TYPE}_${LINUX_MAJOR}.${LINUX_MINOR}_virtualization.inc', '', d)} | ||
8 | 10 | ||
9 | 11 | ||
10 | 12 | ||