summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2014-12-03 02:41:21 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-12-03 10:19:56 -0500
commit48c1f0666b2f523845c10ae352d58a77e3cc474f (patch)
tree1826b4890668f9fb3fe9183d0ddc1d2dc893c169
parenta9bba2da4f266572bb5a514556baa352b31f6fd5 (diff)
downloadmeta-virtualization-48c1f0666b2f523845c10ae352d58a77e3cc474f.tar.gz
libvirt: add PACKAGECONFIG for audit, libcap-ng
Add PACKAGECONFIG for audit, libcap-ng, otherwise there would be warnings like below: WARN: libvirt: libvirt-virsh rdepends on audit, but it isn't a build dependency? WARN: libvirt: libvirt-virsh rdepends on libcap-ng, but it isn't a build dependency? WARN: libvirt: libvirt rdepends on audit, but it isn't a build dependency? WARN: libvirt: libvirt rdepends on libcap-ng, but it isn't a build dependency? WARN: libvirt: libvirt-libvirtd rdepends on audit, but it isn't a build dependency? WARN: libvirt: libvirt-libvirtd rdepends on libcap-ng, but it isn't a build dependency? Both audit and libcap-ng should be enabled/disabled along with selinux since all of them are from meta-selinux. Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/libvirt/libvirt_1.2.8.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-extended/libvirt/libvirt_1.2.8.bb b/recipes-extended/libvirt/libvirt_1.2.8.bb
index 57ae613e..0f4b29f0 100644
--- a/recipes-extended/libvirt/libvirt_1.2.8.bb
+++ b/recipes-extended/libvirt/libvirt_1.2.8.bb
@@ -138,7 +138,7 @@ PRIVATE_LIBS_${PN}-ptest = " \
138# full config 138# full config
139PACKAGECONFIG ??= "qemu yajl uml openvz vmware vbox esx iproute2 lxc test \ 139PACKAGECONFIG ??= "qemu yajl uml openvz vmware vbox esx iproute2 lxc test \
140 remote macvtap libvirtd netcf udev python ebtables \ 140 remote macvtap libvirtd netcf udev python ebtables \
141 ${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \ 141 ${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux audit libcap-ng', '', d)} \
142 ${@base_contains('DISTRO_FEATURES', 'xen', 'xen libxl xen-inotify', '', d)} \ 142 ${@base_contains('DISTRO_FEATURES', 'xen', 'xen libxl xen-inotify', '', d)} \
143 ${@base_contains('DISTRO_FEATURES', 'x11', 'polkit', '', d)} \ 143 ${@base_contains('DISTRO_FEATURES', 'x11', 'polkit', '', d)} \
144 " 144 "
@@ -174,6 +174,8 @@ PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl,cyrus-sasl"
174PACKAGECONFIG[iproute2] = "ac_cv_path_IP_PATH=/sbin/ip,ac_cv_path_IP_PATH=,iproute2,iproute2" 174PACKAGECONFIG[iproute2] = "ac_cv_path_IP_PATH=/sbin/ip,ac_cv_path_IP_PATH=,iproute2,iproute2"
175PACKAGECONFIG[numactl] = "--with-numactl,--without-numactl,numactl," 175PACKAGECONFIG[numactl] = "--with-numactl,--without-numactl,numactl,"
176PACKAGECONFIG[fuse] = "--with-fuse,--without-fuse,fuse," 176PACKAGECONFIG[fuse] = "--with-fuse,--without-fuse,fuse,"
177PACKAGECONFIG[audit] = "--with-audit,--without-audit,audit,"
178PACKAGECONFIG[libcap-ng] = "--with-capnp,--without-capng,libcap-ng,"
177 179
178# Enable the Python tool support 180# Enable the Python tool support
179require libvirt-python.inc 181require libvirt-python.inc