diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-06-07 17:17:56 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-07-22 22:14:24 +0000 |
commit | 498cb48b05d6e9b8d31704adb736852f37301b1c (patch) | |
tree | 9128f8f8d3565f3424e5c86620bfbd462393a594 | |
parent | 9c90d73dbcbadcff93bd77f08a41e191d9543423 (diff) | |
download | meta-virtualization-498cb48b05d6e9b8d31704adb736852f37301b1c.tar.gz |
ceph: convert to git and tox
Waiting for ceph releases means a lot of backported patches
and missing bundled dependencies.
We switch to gitsm to make our updates easier.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-extended/ceph/ceph_git.bb (renamed from recipes-extended/ceph/ceph_18.2.3.bb) | 17 |
1 files changed, 11 insertions, 6 deletions
diff --git a/recipes-extended/ceph/ceph_18.2.3.bb b/recipes-extended/ceph/ceph_git.bb index 282c265a..56160393 100644 --- a/recipes-extended/ceph/ceph_18.2.3.bb +++ b/recipes-extended/ceph/ceph_git.bb | |||
@@ -2,22 +2,23 @@ SUMMARY = "User space components of the Ceph file system" | |||
2 | LICENSE = "LGPL-2.1-only & GPL-2.0-only & Apache-2.0 & MIT" | 2 | LICENSE = "LGPL-2.1-only & GPL-2.0-only & Apache-2.0 & MIT" |
3 | LIC_FILES_CHKSUM = "file://COPYING-LGPL2.1;md5=fbc093901857fcd118f065f900982c24 \ | 3 | LIC_FILES_CHKSUM = "file://COPYING-LGPL2.1;md5=fbc093901857fcd118f065f900982c24 \ |
4 | file://COPYING-GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | 4 | file://COPYING-GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
5 | file://COPYING;md5=5351120989d78252e65dc1a2a92e3617 \ | 5 | file://COPYING;md5=a56a85cf323285df31085240a8aeb94f \ |
6 | " | 6 | " |
7 | inherit cmake pkgconfig python3native python3-dir systemd useradd | 7 | inherit cmake pkgconfig python3native python3-dir systemd useradd |
8 | # Disable python pybind support for ceph temporary, when corss compiling pybind, | 8 | # Disable python pybind support for ceph temporary, when corss compiling pybind, |
9 | # pybind mix cmake and python setup environment, would case a lot of errors. | 9 | # pybind mix cmake and python setup environment, would case a lot of errors. |
10 | 10 | ||
11 | SRC_URI = "http://download.ceph.com/tarballs/ceph-${PV}.tar.gz \ | 11 | SRC_URI = "gitsm://github.com/ceph/ceph.git;protocol=https;branch=main \ |
12 | file://0001-fix-host-library-paths-were-used.patch \ | 12 | file://0001-fix-host-library-paths-were-used.patch \ |
13 | file://ceph.conf \ | 13 | file://ceph.conf \ |
14 | file://0001-avoid-to_string-error.patch \ | ||
15 | file://0001-delete-install-layout-deb.patch \ | 14 | file://0001-delete-install-layout-deb.patch \ |
16 | file://0001-cephadm-build.py-avoid-using-python3-from-sysroot-wh.patch \ | 15 | file://0001-cephadm-build.py-avoid-using-python3-from-sysroot-wh.patch \ |
17 | file://0001-common-dout-fix-FTBFS-on-GCC-14.patch \ | 16 | " |
18 | " | 17 | |
18 | SRCREV="c14e68e1617b77c40bcd5da7e689d626a851c900" | ||
19 | PV = "19.0.0+git" | ||
19 | 20 | ||
20 | SRC_URI[sha256sum] = "47a3aecb724bf246e74ec980464b40d770cd8910f3727e2732575212f13e84ea" | 21 | S = "${WORKDIR}/git" |
21 | 22 | ||
22 | DEPENDS = "boost bzip2 curl cryptsetup expat gperf-native \ | 23 | DEPENDS = "boost bzip2 curl cryptsetup expat gperf-native \ |
23 | keyutils libaio libibverbs lua lz4 \ | 24 | keyutils libaio libibverbs lua lz4 \ |
@@ -26,6 +27,7 @@ DEPENDS = "boost bzip2 curl cryptsetup expat gperf-native \ | |||
26 | python3 python3-native python3-cython-native python3-pyyaml-native \ | 27 | python3 python3-native python3-cython-native python3-pyyaml-native \ |
27 | rabbitmq-c rocksdb snappy thrift udev \ | 28 | rabbitmq-c rocksdb snappy thrift udev \ |
28 | valgrind xfsprogs zlib libgcc zstd re2 \ | 29 | valgrind xfsprogs zlib libgcc zstd re2 \ |
30 | lmdb \ | ||
29 | " | 31 | " |
30 | 32 | ||
31 | 33 | ||
@@ -89,6 +91,9 @@ do_configure:prepend () { | |||
89 | # echo "set( CMAKE_C_COMPILER_WORKS TRUE)" >> ${WORKDIR}/toolchain.cmake | 91 | # echo "set( CMAKE_C_COMPILER_WORKS TRUE)" >> ${WORKDIR}/toolchain.cmake |
90 | # echo "set( CMAKE_CXX_COMPILER_FORCED TRUE)" >> ${WORKDIR}/toolchain.cmake | 92 | # echo "set( CMAKE_CXX_COMPILER_FORCED TRUE)" >> ${WORKDIR}/toolchain.cmake |
91 | echo "set( CMAKE_C_COMPILER_FORCED TRUE )" >> ${WORKDIR}/toolchain.cmake | 93 | echo "set( CMAKE_C_COMPILER_FORCED TRUE )" >> ${WORKDIR}/toolchain.cmake |
94 | |||
95 | echo "set( WITH_QATDRV OFF )" >> ${WORKDIR}/toolchain.cmake | ||
96 | echo "set( WITH_QATZIP OFF )" >> ${WORKDIR}/toolchain.cmake | ||
92 | } | 97 | } |
93 | 98 | ||
94 | do_compile:prepend() { | 99 | do_compile:prepend() { |