summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-02-06 13:27:53 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-02-06 13:27:53 -0500
commit4a16ba75b11a7748c076f3794a62b8a7975dbc81 (patch)
tree06b2a21bd16497d60f5312d93abe18400481610d
parentf32657ae6efd35e259147582ed12fb864688402a (diff)
downloadmeta-virtualization-4a16ba75b11a7748c076f3794a62b8a7975dbc81.tar.gz
crun: update to 0.17
We bump crun, and its dependency repositories to their latest revisions. Along with the code changes, we have a new systemd dependency (or the build fails), and the License was incorrectly set to GPLv3 previously, and we correct it to v2 as part of this update. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/crun/crun_git.bb15
1 files changed, 8 insertions, 7 deletions
diff --git a/recipes-containers/crun/crun_git.bb b/recipes-containers/crun/crun_git.bb
index 7781e110..e4f886c4 100644
--- a/recipes-containers/crun/crun_git.bb
+++ b/recipes-containers/crun/crun_git.bb
@@ -1,12 +1,12 @@
1DESCRIPTION = "A fast and low-memory footprint OCI Container Runtime fully written in C." 1DESCRIPTION = "A fast and low-memory footprint OCI Container Runtime fully written in C."
2LICENSE = "GPLv3" 2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4PRIORITY = "optional" 4PRIORITY = "optional"
5 5
6SRCREV_crun = "a43f72196f7aaf713dc997eaddd0f08612f60ac0" 6SRCREV_crun = "0e9229ae34caaebcb86f1fde18de3acaf18c6d9a"
7SRCREV_libocispec = "01c8f977ff5ed1e8010f40c2572343be1a70a51b" 7SRCREV_libocispec = "ece5f6aede6488396f9c84bc985df09f95204e1d"
8SRCREV_ispec = "775207bd45b6cb8153ce218cc59351799217451f" 8SRCREV_ispec = "79b036d80240ae530a8de15e1d21c7ab9292c693"
9SRCREV_rspec = "19e92ca817772b4466f2ed2b8d808dfb7a8ab4be" 9SRCREV_rspec = "7413a7f753e1bd9a6a9c6dc7f96f55888cbbd476"
10 10
11SRCREV_FORMAT = "crun_rspec" 11SRCREV_FORMAT = "crun_rspec"
12SRC_URI = "git://github.com/containers/crun.git;branch=master;name=crun \ 12SRC_URI = "git://github.com/containers/crun.git;branch=master;name=crun \
@@ -15,7 +15,7 @@ SRC_URI = "git://github.com/containers/crun.git;branch=master;name=crun \
15 git://github.com/opencontainers/image-spec.git;branch=master;name=ispec;destsuffix=git/libocispec/image-spec \ 15 git://github.com/opencontainers/image-spec.git;branch=master;name=ispec;destsuffix=git/libocispec/image-spec \
16 " 16 "
17 17
18PV = "0.10.2+git${SRCREV_crun}" 18PV = "0.17+git${SRCREV_crun}"
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21inherit autotools-brokensep pkgconfig 21inherit autotools-brokensep pkgconfig
@@ -25,6 +25,7 @@ PACKAGECONFIG ??= ""
25DEPENDS = "yajl libcap go-md2man-native" 25DEPENDS = "yajl libcap go-md2man-native"
26# TODO: is there a packageconfig to turn this off ? 26# TODO: is there a packageconfig to turn this off ?
27DEPENDS += "libseccomp" 27DEPENDS += "libseccomp"
28DEPENDS += "systemd"
28DEPENDS += "oci-image-spec oci-runtime-spec" 29DEPENDS += "oci-image-spec oci-runtime-spec"
29 30
30do_install() { 31do_install() {