summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Tricca <flihp@twobit.us>2013-10-17 18:47:34 +0000
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-10-18 11:05:06 -0400
commit4b7ddfca636c60bd896aabcf6e21555d2260b6a1 (patch)
treee35035cd398d8fea658a1974d0068fb314c69fdf
parenta60666fa677aa277901fa586f17383920443dce4 (diff)
downloadmeta-virtualization-4b7ddfca636c60bd896aabcf6e21555d2260b6a1.tar.gz
xen: avoid installing flask policy file as '/boot'
Upstream patch to fix race condition between creating /boot and installing the XSM policy. Race would cause policy to be written to /boot instead of into the /boot directory if it didn't already exist. Signed-off-by: Philip Tricca <flihp@twobit.us> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/xen/xen-4.3.0/flask-avoid-installing-policy-file-as-boot.patch26
-rw-r--r--recipes-extended/xen/xen_4.3.0.bb5
2 files changed, 30 insertions, 1 deletions
diff --git a/recipes-extended/xen/xen-4.3.0/flask-avoid-installing-policy-file-as-boot.patch b/recipes-extended/xen/xen-4.3.0/flask-avoid-installing-policy-file-as-boot.patch
new file mode 100644
index 00000000..d980807d
--- /dev/null
+++ b/recipes-extended/xen/xen-4.3.0/flask-avoid-installing-policy-file-as-boot.patch
@@ -0,0 +1,26 @@
1From 8bff3edead4318bfebc487f929f833d11922c238 Mon Sep 17 00:00:00 2001
2From: "Vadim A. Misbakh-Soloviov" <mva@mva.name>
3Date: Tue, 30 Jul 2013 16:34:38 +0400
4Subject: [PATCH] flask: avoid installing policy file as '/boot'
5
6Signed-off-by: Vadim A. Misbakh-Soloviov <mva@mva.name>
7Acked-by: Daniel De Graaf <dgdegra@tycho.nsa.gov>
8---
9 tools/flask/policy/Makefile | 1 +
10 1 file changed, 1 insertion(+)
11
12diff --git a/tools/flask/policy/Makefile b/tools/flask/policy/Makefile
13index e666f3e..df1e8f3 100644
14--- a/tools/flask/policy/Makefile
15+++ b/tools/flask/policy/Makefile
16@@ -103,6 +103,7 @@ POLICY_SECTIONS += $(USERS) $(CONSTRAINTS) $(ISID_DEFS)
17 all: $(POLICY_FILENAME)
18
19 install: $(POLICY_FILENAME)
20+ $(INSTALL_DIR) $(POLICY_LOADPATH)
21 $(INSTALL_DATA) $^ $(POLICY_LOADPATH)
22
23 $(POLICY_FILENAME): policy.conf
24--
251.7.10.4
26
diff --git a/recipes-extended/xen/xen_4.3.0.bb b/recipes-extended/xen/xen_4.3.0.bb
index e9a22ccd..228f75f9 100644
--- a/recipes-extended/xen/xen_4.3.0.bb
+++ b/recipes-extended/xen/xen_4.3.0.bb
@@ -6,7 +6,10 @@ PR = "r0"
6 6
7LIC_FILES_CHKSUM = "file://COPYING;md5=e0f0f3ac55608719a82394cc353928df" 7LIC_FILES_CHKSUM = "file://COPYING;md5=e0f0f3ac55608719a82394cc353928df"
8 8
9SRC_URI = "http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz" 9SRC_URI = " \
10 http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz \
11 file://flask-avoid-installing-policy-file-as-boot.patch \
12 "
10 13
11SRC_URI[md5sum] = "7b18cfb58f1ac2ce39cf35a1867f0c0a" 14SRC_URI[md5sum] = "7b18cfb58f1ac2ce39cf35a1867f0c0a"
12SRC_URI[sha256sum] = "e1e9faabe4886e2227aacdbde74410653b233d66642ca1972a860cbec6439961" 15SRC_URI[sha256sum] = "e1e9faabe4886e2227aacdbde74410653b233d66642ca1972a860cbec6439961"