summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2020-02-25 16:16:04 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-02-27 16:59:23 -0500
commit50669e428f564e1f9c85b5d79c3b50206921204c (patch)
treee4a0bb252b781c5774f4ab236cdc97d5cb35a950
parente9b2d92954cce089d246a3cd40af6779065548e8 (diff)
downloadmeta-virtualization-50669e428f564e1f9c85b5d79c3b50206921204c.tar.gz
xen-image-minimal: add a build dependency on the xen hypervisor
The hypervisor may not be within the dom0 filesystem image itself, so add a task dependency to ensure that it is deployable: do_build[depends] += "xen:do_deploy" Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-extended/images/xen-image-minimal.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-extended/images/xen-image-minimal.bb b/recipes-extended/images/xen-image-minimal.bb
index c98314e1..dcdc864a 100644
--- a/recipes-extended/images/xen-image-minimal.bb
+++ b/recipes-extended/images/xen-image-minimal.bb
@@ -16,6 +16,10 @@ IMAGE_INSTALL += " \
16 qemu \ 16 qemu \
17 " 17 "
18 18
19# The hypervisor may not be within the dom0 filesystem image but at least
20# ensure that it is deployable:
21do_build[depends] += "xen:do_deploy"
22
19# Networking for HVM-mode guests (x86/64 only) requires the tun kernel module 23# Networking for HVM-mode guests (x86/64 only) requires the tun kernel module
20IMAGE_INSTALL_append_x86 = "kernel-module-tun" 24IMAGE_INSTALL_append_x86 = "kernel-module-tun"
21IMAGE_INSTALL_append_x86-64 = "kernel-module-tun" 25IMAGE_INSTALL_append_x86-64 = "kernel-module-tun"