diff options
author | He Zhe <zhe.he@windriver.com> | 2016-09-05 14:52:49 +0800 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2016-09-06 09:35:45 -0400 |
commit | 548c88a90a003f96ed32dafb015db4c245f823aa (patch) | |
tree | cdcac31028b91f4bf0af4d101ff16b02e3101c8e | |
parent | c46b7903ffd2130d34553d55a93c156a5e9a7749 (diff) | |
download | meta-virtualization-548c88a90a003f96ed32dafb015db4c245f823aa.tar.gz |
libvirt: Add missing test helpers and remove windows 1252
Add missing test helpers
We don't support windows encoding so remove that case
Signed-off-by: He Zhe <zhe.he@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
3 files changed, 59 insertions, 0 deletions
diff --git a/recipes-extended/libvirt/libvirt/0001-ptest-Remove-Windows-1252-check-from-esxutilstest.patch b/recipes-extended/libvirt/libvirt/0001-ptest-Remove-Windows-1252-check-from-esxutilstest.patch new file mode 100644 index 00000000..217bdbc5 --- /dev/null +++ b/recipes-extended/libvirt/libvirt/0001-ptest-Remove-Windows-1252-check-from-esxutilstest.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From ffc71da15c3da068f85d16617b6e0c0175fc0110 Mon Sep 17 00:00:00 2001 | ||
2 | From: He Zhe <zhe.he@windriver.com> | ||
3 | Date: Tue, 23 Aug 2016 02:28:47 -0400 | ||
4 | Subject: [PATCH] ptest: Remove Windows-1252 check from esxutilstest | ||
5 | |||
6 | Currently we use iconv from glibc-locale and it does not support | ||
7 | Windows-1252 and we don't need support windows character encoding. | ||
8 | |||
9 | Signed-off-by: He Zhe <zhe.he@windriver.com> | ||
10 | --- | ||
11 | tests/esxutilstest.c | 1 - | ||
12 | 1 file changed, 1 deletion(-) | ||
13 | |||
14 | diff --git a/tests/esxutilstest.c b/tests/esxutilstest.c | ||
15 | index 44bdc84..3223de3 100644 | ||
16 | --- a/tests/esxutilstest.c | ||
17 | +++ b/tests/esxutilstest.c | ||
18 | @@ -258,7 +258,6 @@ mymain(void) | ||
19 | DO_TEST(ParseDatastorePath); | ||
20 | DO_TEST(ConvertDateTimeToCalendarTime); | ||
21 | DO_TEST(EscapeDatastoreItem); | ||
22 | - DO_TEST(ConvertWindows1252ToUTF8); | ||
23 | |||
24 | return result == 0 ? EXIT_SUCCESS : EXIT_FAILURE; | ||
25 | } | ||
26 | -- | ||
27 | 2.8.1 | ||
28 | |||
diff --git a/recipes-extended/libvirt/libvirt/0001-ptest-add-missing-test_helper-files.patch b/recipes-extended/libvirt/libvirt/0001-ptest-add-missing-test_helper-files.patch new file mode 100644 index 00000000..b4f1e273 --- /dev/null +++ b/recipes-extended/libvirt/libvirt/0001-ptest-add-missing-test_helper-files.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From e625a42caca492fe7d52b70bbbf83ae4d99cb15e Mon Sep 17 00:00:00 2001 | ||
2 | From: He Zhe <zhe.he@windriver.com> | ||
3 | Date: Tue, 23 Aug 2016 02:16:20 -0400 | ||
4 | Subject: [PATCH] ptest: add missing test_helper files | ||
5 | |||
6 | Signed-off-by: He Zhe <zhe.he@windriver.com> | ||
7 | --- | ||
8 | tests/Makefile.am | 4 +++- | ||
9 | 1 file changed, 3 insertions(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/tests/Makefile.am b/tests/Makefile.am | ||
12 | index 1c85656..2f8b9eb 100644 | ||
13 | --- a/tests/Makefile.am | ||
14 | +++ b/tests/Makefile.am | ||
15 | @@ -1422,8 +1422,10 @@ install-ptest: | ||
16 | @(for file in $(PTESTS); do \ | ||
17 | if [ -f .libs/$$file ]; then \ | ||
18 | install .libs/$$file $(DEST_DIR)/tests; \ | ||
19 | - else \ | ||
20 | + elif [ -f $(srcdir)/$$file ]; then \ | ||
21 | install $(srcdir)/$$file $(DEST_DIR)/tests; \ | ||
22 | + else \ | ||
23 | + install $(builddir)/$$file $(DEST_DIR)/tests; \ | ||
24 | fi; \ | ||
25 | done;) | ||
26 | @(if [ -d .libs ]; then install .libs/*.so $(DEST_DIR)/tests/.libs; fi;) | ||
27 | -- | ||
28 | 2.8.1 | ||
29 | |||
diff --git a/recipes-extended/libvirt/libvirt_1.3.5.bb b/recipes-extended/libvirt/libvirt_1.3.5.bb index 7271ebe0..3eff58d2 100644 --- a/recipes-extended/libvirt/libvirt_1.3.5.bb +++ b/recipes-extended/libvirt/libvirt_1.3.5.bb | |||
@@ -35,6 +35,8 @@ SRC_URI = "http://libvirt.org/sources/libvirt-${PV}.tar.gz;name=libvirt \ | |||
35 | file://install-missing-file.patch \ | 35 | file://install-missing-file.patch \ |
36 | file://0001-nsslinktest-also-build-virAtomic.h.patch \ | 36 | file://0001-nsslinktest-also-build-virAtomic.h.patch \ |
37 | file://0001-qemu-Let-empty-default-VNC-password-work-as-document.patch \ | 37 | file://0001-qemu-Let-empty-default-VNC-password-work-as-document.patch \ |
38 | file://0001-ptest-add-missing-test_helper-files.patch \ | ||
39 | file://0001-ptest-Remove-Windows-1252-check-from-esxutilstest.patch \ | ||
38 | " | 40 | " |
39 | 41 | ||
40 | SRC_URI[libvirt.md5sum] = "f9dc1e63d559eca50ae0ee798a4c6c6d" | 42 | SRC_URI[libvirt.md5sum] = "f9dc1e63d559eca50ae0ee798a4c6c6d" |