diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-11-09 05:12:32 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-11-09 05:35:44 +0000 |
commit | 5587dd15356f9897e9e000da4ba6e08733d24287 (patch) | |
tree | a073abc959ee3375d9fa8991be9d045936b57b3e | |
parent | 9232b203626a96fed1907cf7fb3f4e27d3fae607 (diff) | |
download | meta-virtualization-5587dd15356f9897e9e000da4ba6e08733d24287.tar.gz |
podman: fix documentation build issues
podman commit dfec510b41b5 [go-md2man: use vendored-in version, not
system] removes the shell test for go-md2man, which means our native
executable is not found.
While we could export GOMD2MAN and point it to our sysroot version
(${RECIPE_SYSROOT_NATIVE}/usr/bin/go-md2man), we could run into the
issues with formatting that the podman commit is trying to avoid.
If we pass our build host architecture to the build, it will be
used and the executable created as part of the compilation.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/podman/podman_git.bb | 7 |
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-containers/podman/podman_git.bb b/recipes-containers/podman/podman_git.bb index d599c748..7634ac85 100644 --- a/recipes-containers/podman/podman_git.bb +++ b/recipes-containers/podman/podman_git.bb | |||
@@ -11,7 +11,6 @@ REQUIRED_DISTRO_FEATURES ?= "seccomp ipv6" | |||
11 | 11 | ||
12 | DEPENDS = " \ | 12 | DEPENDS = " \ |
13 | go-metalinter-native \ | 13 | go-metalinter-native \ |
14 | go-md2man-native \ | ||
15 | gpgme \ | 14 | gpgme \ |
16 | libseccomp \ | 15 | libseccomp \ |
17 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ | 16 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
@@ -90,7 +89,11 @@ do_compile() { | |||
90 | export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}" | 89 | export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}" |
91 | export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" | 90 | export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" |
92 | 91 | ||
93 | oe_runmake BUILDTAGS="${BUILDTAGS}" | 92 | # podman now builds go-md2man and requires the host/build details |
93 | export NATIVE_GOOS=${BUILD_GOOS} | ||
94 | export NATIVE_GOARCH=${BUILD_GOARCH} | ||
95 | |||
96 | oe_runmake NATIVE_GOOS=${BUILD_GOOS} NATIVE_GOARCH=${BUILD_GOARCH} BUILDTAGS="${BUILDTAGS}" | ||
94 | } | 97 | } |
95 | 98 | ||
96 | do_install() { | 99 | do_install() { |