summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-05-24 15:02:54 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-05-24 16:08:02 -0400
commit5b13da8e575ac746b46426f2471bf004b2201e41 (patch)
tree67ef0a82124fb6d0e5bb0968c089faa78e92694c
parentf5d7b7db559687d5aca8fecac2a64cf398641ef5 (diff)
downloadmeta-virtualization-5b13da8e575ac746b46426f2471bf004b2201e41.tar.gz
cgroup-lite: uprev to v1.15
Upgrade and make the recipe more systemd "friendly". For the most part nobody is going to use this with systemd but in case they do they will get a masked and empty services file, as they do with Debian or Ubuntu. Otherwise this is a minor update from v1.11. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/cgroup-lite/cgroup-lite_1.15.bb (renamed from recipes-containers/cgroup-lite/cgroup-lite_1.11.bb)25
1 files changed, 18 insertions, 7 deletions
diff --git a/recipes-containers/cgroup-lite/cgroup-lite_1.11.bb b/recipes-containers/cgroup-lite/cgroup-lite_1.15.bb
index 065d0eae..7b48c3ac 100644
--- a/recipes-containers/cgroup-lite/cgroup-lite_1.11.bb
+++ b/recipes-containers/cgroup-lite/cgroup-lite_1.15.bb
@@ -1,23 +1,34 @@
1SECTION = "devel" 1SECTION = "devel"
2SUMMARY = "Light-weight package to set up cgroups at system boot." 2SUMMARY = "Light-weight package to set up cgroups at system boot."
3DESCRIPTION = "Light-weight package to set up cgroups at system boot." 3DESCRIPTION = "Light-weight package to set up cgroups at system boot."
4HOMEPAGE = "http://packages.ubuntu.com/source/precise/cgroup-lite" 4HOMEPAGE = "http://packages.ubuntu.com/source/artful/cgroup-lite"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://debian/copyright;md5=5d5da4e0867cf06014f87102154d0102" 6LIC_FILES_CHKSUM = "file://debian/copyright;md5=5d5da4e0867cf06014f87102154d0102"
7SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/cgroup-lite_1.11.tar.xz" 7SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/cgroup-lite_1.15.tar.xz"
8SRC_URI += "file://cgroups-init" 8SRC_URI += "file://cgroups-init"
9SRC_URI[md5sum] = "b20976194ee8fdb61e6b55281fb6ead4" 9SRC_URI[md5sum] = "1438c1f4a7227c0dedfce5f86f02591d"
10SRC_URI[sha256sum] = "a79ab9ae6fb3ff3ce0aa5539b055c0379eaffdc6c5f003af4010fcea683c1a45" 10SRC_URI[sha256sum] = "02f44c70ed3cf27b9e89e5266492fddf4b455336ab4e03abc85e92297537201f"
11 11
12inherit allarch 12inherit allarch update-rc.d systemd
13inherit update-rc.d
14 13
15INITSCRIPT_NAME = "cgroups-init" 14INITSCRIPT_NAME = "cgroups-init"
16INITSCRIPT_PARAMS = "start 8 2 3 4 5 . stop 20 0 1 6 ." 15INITSCRIPT_PARAMS = "start 8 2 3 4 5 . stop 20 0 1 6 ."
16
17# Keeps the sysvinit scripts out of the image if building
18# where systemd is in use.
19SYSTEMD_PACKAGES = "${PN}"
20SYSTEMD_SERVICE_${PN} = "cgroups-init.service"
21SYSTEMD_AUTO_ENABLE_${PN} = "mask"
22
23
17do_install() { 24do_install() {
18 install -d ${D}/bin 25 install -d ${D}/bin
19 install -d ${D}${sysconfdir}/init.d
20 install -m 0755 ${S}/scripts/cgroups-mount ${D}/bin 26 install -m 0755 ${S}/scripts/cgroups-mount ${D}/bin
21 install -m 0755 ${S}/scripts/cgroups-umount ${D}/bin 27 install -m 0755 ${S}/scripts/cgroups-umount ${D}/bin
28
29 install -d ${D}${sysconfdir}/init.d
22 install -m 0755 ${WORKDIR}/cgroups-init ${D}${sysconfdir}/init.d/cgroups-init 30 install -m 0755 ${WORKDIR}/cgroups-init ${D}${sysconfdir}/init.d/cgroups-init
31
32 install -d ${D}${systemd_unitdir}/system
33 ln -sf /dev/null ${D}${systemd_unitdir}/system/cgroups-init.service
23} 34}