diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2023-07-26 15:45:17 +0200 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-07-27 12:03:05 -0400 |
commit | 5bb2ad0d25969f93964c7870ebafeab92271013f (patch) | |
tree | b9ef75b92d01e01262b7f7fad16a75632bbc7de4 | |
parent | c5079557091b215663458807a8f617752614a6bd (diff) | |
download | meta-virtualization-5bb2ad0d25969f93964c7870ebafeab92271013f.tar.gz |
runc-opencontainers: use bfd linker even when gold is selected by ls-is-gold
* fixes:
ld: --no-dynamic-linker: unknown option
* you might need to clean the build for updated LDFLAGS to be corectly re-configured
* lld and bfd are fine:
$ ld.gold --help | grep dynamic-linker
-I PROGRAM, --dynamic-linker PROGRAM
$ ld.bfd --help | grep dynamic-linker
-I PROGRAM, --dynamic-linker PROGRAM
--no-dynamic-linker Produce an executable with no program interpreter header
$ ld.lld --help | grep dynamic-linker
--dynamic-linker=<value>
--no-dynamic-linker Inhibit output of .interp section
* not sure where this came from only place where I see --no-dynamic-linker
in runc-opencontainers WORKDIR is:
aarch64-oe-linux/13.1.1/plugin/include/config/aarch64/aarch64-linux.h: %{static-pie:-Bstatic -pie --no-dynamic-linker -z text} \
aarch64-oe-linux/13.1.1/plugin/include/aarch64-linux.h: %{static-pie:-Bstatic -pie --no-dynamic-linker -z text} \
so my guess is:
923ae4da Makefile: add support for static PIE
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/runc/runc-opencontainers_git.bb | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-containers/runc/runc-opencontainers_git.bb b/recipes-containers/runc/runc-opencontainers_git.bb index 7757baa0..e411859e 100644 --- a/recipes-containers/runc/runc-opencontainers_git.bb +++ b/recipes-containers/runc/runc-opencontainers_git.bb | |||
@@ -8,3 +8,5 @@ SRC_URI = " \ | |||
8 | RUNC_VERSION = "1.1.7" | 8 | RUNC_VERSION = "1.1.7" |
9 | 9 | ||
10 | CVE_PRODUCT = "runc" | 10 | CVE_PRODUCT = "runc" |
11 | |||
12 | LDFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd', '', d)}" | ||