diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-10-08 18:33:41 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-10-08 18:33:41 -0400 |
commit | 5be8686e659c42985fb6ee22dd6a6152735f414e (patch) | |
tree | 32a2ed9bf97f3efb98c1ed41891db2f958fca7e3 | |
parent | 96c644f896b14b246e57fbb80a7fbb86cea93d31 (diff) | |
download | meta-virtualization-5be8686e659c42985fb6ee22dd6a6152735f414e.tar.gz |
kernel: fix conditional application of fragments
using bb.utils.contains wasn't able to match on the substring
"type=kmeta" to enable the conditional inclusion of fragments
and KERNEL_FEATURES.
We switch to a python string only method so we can fix the
fragment application
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-kernel/linux/linux-%.bbappend | 6 |
1 files changed, 2 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-%.bbappend b/recipes-kernel/linux/linux-%.bbappend index bcd358df..5f315787 100644 --- a/recipes-kernel/linux/linux-%.bbappend +++ b/recipes-kernel/linux/linux-%.bbappend | |||
@@ -4,9 +4,7 @@ | |||
4 | LINUX_MAJOR = "${@(d.getVar('LINUX_VERSION') or "x.y").split('.')[0]}" | 4 | LINUX_MAJOR = "${@(d.getVar('LINUX_VERSION') or "x.y").split('.')[0]}" |
5 | LINUX_MINOR = "${@(d.getVar('LINUX_VERSION') or "x.y").split('.')[1]}" | 5 | LINUX_MINOR = "${@(d.getVar('LINUX_VERSION') or "x.y").split('.')[1]}" |
6 | 6 | ||
7 | KERNEL_META_TYPE ?= "${@bb.utils.contains('SRC_URI', 'type=kmeta', 'yocto', '', d)}" | ||
8 | |||
9 | include ${@bb.utils.contains('DISTRO_FEATURES', 'virtualization', 'linux-${KERNEL_META_TYPE}_${LINUX_MAJOR}.${LINUX_MINOR}_virtualization.inc', '', d)} | ||
10 | |||
11 | 7 | ||
8 | KERNEL_META_TYPE = "${@'yocto' if d.getVar('SRC_URI').find('type=kmeta') > 0 else 'none'}" | ||
12 | 9 | ||
10 | include ${@bb.utils.contains('DISTRO_FEATURES', 'virtualization', 'linux-${KERNEL_META_TYPE}_${LINUX_MAJOR}.${LINUX_MINOR}_virtualization.inc', '', d)} | ||