diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-07-11 03:38:10 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-07-11 14:07:17 +0000 |
commit | 61f643c386de78683a6b6376aa2e21b27d9b5d2b (patch) | |
tree | c8ce3ce34fe353c796be623ad3c01e332a15537b | |
parent | 099e9112538540fb4387370d1f7e69f7649031c7 (diff) | |
download | meta-virtualization-61f643c386de78683a6b6376aa2e21b27d9b5d2b.tar.gz |
moby: update to v27.0.3
Bumping moby to version v27.0.3-4-g7fa33a539a, which comprises the following commits:
7d99ebe418 rootless: add `Requires=dbus.socket`
540b29c0c6 update to go1.21.12
276a648ec3 Fix incorrect validation of port mapping
23b8b023dd Fix duplicate subnet allocations
bf222d635b fix some gofmt issues reported by goreportcard
f8231b52d3 daemon/graphdriver/overlay2: set TarOptions.InUserNS for native differ
b951474404 pkg/archive: createTarFile: consistently use the same value for userns
c5794e23ec pkg/archive: handleTarTypeBlockCharFifo: don't discard EPERM errors
02e24483be pkg/archive: getWhiteoutConverter: don't error with userns enabled
838330bac3 Dockerfile: update docker CLI to v27.0.2
e419e22f29 Dockerfile: update compose to v2.28.1
3557077867 update golangci-lint to v1.59.1
c95b917167 pkg/archive: reformat code to make #nosec comment work again
c0ff08acbd builder/remotecontext: reformat code to make #nosec comment work again
4587688258 api/types: deprecate ContainerJSONBase.Node, ContainerNode
6da604aa6a deprecate experimental Graphdriver plugins, and disable by default
ce5571f343 api: swagger: fix definition of TmpFsOptions (API v1.46)
a9ab04603e cmd/dockerd: initMiddlewares: use containerd/logs
e355e10011 vendor: github.com/containerd/ttrpc v1.2.5
f8c088be05 Lookup docker-proxy in libexec paths
d22d8a78f1 runconfig: deprecate IsPreDefinedNetwork
0a4277abf4 api/types: move stats-types to api/types/container
91a2a574d7 api/types: rename container.StatsResponse to StatsResponseReader
6fafc8762f api/types: fix typo in GoDoc
42cb29f6ea registry: Search.searchUnfiltered: inline variable
43d4a4c63e registry: v2AuthHTTPClient: inline some vars and slight refactor
bf35f3d8c8 update one more entry in mailmap and AUTHORS
b4c20da143 volume: use AtomicWriteFile to save volume options
39b4448e12 docs/api: update some example values to be more accurate (API v1.46)
37b57c2ae0 api: swagger: update some example values to be more accurate
2a7bb2a7bd update .mailmap and AUTHORS
68b8e97849 vendor: github.com/spf13/cobra v1.8.1
b5cc61a243 Dockerfile: update buildx to v0.15.1
f741ca857c libnetwork/drivers/macvlan: getDummyName don't use stringid.TruncateID
d241862f36 libnetwork/drivers/macvlan: move truncating ID to getDummyName
dab918b2b0 libnetwork/drivers/ipvlan: getDummyName don't use stringid.TruncateID
b8c80b19de libnetwork/drivers/ipvlan: move truncating ID to getDummyName
8599213b52 vendor: update buildkit to v0.14.1
2df4391473 Fix hairpin between networks with mapped port
b06b6b3648 docs: add API documentation for API v1.46
517fb0991e api/types/container: provide alias for github.com/docker/go-units.Ulimit
ad716b223b integration/container: use consistent alias for import
25f44885ed daemon/cluster/executor/container: use consistent alias for import
084219a5f9 update AUTHORS
f09f756851 daemon/cluster: minor linting issues and cleanup
74d77d8811 Revert "Internal resolver for default bridge network"
6d35673504 Revert "No default nameservers for internal resolver"
01efb9a5ab daemon/cluster/executor/container: fix error-handling
b640582436 Add OomScoreAdj options
8e91b64e07 runconfig: deprecate DefaultDaemonNetworkMode, move to daemon/network
437e1ae15e runconfig/opts: deprecate ConvertKVStringsToMap and move internal
b3e236d3b5 daemon: rename some inconsistent import aliases
2851ddc44c Add containerd image ref to created containers
812f319a57 Add containerd connection info to info endpoint (API v1.46)
1327342b14 hack: Ignore deprecate-integration-cli validation
7b8f4922a5 daemon: Emit Image Create event when image is built
09eb6ec4f1 builder/exporter: Wrap exporter to hook the image export
0e84482ef5 builder-next: Move exporter wrapper to exporter package
48ff86ec64 pkg/longpath: AddPrefix: use early returns
424c22390e pkg/longpath: deprecate Prefix const
2f45cbf69f api/types/container: NetworkMode align code between Windows and Linux
7b56fa8dc0 api/types/container: NetworkMode.NetworkName: use switch
7b438c5c31 daemon: rename variables that shadowed imports
4c7228663c api/server/router/container.postCommit: add TODO about use of CreateRequest
c692af36c3 runconfig: deprecate ContainerConfigWrapper, move to api/types/container
afdfe4ff86 runconfig: deprecate SetDefaultNetModeIfBlank
4af9f418a3 runconfig: remove ContainerConfigWrapper.getHostConfig() utility
98bd08c534 runconfig: remove redundant import-alias
e42503213d runconfig: ContainerConfigWrapper: unify Linux and Windows implementations
2954b05b03 runconfig: remove conversion code for API < v1.18
37f4616751 integration-cli: fix TestCreateWithTooLowMemoryLimit: using deprecated API fields
964aba696c libnetwork: windows/overlay: remove endpointRequest wrapper
c316ed0c22 libnetwork: remove special handling for Windows 14393 (RS1, V1607, LTSC2016)
3108165c94 pkg/archive: TestChangesDirsEmpty, TestChangesDirsMutated: no kernel-version check
17ca8b62bd pkg/archive: remove uses of iota
94caeeb401 pkg/archive: don't call system.Lgetxattr on unsupported platforms
c565a3a1fe pkg/archive: collectFileInfo: don't create FileInfo if unused
7ce1edd7c6 pkg/archive: deprecate NewTempArchive, TempArchive
92b8d93f47 pkg/archive: deprecate CanonicalTarNameForPath
0ffc0c95e6 pkg/tarsum: format #nosec comments to standard format
cb19b59b65 pkg/archive: format #nosec comments to standard format
805ccd2365 pkg/dmesg: deprecate, and use internal utility instead
c7f4abc14a pkg/dmesg: use unix.SYSLOG_ACTION_READ_ALL instead of local variable
528ffa9cae Allow multiple macvlan networks to share a parent
9389f76f6d pkg/chrootarchive: remove dependency on pkg/longpath
f657a75bf6 pkg/archive: remove dependency on pkg/longpath
2100a70741 pkg/stringid: deprecate IsShortID
e19e6cf7f4 pkg/stringid: deprecate ValidateID
0fb6360fa7 builder/dockerfile: createDestInfo: remove platform arg (LCOW left-over)
c5d95fdb04 builder/dockerfile: fix some minor linting issues
6fa6812c51 builder/dockerfile: rename vars that shadowed types and builtins
074932966d builder/dockerfile: remove endsInSlash utility
c8e7fcf91a api: adjust health start interval on swarm update
dd1ca95ef9 Add exec option to API TmpfsOptions
07053a0991 testutil/daemon: Wait() until the daemon is Kill()'ed
955b923352 daemon: releaseNetwork: clear SandboxID, SandboxKey
e3c5665d21 daemon: restore: clear net state for stopped containers
17a59a7506 Don't log an error about route-add for IPv6 bridge
57c6a5e691 libnet: SetKey: propagate traces from API to SetKey reexec
b7186bdfc8 libnet: Sandbox: add ctx to SetKey
6c71ebd82c libcontainerd: Start: add ctx
2d8c4265c7 libcontainerd: NewTask: add ctx
19f72d6fc4 libnet: add more OTel spans
224d7291df container: add a span to CheckpointTo
642242a26b builder/mobyexporter: Add missing nil check
44f19518f9 move the cli/debug package to cmd/dockerd/debug
e4e40558ba builder/builder-next: gofmt
88e5e4cfb4 Prevent data race during version negotiation
9101392309 update runc binary to v1.1.13
ec24e19d69 vendor: github.com/opencontainers/runc v1.1.13
d20739b6fe vendor: golang.org/x/net v0.24.0
535898dd9a vendor: golang.org/x/crypto v0.22.0
4b2aa9f875 vendor: golang.org/x/sys v0.19.0
cec0d50361 libnet: add ctx to Sandbox.Destroy()
af23a024a1 libnet: Endpoint: add ctx to Join and Leave
566026af8f libnet: Controller: add ctx to store methods
9391052700 libnet: Add ctx to NewSandbox
4924f56e7b libnet/driverapi: Add ctx to ProgramExternalConnectivity
c5c1d133ef libnet/driverapi: Add ctx to Join
8dcded102e libnet: add OTel spans to CreateEndpoint
cf376170ed Add more go:build statements to prevent downgrading Go language version
b7d5a42168 Update go:build comments to go1.21
5343c7b451 remove internal/compatcontext and use context instead
13c3384303 hack/vendor.sh: remove redundant -compat 1.18
f20fd3c8a0 golangci-lint: ignore ineffassign & staticcheck on ctx shadowing
d0790fd03e Trivial tidying in osl.setIPv6()
b7f1036cd9 Remove the option to ignore failure to disable ipv6
44d00e3b9b Dev container: try to load kernel module ip6_tables
d0a135772e Dockerfile: update buildx to v0.15.0
215410316f daemon: cleanup getDefaultNetworkSettings
01eecb6cdf Validate port bindings for gateway_mode=routed
2a291c1855 Improve PortBinding.String()
a1f8bbeeef Remove unused bridge.driver.portAllocator
043db3be68 Bind the same port for multiple addresses
20c99e4156 Option to disable NAT for IPv4/IPv6 for a bridge network.
18ff5ef537 vendor: update buildkit to v0.14.0
e05848c002 Set up bridge-specific iptables rules in the bridge driver
4f09af6267 Allocate same port for IPv4/IPv6 for 'any interface' mappings.
03577884d9 Retry port mapping for a range if ports are in-use
931eea20ff Add portallocator.RequestPortsInRange()
e0b762ed1b daemon/containerd: fix duplicate import
7f2ed139fe remove uses of platforms.Platform alias
896de6d426 seccomp: allow specifying a custom profile with `--privileged`
2ccce36d10 c8d/progress: Allow updating "Unavailable" ids
e2326c27b5 c8d/push: Fix wrong Originalindex descriptor in aux error
af0cdc36c7 api: deprecate erroneous Config fields in `GET /images/{name}/json` response
58641c7b5c docs: api: use separate definition for Image.Config (api v1.39 - v1.45)
5e0e34fafd api: swagger: use separate definition for Image.Config
8d96d759bb c8d/image_manifest: IsPseudoImage return true for unknown/unknown platform
b4d2283c89 api/push: Ignore Platform on older APIs
68a63d0611 c8d/push: Extract missing content note to an Aux progress
0a31437208 c8d/push: Support platform selection
999f1c63db testutils/specialimage: Add MultiPlatform
c16d676266 c8d/blobsDirContentStore: Return ErrNotExists
85249a8401 c8d/image_manifest: Add helper functions
c514952774 Changed default value of the startInterval to 5s
6c2934f373 api/types: move ImageLoadResponse to api/types/image
eb675cce71 api/types: move ImageImportSource to api/types/image
f6cc76ceb9 api/types: move ImageSearchOptions to api/types/registry
b5f15bc0aa api/types: move EventsOptions to api/types/events
ecb24afaaf api/types: move ImagesPruneReport to api/types/image
162ef4f8d1 api/types: move VolumesPruneReport to api/types/volume
17c3269a37 api/types: move ContainerStats to api/types/container
fd1d8f323b api/types: move CopyToContainerOptions to api/types/container
47d7c9e31d api/types: move ContainerPathStat to api/types/container
db2f1acd5d api/types: move ContainersPruneReport to api/types/container
5b27e71521 api/types: move ContainerExecInspect to api/types/container
d91638e295 api/types: move ExecStartCheck to api/types/container
452e134001 api/types: move ExecStartOptions to api/types/backend
cd76e3e7f8 api/types: move ExecConfig to api/types/container
ac27a5379b docs: api: image inspect: remove Container and ContainerConfig
52580b2673 vendor: github.com/creack/pty v1.1.21
fa95f8a070 client: fix typos in test-names and godoc
08939f21ad integration-cli: remove DockerAPISuite.TestContainerAPICopyNotExistsAnyMore
75843620a6 api/server/router/container: minor nits in exec router
18e1afd1a1 vendor: github.com/distribution/reference v0.6.0
7501b90a22 vendor: go.etcd.io/bbolt v1.3.10
cf796aa56a pkg/reexec: touch-up GoDoc, and remove "import" comments
d20a074f33 pkg/reexec: remove gotest.tools from tests
defd5a08f4 pkg/reexec: unify non-Linux implementation of Command
004451c812 pkg/reexec: unify implementation of Self() and remove stub
79bff9461c pkg/reexec: don't mix syscall and golang.org/x/sys package
a445f7fa8a daemon/graphdriver: fix GoDoc for ProtoDriver.GetMetadata
a76b768fea daemon/graphdriver: remove redundant Mounted function
837b3f9576 Allow startup with no kernel support for ip6_tables
fd3fa4b28a Add Rob Murray (@robmry) as maintainer
854130eee0 deps: remove `grpc-ecosystem/go-grpc-middleware`
49ca0d0d03 otel: remove deprecated usages of `otelgrpc`
1243f9da6d Revert "libnet/i/defaultipam: Disambiguate PoolID string format"
6af0646236 Revert "libnet/i/defaultipam: Use InternalErrorf instead of InvalidParameterErrof"
4aa85cd159 ci: enable debug for buildkit container builder
fc9dd6acb4 api/types/network: make CheckDuplicate optional
e5f9484ab6 api/types: move NetworksPruneReport to api/types/network
ad6edc139f api/types: move NetworkCreate, NetworkCreateRequest to api/types/network
4f61fa21cb vendor: update buildkit to v0.14.0-rc2
ca0529f984 api/server: ContainerList returns container annotations
b3c8216873 vendor: google.golang.org/appengine v1.6.8
0b5f7b9ff8 builder-next: Adjust NewGatewayFrontend invocation
fa03db1b82 builder: Update detect usage for new detect API from buildkit
995604236e builder: Adjust usage of shlex.ProcessWord
438371e1fe builder: Pass nil linter to instructions.Parse
3bcbb561ad vendor: update github.com/moby/buildkit to v0.14.0-rc2-dev
d365702dbd No default nameservers for internal resolver
18f4f775ed Internal resolver for default bridge network
5318c38eae update containerd binary to v1.7.18
86f7762d48 vendor: github.com/containerd/containerd v1.7.18
91e2c29865 update to go1.21.11
163c6ca9ad api: Make EnableIPv6 optional
83c532c9b7 daemon/cluster: remove Cluster.getRequestContext()
69b2a05d27 api/types: migrate NetworkResource to api/types/network
3306034c64 api/types: remove aliases for deprecated Image types
70bac42113 integration/network: remove used of deprecated NetworkInspectOptions
1ec92ea60b opts: remove alias for ipamutils
e6f41e22a7 client: Client.doRequest: fix closing filehandle and reversed errors
9110ef1eec client: ensureReaderClosed: make linters happier
57f597b866 client: Client.NetworkInspectWithRaw: minor cleanup
42f4db26c7 api/server/httpstatus: FromError: remove redundant checks and cleanup
f78dac35e5 api/types: migrate NetworkListOptions to api/types/network
d18b88fd32 daemon: add ULA prefix by default
68bf0e7625 api/types: migrate EndpointResource to api/types/network
5bea0c38bc api/types: migrate NetworkInspectOptions to api/types/network
245d12175f api/types: migrate NetworkConnect, NetworkDisconnect to api/types/network
89624e09e6 api/types: migrate NetworkCreateResponse to network.CreateResponse
32418e9753 daemon: set the default local addr pool if none configured
0071832226 Add per-endpoint sysctls to DriverOpts
347bb4122a update docker-py to 7.1.0
69f1e2a923 docs/api: add Scope, ConfigOnly, ConfigFrom, Peers (v1.41 - v1.45)
53542fefd5 api: swagger: Network: add Peers
44125530bf api: swagger: POST /networks/create: document Scope, ConfigOnly, ConfigFrom
8b7a54f622 api: swagger: Network: inline examples, and add ConfigOnly, ConfigFrom
6cab6d0302 docs/api: POST /networks/create: inline examples per-field (v1.41 - v1.45)
51885166b9 api: swagger: POST /networks/create: inline examples per-field
d64e220afb api/types: NetworkCreate: add GoDoc
cd1ed46d73 don't depend on containerd platform.Parse to return a typed error
56086c9952 integration/container: remove redundant type-conversion, and minor cleanup
070e90a94c integration/system: remove redundant type-conversion, and minor cleanup
667094924d testutil/fakestorage: fix minor (linting) issues
4a074c809e integration/internal/swarm: remove unused ContainerPoll
fe78d6d9da integration/internal/swarm: rename vars that collided with imports
4619b14403 refactor: rename attach config var
2d134c5abd Fix goroutine/fd leak when client disconnects
8361baf8d9 Dockerfile: update compose to v2.27.1
387be6ec91 Dockerfile: update buildx to v0.14.1
500eff0ae9 libnet/i/defaultipam: improve address pools validation
0c022307e9 libnet/i/defaultipam: Unmap IPv4-mapped IPv6 addrs
9d288b5b43 libnet/i/defaultipam: introduce a linear allocator
a9ebb0c267 Replace dead RFC8878 go doc hyperlink
16e5c41591 Fix issue where node promotion could fail
5a2fa59688 libnet/i/defaultipam: Use InternalErrorf instead of InvalidParameterErrof
9369132879 libnet/i/defaultipam: Disambiguate PoolID string format
6d21574535 libnet: Controller: drop getStore()
49888559cc libnet: Controller: drop closeStores
2336363e28 libnet: init datastore in ctrler constructor
3847da374b integration/TestDiskUsage: Make 4096 also a 'empty' value
1e29f9b12f Move EndpointSettings.DriverOpts from op-state to config
a35716f5b9 Factor out selection of endpoint for config migration
4f0cb7d964 Dockerfile: update containerd binary to v1.7.17 (static binaries and CI only)
e459487feb Update containerd to v1.7.17
707ab48cbb Explicity write http headers on streaming endpoints
50d3028464 Fix fd leak/goroutine when attaching stdin only
ad0f263eb5 tarexport: Plumb ctx, add OTEL spans, handle cancellation
33f9a5329a Default to "windows-dns-proxy":true
77a47dba3b Forward DNS requests into --internal networks
6fbae5ff26 libnet/d/bridge: don't parse the MacAddress netlabel
41ddc47bbf Don't explicitly enable ip6tables in tests
07ccaf028d Enable 'ip6tables' by default, don't require 'experimental'.
5705cbf6e3 Make it an error to set up filtering on an unnamed bridge
d6b6a5122f Enable filtering on IPv6 bridges with no IPv6 address
4df97f2e1e Gate setting of bridge-nf-call-ip6tables on "--ip6tables=true".
8751562d3f Set up IPv6 n/w isolation rules when --ip6tables=true
23fd15985b Allow "--ip6tables=true" when "--iptables=false"
9a8ffe38fc Disable ip6tables in tests that disable iptables
5952920380 libnet/d/remote: replace errorWithRollback
7216541b17 libnet: don't check if ctrler store is nil
7ea9acc97f cmd/dockerd: deprecate `api-cors-header`
6c97e0e0b5 update to go1.21.10
72eb615490 Makefile: bundles is not PHONY
fda708f55d Delete broken/unused test requirement helper "IPv6"
4aff2fbc98 Remove integration-cli TestDaemonSuite/TestDaemonIPv6Enabled
346a7c07a0 Fix TestDockerSwarmSuite/TestSwarmInitIPv6
b11e95f5bc Don't delete IPv6 multicast addresses from a bridge
a5f82ba4bf Disallow IPv6 multicast as bridge n/w subnet
aa3a86c038 Refactor IPv6 subnet validation
f46473b29c Do not remove kernel-ll addresses from bridges
01ea18f1e3 Allow for a read-only "/proc/sys/net".
57ada4b848 Option to avoid deleting the kernel_ll address from bridges.
c5376e534c libnet/ipams/null: move driver name to its pkg
f2387f3632 libnet/ipams/defaultipam: move driver name to its pkg
0db56de78e libnet/ipamutils: no more global state
3c9718144f libnet/ipams: register all drivers
eda47500fc libnet/ipams: Unconditionally call windowsipam.Register
ae9e4319b0 libnet/ipams/windowsipam: that driver knows its name
8cec9f0dca libnet/ipams/defaultipam: add a Register fn
218394cada libnet/ipams/builtin: move to libnet/ipams
29f2ca04e0 libnet: move ipam pkg to ipam/defaultipam
e8644c3e0e libnet/ipam: default-address-pools as Register arg
1d5a12dfb1 integration-cli: createNetwork: add t.Helper()
115de5ff3d libnet/ipamapi: add in/out structs for RequestPool
82aae0fe50 libnet/netutils: remove dead util NetworkRange
37a81cd04d libnet/ipam: split v4/v6 address spaces
199c72cb5d libnet/ipam: remove dead DumpDatabase()
df88857e6c libnet/ipam: put `addrSpace` into a separate file
a047d4b1df libnet/ipam: un-embed mutex from `addrSpace`
eeec716e33 Update containerd to v1.7.16
efca9303a4 refactor: updated native diff error message
ff8de5e156 Add firewalld policy "docker-forwarding".
5ebe2c0d6b apparmor: Allow confined runc to kill containers
87506142d8 Do not forward DNS requests to self.
147f701bd1 chore: fix function names in comment
e3c59640d5 vendor: github.com/Microsoft/go-winio v0.6.2
2140e7e0f5 vendor: golang.org/x/tools v0.16.0
85c9900377 vendor: golang.org/x/mod v0.17.0
e314113ad7 Dockerfile: update docker CLI to v26.1.0
df831c943f vendor: github.com/cilium/ebpf v0.12.3
194cbd6e7d Makefile: refactoring .PHONY
57a12a372f Update GoDoc for ioutils on atomic writers
98d51b510d chore: remove repetitive words
8bbba6315f API: bump version to 1.46
80d92fd450 feat: ctx to client API
838047a1f5 archive: fix ConvertRead/ConvertWrite functions for rootless docker & native diff overlay
aef6905e01 overlay2: better documentation of user namespace behavior when checking native diff support
f6b80253b8 overlay2: get rid of unnecessary kernel version check
b2fd67de77 overlay2: support rootless native overlay diff in kernel 5.11 and above
d4f61f92fd Move StartedAt time to before starting the container
Bumping docker-cli to version v27.0.3-15-gd41cb083c, which comprises the following commits:
0a8bb6e5b chore: regenerate docs
c777dd16d docs: update cli-docs-tool (v0.8.0)
eea26c50d docs: update links to docker cli reference
1cf2c4efb docs: regenerate base command
c2b9c1474 docs: align heading structure for base command
598442d37 docs: remove frontmatter for base command
c964b80e5 docs: rename cli.md to docker.md (base command)
0ca7be015 docs: remove empty docker base command reference
27bf78d33 docs: make buildx build the canonical reference doc
5ed8f858c update to go1.21.12
6b99e0370 vendor: github.com/docker/docker v27.0.3
3134d5582 vendor: github.com/docker/docker v27.0.2
c97e8091a vendor: github.com/docker/docker v27.0.2-dev (e953d76450b6)
894584802 vendor: github.com/docker/docker v27.0.2-dev (861fde8cc974)
cd560916f gha/e2e: Update latest version to 27.0
50fae2074 cli/config/credentials: ConvertToHostname: handle IP-addresses
217971d48 re-introduced support for port numbers in docker registry URL
6e35a78fd update golangci-lint to v1.59.1
bf1a70182 vendor: github.com/docker/docker v27.0.1
617eb5271 cli: make initializing the global meter- and tracing providers optional
9f8bda1df cli/config: replace pkg/homedir dependency with local copy
ad583961b vendor: github.com/docker/docker v27.0-dev (ff1e2c0de72a, master)
c8c13bdca docs/deprecated: update status for graphdriver-plugins
1f7561ecb Dockerfile: update compose to v2.28.0
1a0481007 vendor: github.com/docker/docker v27.0.1-rc.1
faf7647dc refactor: remove test
d1cb7d41c cli/command: Don't copy fakeClient
1322f585f test: cli force exit signal handler
34d42bdf0 vendor: github.com/docker/docker v27.0-dev (018d93decfb5)
443617c0f update mailmap and AUTHORS
2088c5963 vendor: github.com/docker/docker 1a1f3cff45ec (master, v27.0-dev)
64c20f301 Additional typo corrections
a84536eb4 Fix RFC3339 typo in docs
e5d26a8d4 build: allow BuildKit to be used on Windows daemons that advertise it
55a1f6eb7 cli-plugins/manager: add GoDoc for getPluginDirs, defaultSystemPluginDirs
4f00eee52 vendor: github.com/spf13/cobra v1.8.1
00b0eb778 update go-md2man to v2.0.4
b0793613a Dockerfile: update buildx to v0.15.1
0bc092496 deprecate experimental graphdriver plugins
1f1b70dfd docs: add deprecation warning to experimental grapdriver plugins
a4bfd8c74 feat: add a global sigint/sigterm handler as a fallback to ctx cancellation
eae63069e vendor: github.com/moby/swarmkit/v2 v2.0.0-20240611172349-ea1a7cec35cb
3d017f30d vendor: github.com/docker/docker v27.0.0-rc.2
e0972e94b gha: e2e: test against v27.0 release candidates
43210216f bump version to v27.0.1-dev
c07cee05e Update go:build comments to go1.21
1fd8e2434 cli/command/image: add go:build tag to prevent downgrading go version
c8f5d4cc6 build(deps): bump docker/bake-action from 4 to 5
3b0d297aa vendor: github.com/docker/docker caf502a0bc44 (v27.0.0-dev)
11a3d8728 vendor: github.com/docker/docker ec4bac431c88 (v27.0.0-dev)
1bfec63b9 vendor: github.com/docker/docker ba69bd9c1e48 (v27.0.0-rc.2-dev)
8376b3e42 use local ConvertToHostname() implementation
4ea91a73e vendor: golang.org/x/net v0.24.0
91b63ac45 vendor: golang.org/x/crypto v0.22.0
a2ccd3eb0 vendor: golang.org/x/term v0.19.0
634b19f5e vendor: golang.org/x/sys v0.19.0
872935f1c vendor: github.com/docker/docker v27.0.0-rc.1
1fc73b470 vendor: github.com/docker/docker v27.0.0-dev (bcd280a3ed2d)
e9c0fc330 docs: extend deprecation target for non-TLS API
3dcc65353 plugins: cleanup sockets when done
f80d7182c cli/command: remove deprecated EventHandler, InitEventHandler
ad62b6869 vendor: github.com/containerd/platforms v0.2.1
6e7266a72 cli/command/registry: fix link to credential stores
6b93cf221 cli: Wrap Err stream
b79d68465 Deprecate non-standard (config) fields in image inspect output
e06ef800f Removed all mentions of "please" from docs and messages
32ac7a08f cli/push: Print aux notes
966fa7c47 cli/push: Add `platform` switch
892784dee vendor: github.com/docker/docker v27.0.0-dev (9d9488468fe2)
3ce317747 gha: switch to Ubuntu 24.04
43b97e888 update golangci-lint to .v1.59.0
df474d517 cli/command/image/build: fix nosec comment
0ba14fde4 linting: fmt.Sprintf can be replaced with string concatenation (perfsprint)
7db922cf9 cli/command: TestGetDefaultAuthConfig: remove unused expectedErr
dfec976e8 linting: fmt.Errorf can be replaced with errors.New (perfsprint)
e93abde7a cli/command/network: fix linting issue and pass client instead of cli
43b840ed9 vendor: github.com/docker/docker a736d0701c41 (master, v27.0.0-dev)
c481c6492 cli/command: remove some import aliases
851277f96 cli/command/container: rename some variables
1a83595c7 cli/command/container: legacyWaitExitOrRemoved rm intermediate var
0d4de2392 cli/command/container: inline some variables to prevent shadowing
d11fbda36 vendor: github.com/distribution/reference v0.6.0
d0057db3a cli/command: more go1.19 ("predeclared any")
3f0d90a2a feat: global signal handling with context cancellation
97b7746df vendor: github.com/docker/docker 59996a493cfc (v27.0.0-dev)
94f9de592 Handle networks.driver_opts for a service
a73172265 cli/compose: add schema 3.13 (no changes from 3.12 yet)
0502189e2 cli/command/network: add minimal test for --ipv6 option
db2672e68 network create: make --ipv6 optional
0ed8a7e31 vendor: github.com/docker/docker 00f18ef7a455 (master / v27.0.0-dev)
9acfbbd74 Correct typos in docs/ and man/
bc2e27478 vendor: migrate to github.com/go-viper/mapstructure/v2 v2.0.0
23148220e vendor: github.com/docker/docker c6aaabc9fc82 (master / v27.0.0-dev)
a9ea03481 vendor: github.com/containerd/containerd v1.7.18
630e1d3e9 update to go1.21.11
558a910b8 vendor: github.com/containerd/containerd v1.7.17
be2c284ee vendor: tags.cncf.io/container-device-interface v0.7.2
20d1b661b cli/command: use shallower interface for completions
b6a3ce416 vendor: github.com/docker/docker cd3804655a25 (master / v27.0.0-dev)
d4491fc09 Correct typos in the cli/ folder
b9cd72259 gha: update to actions/upload-artifact@v4
2ef6bc1c1 Update CODEOWNERS
e2fc6bd77 vendor: github.com/docker/docker e622cea55698 (master / v27.0.0-dev)
16c8f4942 vendor: github.com/Microsoft/hcsshim v0.11.5
b7548ba7f vendor: github.com/opencontainers/image-spec v1.1.0
12aaeae21 vendor: github.com/Microsoft/go-winio v0.6.2
fed9fa0f7 context list: temporarily add ContextType to JSON output
40a1da8b4 cli/command/context: list: add test for JSON output
2e9eff235 cli/command/context: test inspecting context with custom metadata
54291dd47 cli/command/context: add test-utility to create multiple contexts
9d9bb19f0 docs: deprecate daemon's api-cors-header flag
7dc271a8b migrate to new github.com/containerd/platforms package
d5d94e46f Explain how to use "network connect --driver-opt" to set sysctls
7f9dba60e Test quoted fields in --driver-opt
b7583a2c2 Explain how to use "--network driver-opt" to set sysctls
068f118f8 Test quoted field in --network
82ed39e31 docs: use --quiet in example to simplify output
e70f68595 Dockerfile: update ALPINE_VERSION to 3.20
0b7aff333 Dockerfile: update compose to v2.27.1
f0e7e07b8 Dockerfile: update buildx to v0.14.1
05905bd92 vendor: github.com/docker/docker-credential-helpers v0.8.2
dc75e9ed6 cli/config: do not discard permission errors when loading config-file
c80adf4e8 cli/config: TestLoadDefaultConfigFile: check that no warnings are printed
de91207b8 cli/config: add test for dangling symlink for config-file
426fb2fd8 cli/config: Load(), LoadDefaultConfigFile(): improve GoDoc
6d21372db run, create: update "--rm" flag description to mention anonymous volumes
296a6f587 plugins/hooks: Don't show empty hooks
1527d625f Plumb context to API callbacks
3fdf377b6 vendor: github.com/docker/docker master (06e3a49d66fa)
6a4d38c7f docs: fix json syntax error
ffd57fac1 Updated engine versions in e2e text matrix
dbf844366 vendor: github.com/moby/swarmkit/v2 master (c1c857e2dca1)
5f4f4f64d OTel: implement missing MeterProvider `ForceFlush`
f07834d18 OTel: add `command.time` metric to plugin commands
02537eac5 Use funcs on DockerCli to return Meter/TracerProviders, not initialize them. Initialize them during DockerCli struct init
4758ed0b0 Document the extended '--network' syntax
e8bfedd26 Fix TestNetworkConnectWithFlags
eb99994c7 update to go1.21.10
8d6e571c0 Add e2e tests for run w/ bad entrypoint
31644d5ea Fix hang when container fails to start
b7e25a4b4 docstring: typo: settings -> setting
e3216ca64 go.mod: use SemVer format for go version to assist CodeQL AutoBuild
692c7ee7e gha: CodeQL: move go.mod/go.sum symlink earlier to help caching
e1dcc194e OTEL collector/prometheus/aspire-dashboard stack for testing purposes
1d666b410 feat: wire ctx into plugin hooks
5ccb48459 cli-plugins: PluginRunCommand: use cmd.Environ instead of os.Environ
86162f781 feat: use main func ctx for cobra and use ctx in tests
e73fde8ca vendor: update github.com/docker/docker to v26.1.0
dccfd6e4d chore: fix function names in comment
116db4fc8 docs: tidy up CDI docs
73959eef7 chore: remove deprecated DualStack field
1433df8fe bake/bin-image-cross: Add darwin
0c2697d77 Dockerfile: Remove xx-sdk-extras
094af6ea0 darwin/build: Disallow CGO_ENABLED=1 when cross-compiling
faf096b25 docs: clarify that --data-path-addr doesn't restrict access
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/docker/docker-moby_git.bb | 10 |
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-containers/docker/docker-moby_git.bb b/recipes-containers/docker/docker-moby_git.bb index 40802353..b4576de9 100644 --- a/recipes-containers/docker/docker-moby_git.bb +++ b/recipes-containers/docker/docker-moby_git.bb | |||
@@ -44,14 +44,14 @@ DESCRIPTION = "Linux container runtime \ | |||
44 | # so we get that tag, and make it our SRCREVS: | 44 | # so we get that tag, and make it our SRCREVS: |
45 | # | 45 | # |
46 | 46 | ||
47 | SRCREV_moby = "f5334644ecc787861fef75c7f6d08756ffe8bbd7" | 47 | SRCREV_moby = "7fa33a539a2054417c8aacdd7f92e3f8e50f1dff" |
48 | SRCREV_libnetwork = "67e0588f1ddfaf2faf4c8cae8b7ea2876434d91c" | 48 | SRCREV_libnetwork = "67e0588f1ddfaf2faf4c8cae8b7ea2876434d91c" |
49 | SRCREV_cli = "6eb67bf57280491a7e03d0a499e890fe0b89c979" | 49 | SRCREV_cli = "d41cb083c352853f94b292a87df4859c4a96dcc2" |
50 | SRCREV_FORMAT = "moby_libnetwork" | 50 | SRCREV_FORMAT = "moby_libnetwork" |
51 | SRC_URI = "\ | 51 | SRC_URI = "\ |
52 | git://github.com/moby/moby.git;branch=26.1;name=moby;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX} \ | 52 | git://github.com/moby/moby.git;branch=27.0;name=moby;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX} \ |
53 | git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork;protocol=https \ | 53 | git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork;protocol=https \ |
54 | git://github.com/docker/cli;branch=26.1;name=cli;destsuffix=git/cli;protocol=https \ | 54 | git://github.com/docker/cli;branch=27.0;name=cli;destsuffix=git/cli;protocol=https \ |
55 | file://docker.init \ | 55 | file://docker.init \ |
56 | file://0001-libnetwork-use-GO-instead-of-go.patch \ | 56 | file://0001-libnetwork-use-GO-instead-of-go.patch \ |
57 | file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \ | 57 | file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \ |
@@ -66,7 +66,7 @@ require docker.inc | |||
66 | LICENSE = "Apache-2.0" | 66 | LICENSE = "Apache-2.0" |
67 | LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" | 67 | LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" |
68 | 68 | ||
69 | DOCKER_VERSION = "26.1.4" | 69 | DOCKER_VERSION = "27.0.3" |
70 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" | 70 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" |
71 | 71 | ||
72 | CVE_PRODUCT = "docker mobyproject:moby" | 72 | CVE_PRODUCT = "docker mobyproject:moby" |