diff options
author | Christopher Clark <christopher.w.clark@gmail.com> | 2017-09-17 18:22:53 -0700 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2017-09-19 09:22:55 -0400 |
commit | 6aa755e493c298afc2ee49685180746ffd9cf7d7 (patch) | |
tree | 1720469494b389f33421d30d86170e301b678c26 | |
parent | d16d4acc6059d05d94a4e319b801ce0272f17dd9 (diff) | |
download | meta-virtualization-6aa755e493c298afc2ee49685180746ffd9cf7d7.tar.gz |
xen-image-minimal: Make kernel-module-xen-pciback a x86-only dependency
This commit fixes the xen-image-minimal build for non-x86 arch with PCI enabled.
The Linux kernel option CONFIG_XEN_PCIDEV_BACKEND currently depends on X86.
This means that the xen-pciback kernel module cannot be included in this image
for non-x86 architecture builds, so don't attempt to install it in that case.
Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r-- | recipes-extended/images/xen-image-minimal.bb | 7 |
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-extended/images/xen-image-minimal.bb b/recipes-extended/images/xen-image-minimal.bb index 94240f69..a01976e7 100644 --- a/recipes-extended/images/xen-image-minimal.bb +++ b/recipes-extended/images/xen-image-minimal.bb | |||
@@ -10,12 +10,17 @@ IMAGE_INSTALL += " \ | |||
10 | kernel-module-xen-gntalloc \ | 10 | kernel-module-xen-gntalloc \ |
11 | kernel-module-xen-gntdev \ | 11 | kernel-module-xen-gntdev \ |
12 | kernel-module-xen-netback \ | 12 | kernel-module-xen-netback \ |
13 | ${@bb.utils.contains('MACHINE_FEATURES', 'pci', 'kernel-module-xen-pciback', '', d)} \ | ||
14 | kernel-module-xen-wdt \ | 13 | kernel-module-xen-wdt \ |
15 | xen-base \ | 14 | xen-base \ |
16 | qemu \ | 15 | qemu \ |
17 | " | 16 | " |
18 | 17 | ||
18 | # Linux kernel option CONFIG_XEN_PCIDEV_BACKEND depends on X86 | ||
19 | IMAGE_INSTALL_x86 += " \ | ||
20 | ${@bb.utils.contains('MACHINE_FEATURES', 'pci', 'kernel-module-xen-pciback', '', d)}" | ||
21 | IMAGE_INSTALL_x86-64 += " \ | ||
22 | ${@bb.utils.contains('MACHINE_FEATURES', 'pci', 'kernel-module-xen-pciback', '', d)}" | ||
23 | |||
19 | LICENSE = "MIT" | 24 | LICENSE = "MIT" |
20 | 25 | ||
21 | inherit core-image | 26 | inherit core-image |