diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-07-22 22:08:47 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-07-22 22:14:24 +0000 |
commit | 6c52d3e88b75e2b5e1a0230f684c8c156f23353a (patch) | |
tree | 2b2743f1a6bd074954f2310a7c1f96fe03393d24 | |
parent | 4e8568e32e516d87b5f24e4ec6e7af3a399fcb01 (diff) | |
download | meta-virtualization-6c52d3e88b75e2b5e1a0230f684c8c156f23353a.tar.gz |
ceph: fix gcc14 and 19.0.0 packaging issues
To fix the final gcc14 errors, we temporarily disable incompatible
type warnings on two python modules.
We also package a new systemd file and account for WORKDIR being
replaced by UNPACKDIR for patches.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
4 files changed, 88 insertions, 1 deletions
diff --git a/recipes-extended/ceph/ceph/0001-cepth-node-proxy-specify-entrypoint-executable.patch b/recipes-extended/ceph/ceph/0001-cepth-node-proxy-specify-entrypoint-executable.patch new file mode 100644 index 00000000..a4135fd1 --- /dev/null +++ b/recipes-extended/ceph/ceph/0001-cepth-node-proxy-specify-entrypoint-executable.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From cd7b184bad23a3a80f2ccf8acc7662d0079282d3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Mon, 22 Jul 2024 20:02:12 +0000 | ||
4 | Subject: [PATCH] cepth-node-proxy: specify entrypoint executable | ||
5 | |||
6 | Upstream-Status: Inappropriate [oe specific] | ||
7 | |||
8 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
9 | --- | ||
10 | src/ceph-node-proxy/setup.py | 1 + | ||
11 | 1 file changed, 1 insertion(+) | ||
12 | |||
13 | diff --git a/src/ceph-node-proxy/setup.py b/src/ceph-node-proxy/setup.py | ||
14 | index 7dcc7cdf5bf..f137c2e4307 100644 | ||
15 | --- a/src/ceph-node-proxy/setup.py | ||
16 | +++ b/src/ceph-node-proxy/setup.py | ||
17 | @@ -25,6 +25,7 @@ setup( | ||
18 | entry_points=dict( | ||
19 | console_scripts=[ | ||
20 | 'ceph-node-proxy = ceph_node_proxy.main:main', | ||
21 | + 'executable': 'python3', | ||
22 | ], | ||
23 | ), | ||
24 | classifiers=[ | ||
25 | -- | ||
26 | 2.39.2 | ||
27 | |||
diff --git a/recipes-extended/ceph/ceph/0001-rados-setup.py-allow-incompatible-pointer-types.patch b/recipes-extended/ceph/ceph/0001-rados-setup.py-allow-incompatible-pointer-types.patch new file mode 100644 index 00000000..a67e45b5 --- /dev/null +++ b/recipes-extended/ceph/ceph/0001-rados-setup.py-allow-incompatible-pointer-types.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 1b64bc536a3ea47c39e631409c833e99820ae7c2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Mon, 22 Jul 2024 21:01:17 +0000 | ||
4 | Subject: [PATCH] rados: setup.py allow incompatible pointer types | ||
5 | |||
6 | Upstream-Status: Inappropriate [oe specific] | ||
7 | |||
8 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
9 | --- | ||
10 | src/pybind/rados/setup.py | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/src/pybind/rados/setup.py b/src/pybind/rados/setup.py | ||
14 | index 74bf75b6ddc..87126ca8338 100755 | ||
15 | --- a/src/pybind/rados/setup.py | ||
16 | +++ b/src/pybind/rados/setup.py | ||
17 | @@ -30,7 +30,7 @@ def filter_unsupported_flags(compiler, flags): | ||
18 | f.startswith('-fcf-protection'), | ||
19 | flags)) | ||
20 | else: | ||
21 | - return flags | ||
22 | + return flags + [ "-Wno-error=incompatible-pointer-types" ] | ||
23 | |||
24 | |||
25 | def monkey_with_compiler(customize): | ||
26 | -- | ||
27 | 2.39.2 | ||
28 | |||
diff --git a/recipes-extended/ceph/ceph/0001-rgw-setup.py-allow-incompatible-pointer-types.patch b/recipes-extended/ceph/ceph/0001-rgw-setup.py-allow-incompatible-pointer-types.patch new file mode 100644 index 00000000..b21678a9 --- /dev/null +++ b/recipes-extended/ceph/ceph/0001-rgw-setup.py-allow-incompatible-pointer-types.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 84097fe398ee69172d4d9ae978ff0380fd6362cf Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Mon, 22 Jul 2024 20:43:50 +0000 | ||
4 | Subject: [PATCH] rgw: setup.py allow incompatible pointer types | ||
5 | |||
6 | Upstream-Status: Inappropriate [oe specific] | ||
7 | |||
8 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
9 | --- | ||
10 | src/pybind/rgw/setup.py | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/src/pybind/rgw/setup.py b/src/pybind/rgw/setup.py | ||
14 | index 74bf75b6ddc..87126ca8338 100755 | ||
15 | --- a/src/pybind/rgw/setup.py | ||
16 | +++ b/src/pybind/rgw/setup.py | ||
17 | @@ -30,7 +30,7 @@ def filter_unsupported_flags(compiler, flags): | ||
18 | f.startswith('-fcf-protection'), | ||
19 | flags)) | ||
20 | else: | ||
21 | - return flags | ||
22 | + return flags + [ "-Wno-error=incompatible-pointer-types" ] | ||
23 | |||
24 | |||
25 | def monkey_with_compiler(customize): | ||
26 | -- | ||
27 | 2.39.2 | ||
28 | |||
diff --git a/recipes-extended/ceph/ceph_git.bb b/recipes-extended/ceph/ceph_git.bb index c0b97e0e..36f4cccd 100644 --- a/recipes-extended/ceph/ceph_git.bb +++ b/recipes-extended/ceph/ceph_git.bb | |||
@@ -13,6 +13,9 @@ SRC_URI = "gitsm://github.com/ceph/ceph.git;protocol=https;branch=main \ | |||
13 | file://ceph.conf \ | 13 | file://ceph.conf \ |
14 | file://0001-delete-install-layout-deb.patch \ | 14 | file://0001-delete-install-layout-deb.patch \ |
15 | file://0001-cephadm-build.py-avoid-using-python3-from-sysroot-wh.patch \ | 15 | file://0001-cephadm-build.py-avoid-using-python3-from-sysroot-wh.patch \ |
16 | file://0001-cepth-node-proxy-specify-entrypoint-executable.patch \ | ||
17 | file://0001-rados-setup.py-allow-incompatible-pointer-types.patch \ | ||
18 | file://0001-rgw-setup.py-allow-incompatible-pointer-types.patch \ | ||
16 | " | 19 | " |
17 | 20 | ||
18 | SRCREV="103cd8e78bcfe7f69647013187c053c9ccb76685" | 21 | SRCREV="103cd8e78bcfe7f69647013187c053c9ccb76685" |
@@ -55,6 +58,7 @@ SYSTEMD_SERVICE:${PN} = " \ | |||
55 | ceph-mgr@.service \ | 58 | ceph-mgr@.service \ |
56 | ceph-mgr.target \ | 59 | ceph-mgr.target \ |
57 | ceph-crash.service \ | 60 | ceph-crash.service \ |
61 | ceph-exporter.service \ | ||
58 | rbdmap.service \ | 62 | rbdmap.service \ |
59 | ceph-immutable-object-cache@.service \ | 63 | ceph-immutable-object-cache@.service \ |
60 | ceph-immutable-object-cache.target \ | 64 | ceph-immutable-object-cache.target \ |
@@ -117,7 +121,7 @@ do_install:append () { | |||
117 | ${D}${sbindir}/ceph-volume ${D}${sbindir}/ceph-volume-systemd | 121 | ${D}${sbindir}/ceph-volume ${D}${sbindir}/ceph-volume-systemd |
118 | find ${D} -name SOURCES.txt | xargs sed -i -e 's:${WORKDIR}::' | 122 | find ${D} -name SOURCES.txt | xargs sed -i -e 's:${WORKDIR}::' |
119 | install -d ${D}${sysconfdir}/ceph | 123 | install -d ${D}${sysconfdir}/ceph |
120 | install -m 644 ${WORKDIR}/ceph.conf ${D}${sysconfdir}/ceph/ | 124 | install -m 644 ${UNPACKDIR}/ceph.conf ${D}${sysconfdir}/ceph/ |
121 | install -d ${D}${systemd_unitdir} | 125 | install -d ${D}${systemd_unitdir} |
122 | mv ${D}${libexecdir}/ceph/ceph-osd-prestart.sh ${D}${libdir}/ceph | 126 | mv ${D}${libexecdir}/ceph/ceph-osd-prestart.sh ${D}${libdir}/ceph |
123 | mv ${D}${libexecdir}/ceph/ceph_common.sh ${D}${libdir}/ceph | 127 | mv ${D}${libexecdir}/ceph/ceph_common.sh ${D}${libdir}/ceph |