diff options
author | Mark Asselstine <mark.asselstine@windriver.com> | 2013-11-19 12:20:45 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2013-11-19 23:29:51 -0500 |
commit | 6e915099cc1d6f81fb7aee82dc69a290a3eb777c (patch) | |
tree | 28c819cee1c86044ef0d162bf83a22e963cb79c4 | |
parent | ad150f5655400fbc020ff56d79005365f4819f10 (diff) | |
download | meta-virtualization-6e915099cc1d6f81fb7aee82dc69a290a3eb777c.tar.gz |
openvswitch: deal with missing RDEPENDS of libpcap
Bitbake was properly detecting a dependency on libpcap but since it
was not an explicit RDEPENDS the libpcap package was not being built
in all cases which had the potential to break rootfs image building.
The obvious solution was to add libpcap to the RDEPENDS but looking
upstream it was found that they have removed the use of this library
for all but FreeBSD since for other systems it is unused. So using the
upstream patch here eliminates the dependency and in turn the issue
described above.
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r-- | recipes-networking/openvswitch/files/configure-Only-link-against-libpcap-on-FreeBSD.patch | 70 | ||||
-rw-r--r-- | recipes-networking/openvswitch/openvswitch_1.10.0.bb | 3 |
2 files changed, 72 insertions, 1 deletions
diff --git a/recipes-networking/openvswitch/files/configure-Only-link-against-libpcap-on-FreeBSD.patch b/recipes-networking/openvswitch/files/configure-Only-link-against-libpcap-on-FreeBSD.patch new file mode 100644 index 00000000..0a44b85e --- /dev/null +++ b/recipes-networking/openvswitch/files/configure-Only-link-against-libpcap-on-FreeBSD.patch | |||
@@ -0,0 +1,70 @@ | |||
1 | From d30e714ccb9d13caf39d14d5b2fc9523b678ed51 Mon Sep 17 00:00:00 2001 | ||
2 | From: Ben Pfaff <blp@nicira.com> | ||
3 | Date: Thu, 14 Mar 2013 15:20:55 -0700 | ||
4 | Subject: [PATCH] configure: Only link against libpcap on FreeBSD. | ||
5 | |||
6 | commit d30e714ccb9d13caf39d14d5b2fc9523b678ed51 upstream | ||
7 | http://git.openvswitch.org/git/openvswitch | ||
8 | |||
9 | On other platforms there is no benefit to linking against libpcap, because | ||
10 | it is not used. | ||
11 | |||
12 | Signed-off-by: Ben Pfaff <blp@nicira.com> | ||
13 | CC: Ed Maste <emaste@freebsd.org> | ||
14 | --- | ||
15 | acinclude.m4 | 7 ++++++- | ||
16 | configure.ac | 3 +-- | ||
17 | 2 files changed, 7 insertions(+), 3 deletions(-) | ||
18 | |||
19 | diff --git a/acinclude.m4 b/acinclude.m4 | ||
20 | index f0610c9..19a47dd 100644 | ||
21 | --- a/acinclude.m4 | ||
22 | +++ b/acinclude.m4 | ||
23 | @@ -1,6 +1,6 @@ | ||
24 | # -*- autoconf -*- | ||
25 | |||
26 | -# Copyright (c) 2008, 2009, 2010, 2011, 2012 Nicira, Inc. | ||
27 | +# Copyright (c) 2008, 2009, 2010, 2011, 2012, 2013 Nicira, Inc. | ||
28 | # | ||
29 | # Licensed under the Apache License, Version 2.0 (the "License"); | ||
30 | # you may not use this file except in compliance with the License. | ||
31 | @@ -295,6 +295,8 @@ AC_DEFUN([OVS_CHECK_IF_PACKET], | ||
32 | fi]) | ||
33 | |||
34 | dnl Checks for net/if_dl.h. | ||
35 | +dnl | ||
36 | +dnl (We use this as a proxy for checking whether we're building on FreeBSD.) | ||
37 | AC_DEFUN([OVS_CHECK_IF_DL], | ||
38 | [AC_CHECK_HEADER([net/if_dl.h], | ||
39 | [HAVE_IF_DL=yes], | ||
40 | @@ -303,6 +305,9 @@ AC_DEFUN([OVS_CHECK_IF_DL], | ||
41 | if test "$HAVE_IF_DL" = yes; then | ||
42 | AC_DEFINE([HAVE_IF_DL], [1], | ||
43 | [Define to 1 if net/if_dl.h is available.]) | ||
44 | + | ||
45 | + # On FreeBSD we use libpcap to access network devices. | ||
46 | + AC_SEARCH_LIBS([pcap_open_live], [pcap]) | ||
47 | fi]) | ||
48 | |||
49 | dnl Checks for buggy strtok_r. | ||
50 | diff --git a/configure.ac b/configure.ac | ||
51 | index 1cacd29..bd49179 100644 | ||
52 | --- a/configure.ac | ||
53 | +++ b/configure.ac | ||
54 | @@ -1,4 +1,4 @@ | ||
55 | -# Copyright (c) 2008, 2009, 2010, 2011, 2012 Nicira, Inc. | ||
56 | +# Copyright (c) 2008, 2009, 2010, 2011, 2012, 2013 Nicira, Inc. | ||
57 | # | ||
58 | # Licensed under the Apache License, Version 2.0 (the "License"); | ||
59 | # you may not use this file except in compliance with the License. | ||
60 | @@ -44,7 +44,6 @@ AC_SYS_LARGEFILE | ||
61 | AC_SEARCH_LIBS([pow], [m]) | ||
62 | AC_SEARCH_LIBS([clock_gettime], [rt]) | ||
63 | AC_SEARCH_LIBS([timer_create], [rt]) | ||
64 | -AC_SEARCH_LIBS([pcap_open_live], [pcap]) | ||
65 | |||
66 | OVS_CHECK_ESX | ||
67 | OVS_CHECK_COVERAGE | ||
68 | -- | ||
69 | 1.8.3.2 | ||
70 | |||
diff --git a/recipes-networking/openvswitch/openvswitch_1.10.0.bb b/recipes-networking/openvswitch/openvswitch_1.10.0.bb index 02c8ab3d..c0ea8290 100644 --- a/recipes-networking/openvswitch/openvswitch_1.10.0.bb +++ b/recipes-networking/openvswitch/openvswitch_1.10.0.bb | |||
@@ -18,7 +18,7 @@ RRECOMMENDS_${PN} += "kernel-module-openvswitch" | |||
18 | # rdeps. E.g. ovs-pki calls sed in the postinstall. sed may be | 18 | # rdeps. E.g. ovs-pki calls sed in the postinstall. sed may be |
19 | # queued for install later. | 19 | # queued for install later. |
20 | RDEPENDS_${PN} += "sed gawk grep" | 20 | RDEPENDS_${PN} += "sed gawk grep" |
21 | PR = "r3" | 21 | PR = "r4" |
22 | 22 | ||
23 | SRC_URI = "http://openvswitch.org/releases/openvswitch-${PV}.tar.gz \ | 23 | SRC_URI = "http://openvswitch.org/releases/openvswitch-${PV}.tar.gz \ |
24 | file://openvswitch-switch \ | 24 | file://openvswitch-switch \ |
@@ -27,6 +27,7 @@ SRC_URI = "http://openvswitch.org/releases/openvswitch-${PV}.tar.gz \ | |||
27 | file://openvswitch-controller-setup \ | 27 | file://openvswitch-controller-setup \ |
28 | file://openvswitch-add-target-python-handling.patch \ | 28 | file://openvswitch-add-target-python-handling.patch \ |
29 | file://openvswitch-add-target-perl-handling.patch \ | 29 | file://openvswitch-add-target-perl-handling.patch \ |
30 | file://configure-Only-link-against-libpcap-on-FreeBSD.patch \ | ||
30 | " | 31 | " |
31 | 32 | ||
32 | SRC_URI[md5sum] = "fe8b49efe9f86b57abab00166b971106" | 33 | SRC_URI[md5sum] = "fe8b49efe9f86b57abab00166b971106" |