summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2025-02-11 23:17:31 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2025-02-11 23:19:51 +0000
commit70790134547d8722a682cc1a2a4f4bc11ab8f110 (patch)
treed054bd6998d8eb015037168032a05128b68dc21b
parentfc423a7cb882553fe4a29a23e6135c9f1cc8e4d0 (diff)
downloadmeta-virtualization-70790134547d8722a682cc1a2a4f4bc11ab8f110.tar.gz
kernel: drop 6.6 support
It could be argued that we could keep the fragments and virtualization .inc file for old versions, as they won't trigger and immediate issue for configurations that are using the older supported kernel versions. BUT, we could extend that comment to any / all versions ever supported by OEcore. Since 6.6 isn't actively being tested in master, let's drop all the references and only have 6.12 active. If someone does need the older kernel support, then the support could be restored. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_6.6.bbappend6
-rw-r--r--recipes-kernel/linux/linux-yocto_6.6_virtualization.inc4
-rw-r--r--recipes-kernel/linux/yocto-cfg-fragments-6.6.bb37
3 files changed, 0 insertions, 47 deletions
diff --git a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_6.6.bbappend b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_6.6.bbappend
deleted file mode 100644
index 2e2f92b6..00000000
--- a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto_6.6.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
1# Enable use of the linux-yocto kernel for the Raspberry Pi 4
2KBRANCH:raspberrypi4-64 ?= "v6.6/standard/bcm-2xxx-rpi"
3KMACHINE:raspberrypi4-64 ?= "bcm-2xxx-rpi4"
4COMPATIBLE_MACHINE:raspberrypi4-64 = "(raspberrypi4-64)"
5
6require linux-yocto_xen-rpi.inc
diff --git a/recipes-kernel/linux/linux-yocto_6.6_virtualization.inc b/recipes-kernel/linux/linux-yocto_6.6_virtualization.inc
deleted file mode 100644
index 59311487..00000000
--- a/recipes-kernel/linux/linux-yocto_6.6_virtualization.inc
+++ /dev/null
@@ -1,4 +0,0 @@
1# include the baseline meta virtualization configuration options
2# after this include, we can do version specific things
3
4include linux-yocto_virtualization.inc
diff --git a/recipes-kernel/linux/yocto-cfg-fragments-6.6.bb b/recipes-kernel/linux/yocto-cfg-fragments-6.6.bb
deleted file mode 100644
index 6bdc0d03..00000000
--- a/recipes-kernel/linux/yocto-cfg-fragments-6.6.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1HOMEPAGE = "https://git.yoctoproject.org/cgit/cgit.cgi/yocto-kernel-cache/"
2SUMMARY = "Kernel configuration fragments"
3DESCRIPTION = "Typically used as part of a kernel clone, this is the standalone \
4fragment repository. Making it available to other fragment management schemes \
5"
6SECTION = "devel"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
10
11do_configure[noexec] = "1"
12do_compile[noexec] = "1"
13INHIBIT_DEFAULT_DEPS = "1"
14
15LINUX_VERSION ?= "6.6"
16PV = "v${LINUX_VERSION}+git${SRCREV}"
17
18SRCREV = "4a494b202029e94a72ebb3c3966d9f1d249900f3"
19SRC_URI = "\
20 git://git.yoctoproject.org/yocto-kernel-cache;branch=yocto-${LINUX_VERSION} \
21 "
22
23S = "${WORKDIR}/git"
24
25do_install() {
26 install -d ${D}${base_prefix}/kcfg
27
28 # copy the configuration fragments over to the native deploy
29 cp -r ${S}/* ${D}${base_prefix}/kcfg
30 # scripts bring in a bash dependency we don't want
31 rm -rf ${D}${base_prefix}/kcfg/scripts
32}
33
34FILES:${PN} += "kcfg/"
35SYSROOT_DIRS += "${base_prefix}/kcfg"
36BBCLASSEXTEND = "native nativesdk"
37