summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-10-29 20:20:18 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-11-15 19:50:00 +0000
commit718da5ae40540ced4fc48791a84dde9053376d85 (patch)
treeed5e5efd17761f15b02e4223f7eecdaf08aa9b8b
parent9f88821d801873f7c322df0c9957e05dbd9eeb49 (diff)
downloadmeta-virtualization-718da5ae40540ced4fc48791a84dde9053376d85.tar.gz
containerd: make network configuration a conflist
parsing errors occur if this fragment ends with .conf, so we renamed it to make sure it is processed as a conflist. Tested with containerd + nerdctl Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/containerd/containerd_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-containers/containerd/containerd_git.bb b/recipes-containers/containerd/containerd_git.bb
index 5f106a67..ffe447c8 100644
--- a/recipes-containers/containerd/containerd_git.bb
+++ b/recipes-containers/containerd/containerd_git.bb
@@ -9,7 +9,7 @@ SRCREV = "19430264c19b8bd9f940101ec71d52ab2d2e54d5"
9SRC_URI = "git://github.com/containerd/containerd;branch=main;protocol=https;destsuffix=git/src/github.com/containerd/containerd/v2 \ 9SRC_URI = "git://github.com/containerd/containerd;branch=main;protocol=https;destsuffix=git/src/github.com/containerd/containerd/v2 \
10 file://0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch \ 10 file://0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch \
11 file://0001-build-don-t-use-gcflags-to-define-trimpath.patch \ 11 file://0001-build-don-t-use-gcflags-to-define-trimpath.patch \
12 file://cni-containerd-net.conf \ 12 file://cni-containerd-net.conflist \
13 " 13 "
14 14
15# Apache-2.0 for containerd 15# Apache-2.0 for containerd
@@ -101,5 +101,5 @@ RDEPENDS:${PN} += " ${VIRTUAL-RUNTIME_container_runtime}"
101 101
102## This may need to be made conditional on K3S or similar being 102## This may need to be made conditional on K3S or similar being
103## configured in the distro, since we may have collisions. 103## configured in the distro, since we may have collisions.
104CNI_NETWORKING_FILES ?= "${UNPACKDIR}/cni-containerd-net.conf" 104CNI_NETWORKING_FILES ?= "${UNPACKDIR}/cni-containerd-net.conflist"
105inherit cni_networking 105inherit cni_networking