diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2020-03-03 23:11:34 +0100 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-03-03 20:03:22 -0500 |
commit | 7251b240d1bd177e70d309c318b1ebe35cbe0e69 (patch) | |
tree | 30b09b6c4f21a67287b6abfc0cc13273e6c88b76 | |
parent | cf6d398d51e5174350e5b32536c4004ba3c6829f (diff) | |
download | meta-virtualization-7251b240d1bd177e70d309c318b1ebe35cbe0e69.tar.gz |
docker-moby: fix DOCKER_GITCOMMIT
* SRCREV_docker isn't defined in docker-moby recipes at all
so it passes unexpanded ${SRCREV_docker} as noticed in
error log:
| ERROR: Execution of 'work/raspberrypi4-oe-linux-gnueabi/docker-moby/19.03.6+git71373c6105e3cbc9702935b96d8ee01214c405e7-r0/temp/run.do_compile.31754' failed with exit code 2:
|
| Package devmapper was not found in the pkg-config search path.
| Perhaps you should add the directory containing `devmapper.pc'
| to the PKG_CONFIG_PATH environment variable
| No package 'devmapper' found
| Removing bundles/
|
| ---> Making bundle: dynbinary (in bundles/dynbinary)
| Building: bundles/dynbinary-daemon/dockerd-19.03.6
| GOOS="linux" GOARCH="arm" GOARM="7"
| # runtime/cgo
| exec: "arm-linux-gnueabihf-gcc": executable file not found in $PATH
| WARNING: work/raspberrypi4-oe-linux-gnueabi/docker-moby/19.03.6+git71373c6105e3cbc9702935b96d8ee01214c405e7-r0/temp/run.do_compile.31754:1 exit 2 from 'VERSION="19.03.6" DOCKER_GITCOMMIT="${SRCREV_docker}" ./hack/make.sh dynbinary'
| ERROR: Task (meta-virtualization/recipes-containers/docker/docker-moby.bb:do_compile) failed with exit code '1'
this build issue is somehow caused by recent upgrade:
http://git.yoctoproject.org/cgit/cgit.cgi/meta-virtualization/commit/?id=f770151b3ff0938bea4972abdd1ee7f6cbc3a074
and this build error is not fixed by this change, but
see 2nd to last line which shows
DOCKER_GITCOMMIT="${SRCREV_docker}"
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/docker/docker-moby.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-containers/docker/docker-moby.bb b/recipes-containers/docker/docker-moby.bb index b29c4b34..a8c5946e 100644 --- a/recipes-containers/docker/docker-moby.bb +++ b/recipes-containers/docker/docker-moby.bb | |||
@@ -101,14 +101,14 @@ do_compile() { | |||
101 | # this is the unsupported built structure | 101 | # this is the unsupported built structure |
102 | # that doesn't rely on an existing docker | 102 | # that doesn't rely on an existing docker |
103 | # to build this: | 103 | # to build this: |
104 | VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_docker}" ./hack/make.sh dynbinary | 104 | VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_moby}" ./hack/make.sh dynbinary |
105 | 105 | ||
106 | # build the cli | 106 | # build the cli |
107 | cd ${S}/src/import/.gopath/src/github.com/docker/cli | 107 | cd ${S}/src/import/.gopath/src/github.com/docker/cli |
108 | export CFLAGS="" | 108 | export CFLAGS="" |
109 | export LDFLAGS="" | 109 | export LDFLAGS="" |
110 | export DOCKER_VERSION=${DOCKER_VERSION} | 110 | export DOCKER_VERSION=${DOCKER_VERSION} |
111 | VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_docker}" make dynbinary | 111 | VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_moby}" make dynbinary |
112 | 112 | ||
113 | # build the proxy | 113 | # build the proxy |
114 | cd ${S}/src/import/.gopath/src/github.com/docker/libnetwork | 114 | cd ${S}/src/import/.gopath/src/github.com/docker/libnetwork |