diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-06-18 10:44:59 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-06-18 10:44:59 -0400 |
commit | 73fff505780467b7bd3d58ccbd39a22332849e41 (patch) | |
tree | a4ca0bf3c55bf6cc23829edc6c2d45f9a5a51d80 | |
parent | 9765cee9e9b55168c539c7bc17323d4ad2e7a995 (diff) | |
download | meta-virtualization-73fff505780467b7bd3d58ccbd39a22332849e41.tar.gz |
runx: update to v5.4 kernel
Updating to the tip of the runx repository. This brings in some build
changes, as well as introducing the v5.4 kernel.
Our patches for cross compilation need to be tweaked to the new
structure, as well as the install task to pickup the new location
of some files.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
3 files changed, 27 insertions, 33 deletions
diff --git a/recipes-core/runx/runx/0001-make-initrd-cross-install-tweaks.patch b/recipes-core/runx/runx/0001-make-initrd-cross-install-tweaks.patch index c9fdc5d6..43c621e0 100644 --- a/recipes-core/runx/runx/0001-make-initrd-cross-install-tweaks.patch +++ b/recipes-core/runx/runx/0001-make-initrd-cross-install-tweaks.patch | |||
@@ -8,15 +8,15 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@xilinx.com> | |||
8 | kernel/make-initrd | 18 ++++++++++++++++-- | 8 | kernel/make-initrd | 18 ++++++++++++++++-- |
9 | 1 file changed, 16 insertions(+), 2 deletions(-) | 9 | 1 file changed, 16 insertions(+), 2 deletions(-) |
10 | 10 | ||
11 | diff --git a/kernel/make-initrd b/kernel/make-initrd | 11 | Index: git/initrd/make-initrd |
12 | index 4c299dc..9ef386f 100755 | 12 | =================================================================== |
13 | --- a/kernel/make-initrd | 13 | --- git.orig/initrd/make-initrd |
14 | +++ b/kernel/make-initrd | 14 | +++ git/initrd/make-initrd |
15 | @@ -16,8 +16,22 @@ mkdir -p $tmpdir/sys | 15 | @@ -23,8 +23,22 @@ |
16 | mkdir -p $tmpdir/lib | 16 | mkdir -p $tmpdir/lib |
17 | mkdir -p $tmpdir/var | 17 | mkdir -p $tmpdir/var |
18 | mkdir -p $tmpdir/mnt | 18 | mkdir -p $tmpdir/mnt |
19 | -cp `which busybox` $tmpdir/bin | 19 | -cp "$busybox" $tmpdir/bin/busybox |
20 | -$tmpdir/bin/busybox --install $tmpdir/bin | 20 | -$tmpdir/bin/busybox --install $tmpdir/bin |
21 | + | 21 | + |
22 | + | 22 | + |
@@ -35,8 +35,5 @@ index 4c299dc..9ef386f 100755 | |||
35 | + $tmpdir/bin/busybox --install $tmpdir/bin | 35 | + $tmpdir/bin/busybox --install $tmpdir/bin |
36 | +fi | 36 | +fi |
37 | 37 | ||
38 | cp $init $tmpdir/init | 38 | mkdir -p $tmpdir/etc/init.d |
39 | chmod +x $tmpdir/init | 39 | cp $init $tmpdir/etc/init.d/rcS |
40 | -- | ||
41 | 2.17.1 | ||
42 | |||
diff --git a/recipes-core/runx/runx/0001-make-kernel-cross-compilation-tweaks.patch b/recipes-core/runx/runx/0001-make-kernel-cross-compilation-tweaks.patch index 7d66f421..2821b61b 100644 --- a/recipes-core/runx/runx/0001-make-kernel-cross-compilation-tweaks.patch +++ b/recipes-core/runx/runx/0001-make-kernel-cross-compilation-tweaks.patch | |||
@@ -8,11 +8,11 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@xilinx.com> | |||
8 | kernel/make-kernel | 41 +++++++++++++++++++++++++++++++++-------- | 8 | kernel/make-kernel | 41 +++++++++++++++++++++++++++++++++-------- |
9 | 1 file changed, 33 insertions(+), 8 deletions(-) | 9 | 1 file changed, 33 insertions(+), 8 deletions(-) |
10 | 10 | ||
11 | diff --git a/kernel/make-kernel b/kernel/make-kernel | 11 | Index: git/kernel/make-kernel |
12 | index 33b7150..c684669 100755 | 12 | =================================================================== |
13 | --- a/kernel/make-kernel | 13 | --- git.orig/kernel/make-kernel |
14 | +++ b/kernel/make-kernel | 14 | +++ git/kernel/make-kernel |
15 | @@ -13,6 +13,7 @@ fi | 15 | @@ -13,6 +13,7 @@ |
16 | 16 | ||
17 | kernel_stuffdir=`readlink -f kernel` | 17 | kernel_stuffdir=`readlink -f kernel` |
18 | kernel_outpath=$kernel_stuffdir/out | 18 | kernel_outpath=$kernel_stuffdir/out |
@@ -20,9 +20,9 @@ index 33b7150..c684669 100755 | |||
20 | kernel_builddir=$kernel_stuffdir/build | 20 | kernel_builddir=$kernel_stuffdir/build |
21 | kernel_out=$kernel_outpath/kernel | 21 | kernel_out=$kernel_outpath/kernel |
22 | 22 | ||
23 | @@ -22,28 +23,52 @@ kernel_tarball="$kernel_name".tar.xz | 23 | @@ -22,28 +23,52 @@ |
24 | kernel_url=https://www.kernel.org/pub/linux/kernel/v4.x/"$kernel_tarball" | 24 | kernel_url=https://www.kernel.org/pub/linux/kernel/v5.x/"$kernel_tarball" |
25 | kernel_src_config="$kernel_stuffdir"/cutdown-config.$ARCH | 25 | kernel_src_config="$kernel_stuffdir"/cutdown-config."$ARCH" |
26 | kernel_patchesdir="$kernel_stuffdir"/patches | 26 | kernel_patchesdir="$kernel_stuffdir"/patches |
27 | -kernel_image="$kernel_builddir"/"$kernel_name"/arch/"$ARCH"/boot/"$image" | 27 | -kernel_image="$kernel_builddir"/"$kernel_name"/arch/"$ARCH"/boot/"$image" |
28 | +kernel_image="$kernel_builddir"/arch/"$ARCH"/boot/"$image" | 28 | +kernel_image="$kernel_builddir"/arch/"$ARCH"/boot/"$image" |
@@ -66,10 +66,10 @@ index 33b7150..c684669 100755 | |||
66 | do | 66 | do |
67 | patch -p1 < $i | 67 | patch -p1 < $i |
68 | done | 68 | done |
69 | - cp $kernel_src_config .config | ||
70 | fi | 69 | fi |
71 | -cd $kernel_builddir/$kernel_name | 70 | -cd $kernel_builddir/$kernel_name |
72 | -make -j4 $image | 71 | -cp $kernel_src_config .config |
72 | -make -j "$(getconf _NPROCESSORS_ONLN)" $image | ||
73 | +if [[ ! -f $kernel_builddir/.config ]] | 73 | +if [[ ! -f $kernel_builddir/.config ]] |
74 | +then | 74 | +then |
75 | + cp $kernel_src_config $kernel_builddir/.config | 75 | + cp $kernel_src_config $kernel_builddir/.config |
@@ -78,9 +78,6 @@ index 33b7150..c684669 100755 | |||
78 | + | 78 | + |
79 | +echo "building the kernel ..." | 79 | +echo "building the kernel ..." |
80 | +eval make O=$kernel_builddir $build_vars oldconfig | 80 | +eval make O=$kernel_builddir $build_vars oldconfig |
81 | +eval make -j4 O=$kernel_builddir $build_vars $image | 81 | +eval make -j "$(getconf _NPROCESSORS_ONLN)" O=$kernel_builddir $build_vars $image |
82 | 82 | ||
83 | cp $kernel_image $kernel_out | 83 | cp $kernel_image $kernel_out |
84 | -- | ||
85 | 2.17.1 | ||
86 | |||
diff --git a/recipes-core/runx/runx_git.bb b/recipes-core/runx/runx_git.bb index 3b4cd335..991e6e1f 100644 --- a/recipes-core/runx/runx_git.bb +++ b/recipes-core/runx/runx_git.bb | |||
@@ -2,15 +2,15 @@ HOMEPAGE = "https://github.com/lf-edge/runx" | |||
2 | SUMMARY = "runx stuff" | 2 | SUMMARY = "runx stuff" |
3 | DESCRIPTION = "Xen Runtime for OCI" | 3 | DESCRIPTION = "Xen Runtime for OCI" |
4 | 4 | ||
5 | SRCREV_runx = "da0c75c58ae5232d19b1791c33545db3225e1ea9" | 5 | SRCREV_runx = "f24efd33fb18469e9cfe4d1bfe8e2c90ec8c4e93" |
6 | SRC_URI = "\ | 6 | SRC_URI = "\ |
7 | git://github.com/lf-edge/runx;nobranch=1;name=runx \ | 7 | git://github.com/lf-edge/runx;nobranch=1;name=runx \ |
8 | https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.15.tar.xz;destsuffix=git/kernel/build \ | 8 | https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.4.tar.xz;destsuffix=git/kernel/build \ |
9 | file://0001-make-kernel-cross-compilation-tweaks.patch \ | 9 | file://0001-make-kernel-cross-compilation-tweaks.patch \ |
10 | file://0001-make-initrd-cross-install-tweaks.patch \ | 10 | file://0001-make-initrd-cross-install-tweaks.patch \ |
11 | " | 11 | " |
12 | SRC_URI[md5sum] = "0d701ac1e2a67d47ce7127432df2c32b" | 12 | SRC_URI[md5sum] = "ce9b2d974d27408a61c53a30d3f98fb9" |
13 | SRC_URI[sha256sum] = "5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769" | 13 | SRC_URI[sha256sum] = "bf338980b1670bca287f9994b7441c2361907635879169c64ae78364efc5f491" |
14 | 14 | ||
15 | LICENSE = "Apache-2.0" | 15 | LICENSE = "Apache-2.0" |
16 | LIC_FILES_CHKSUM = "file://LICENSE;md5=945fc9aa694796a6337395cc291ddd8c" | 16 | LIC_FILES_CHKSUM = "file://LICENSE;md5=945fc9aa694796a6337395cc291ddd8c" |
@@ -31,7 +31,7 @@ DEPENDS = "busybox go-build" | |||
31 | 31 | ||
32 | # for the kernel build phase | 32 | # for the kernel build phase |
33 | DEPENDS += "openssl-native coreutils-native util-linux-native xz-native bc-native" | 33 | DEPENDS += "openssl-native coreutils-native util-linux-native xz-native bc-native" |
34 | DEPENDS += "qemu-native" | 34 | DEPENDS += "qemu-native bison-native" |
35 | 35 | ||
36 | RDEPENDS_${PN} += " jq bash" | 36 | RDEPENDS_${PN} += " jq bash" |
37 | RDEPENDS_${PN} += " xen-tools-xl go-build socat daemonize" | 37 | RDEPENDS_${PN} += " xen-tools-xl go-build socat daemonize" |
@@ -77,7 +77,7 @@ do_compile() { | |||
77 | export QEMU_USER=`which qemu-${HOST_ARCH}` | 77 | export QEMU_USER=`which qemu-${HOST_ARCH}` |
78 | export BUSYBOX="${WORKDIR}/busybox" | 78 | export BUSYBOX="${WORKDIR}/busybox" |
79 | export CROSS_COMPILE="t" | 79 | export CROSS_COMPILE="t" |
80 | ${S}/kernel/make-initrd | 80 | ${S}/initrd/make-initrd |
81 | } | 81 | } |
82 | 82 | ||
83 | do_install() { | 83 | do_install() { |
@@ -86,11 +86,11 @@ do_install() { | |||
86 | 86 | ||
87 | install -d ${D}${datadir}/runX | 87 | install -d ${D}${datadir}/runX |
88 | install -m 755 ${S}/kernel/out/kernel ${D}/${datadir}/runX | 88 | install -m 755 ${S}/kernel/out/kernel ${D}/${datadir}/runX |
89 | install -m 755 ${S}/kernel/out/initrd ${D}/${datadir}/runX | 89 | install -m 755 ${S}/initrd/out/initrd ${D}/${datadir}/runX |
90 | install -m 755 ${S}/files/start ${D}/${datadir}/runX | 90 | install -m 755 ${S}/files/start ${D}/${datadir}/runX |
91 | install -m 755 ${S}/files/create ${D}/${datadir}/runX | ||
91 | install -m 755 ${S}/files/state ${D}/${datadir}/runX | 92 | install -m 755 ${S}/files/state ${D}/${datadir}/runX |
92 | install -m 755 ${S}/files/delete ${D}/${datadir}/runX | 93 | install -m 755 ${S}/files/delete ${D}/${datadir}/runX |
93 | install -m 755 ${S}/files/serial_bridge ${D}/${datadir}/runX | ||
94 | install -m 755 ${S}/files/serial_start ${D}/${datadir}/runX | 94 | install -m 755 ${S}/files/serial_start ${D}/${datadir}/runX |
95 | 95 | ||
96 | 96 | ||