diff options
author | Chen Qi <Qi.Chen@windriver.com> | 2025-01-14 21:46:38 -0800 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2025-01-17 19:17:09 +0000 |
commit | 7834a259adaca56f707cfa29d3093b75ddff9b11 (patch) | |
tree | da6a48ee49098b37ccd458052bd358ba5ac77cb3 | |
parent | af1d32686e8d9468e43e9ca8ddf427d84cf830d4 (diff) | |
download | meta-virtualization-7834a259adaca56f707cfa29d3093b75ddff9b11.tar.gz |
cri-o: fix already-stripped QA issue and clean up
Set DEBUG=1 to avoid stripping.
See https://github.com/cri-o/cri-o/blob/main/Makefile#L93
Set STRIP=true to avoid stripping bin/pinns.
See https://github.com/cri-o/cri-o/blob/main/pinns/Makefile#L4
ALLOW_EMPTY:${PN} = "1" is not needed. Remove it.
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/cri-o/cri-o_git.bb | 8 |
1 files changed, 3 insertions, 5 deletions
diff --git a/recipes-containers/cri-o/cri-o_git.bb b/recipes-containers/cri-o/cri-o_git.bb index 9dd37da8..6fdd58a1 100644 --- a/recipes-containers/cri-o/cri-o_git.bb +++ b/recipes-containers/cri-o/cri-o_git.bb | |||
@@ -60,7 +60,7 @@ inherit goarch | |||
60 | inherit pkgconfig | 60 | inherit pkgconfig |
61 | inherit container-host | 61 | inherit container-host |
62 | 62 | ||
63 | EXTRA_OEMAKE="BUILDTAGS=''" | 63 | EXTRA_OEMAKE = "BUILDTAGS='' DEBUG=1 STRIP=true" |
64 | 64 | ||
65 | do_compile() { | 65 | do_compile() { |
66 | set +e | 66 | set +e |
@@ -115,15 +115,13 @@ do_install_ptest() { | |||
115 | cp -rf ${S}/src/import/test ${D}${PTEST_PATH} | 115 | cp -rf ${S}/src/import/test ${D}${PTEST_PATH} |
116 | cp -rf ${S}/src/import/bin ${D}${PTEST_PATH} | 116 | cp -rf ${S}/src/import/bin ${D}${PTEST_PATH} |
117 | } | 117 | } |
118 | |||
118 | FILES:${PN}-config = "${sysconfdir}/crio/config/*" | 119 | FILES:${PN}-config = "${sysconfdir}/crio/config/*" |
119 | FILES:${PN} += "${systemd_unitdir}/system/*" | 120 | FILES:${PN} += "${systemd_unitdir}/system/*" |
120 | FILES:${PN} += "/usr/local/bin/*" | 121 | FILES:${PN} += "/usr/local/bin/*" |
121 | FILES:${PN} += "/usr/share/containers/oci/hooks.d" | 122 | FILES:${PN} += "/usr/share/containers/oci/hooks.d" |
122 | 123 | ||
123 | # don't clobber hooks.d | 124 | INSANE_SKIP:${PN} += "ldflags textrel" |
124 | ALLOW_EMPTY:${PN} = "1" | ||
125 | |||
126 | INSANE_SKIP:${PN} += "ldflags already-stripped textrel" | ||
127 | INSANE_SKIP:${PN}-ptest += "textrel" | 125 | INSANE_SKIP:${PN}-ptest += "textrel" |
128 | 126 | ||
129 | RDEPENDS:${PN}-ptest += " \ | 127 | RDEPENDS:${PN}-ptest += " \ |