summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-03-01 11:37:40 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-03-01 15:57:20 -0500
commit7aee7a31ed93d788fa89164255212b87b1cedd3d (patch)
tree2ce3c429a3de0fea200d6c1c9ce650f6a3a9c92a
parentec60660c3c19a08357f6cc755c1a5c2f0df88714 (diff)
downloadmeta-virtualization-7aee7a31ed93d788fa89164255212b87b1cedd3d.tar.gz
oci-runtime-tools: export GO111MODULE=off
With the latest go version bump in oe-core export GO111MODULE is on by default. Our build is not setup to use go modules, so we disable it and avoid configuration errors: no required module provides package ... : working directory is not part of a module Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
index a0ccb85c..7f194027 100644
--- a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
+++ b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
@@ -29,6 +29,7 @@ do_compile() {
29 export LDFLAGS="" 29 export LDFLAGS=""
30 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 30 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
31 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 31 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
32 export GO111MODULE=off
32 33
33 # link fixups for compilation 34 # link fixups for compilation
34 rm -f ${S}/src/import/vendor/src 35 rm -f ${S}/src/import/vendor/src