summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeith Holman <Keith.Holman@windriver.com>2014-08-20 16:46:08 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-08-22 14:42:55 -0400
commit7b424fa19e7a8d3aaac9e7535ee113efc4931765 (patch)
tree2163cf4e6d702385a8bf4566e1de34072efa6279
parent8bbaf80f47c7c14b1e9a42e5c328b9dfad97b9db (diff)
downloadmeta-virtualization-7b424fa19e7a8d3aaac9e7535ee113efc4931765.tar.gz
protobuf: add python support
The compiler generated by Google Protocol Buffers currently includes support for Python bindings. However, currently the python files required to use the generated files are not included on the system. This fix installs the python header files using python setup-tools after the compiler is built. Signed-off-by: Keith Holman <Keith.Holman@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/criu/protobuf_2.5.0.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/recipes-containers/criu/protobuf_2.5.0.bb b/recipes-containers/criu/protobuf_2.5.0.bb
index 4a90b2c6..a9a26d88 100644
--- a/recipes-containers/criu/protobuf_2.5.0.bb
+++ b/recipes-containers/criu/protobuf_2.5.0.bb
@@ -13,8 +13,22 @@ PR = "r0"
13SRC_URI[md5sum] = "b751f772bdeb2812a2a8e7202bf1dae8" 13SRC_URI[md5sum] = "b751f772bdeb2812a2a8e7202bf1dae8"
14SRC_URI[sha256sum] = "c55aa3dc538e6fd5eaf732f4eb6b98bdcb7cedb5b91d3b5bdcf29c98c293f58e" 14SRC_URI[sha256sum] = "c55aa3dc538e6fd5eaf732f4eb6b98bdcb7cedb5b91d3b5bdcf29c98c293f58e"
15SRC_URI = "http://protobuf.googlecode.com/files/protobuf-${PV}.tar.gz" 15SRC_URI = "http://protobuf.googlecode.com/files/protobuf-${PV}.tar.gz"
16PYTHON_SRC_DIR="python"
16 17
17EXTRA_OECONF += " --with-protoc=echo" 18EXTRA_OECONF += " --with-protoc=echo"
18inherit autotools 19inherit autotools setuptools
20
21do_compile() {
22 # Compile protoc compiler
23 base_do_compile
24}
25
26do_install() {
27 # Install protoc compiler
28 autotools_do_install
29 # Install header files
30 cd "${PYTHON_SRC_DIR}"
31 distutils_do_install
32}
19 33
20BBCLASSEXTEND = "native nativesdk" 34BBCLASSEXTEND = "native nativesdk"