diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-10-25 22:53:00 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-03-15 23:15:42 -0400 |
commit | 7c92c5263f2e8d3254825f7f6249b32b5074be16 (patch) | |
tree | 4d31cd5d0c5a66325382a3fbbfd35e92b1170869 | |
parent | 3e66fce9acc2892f5ea440121a1eb406b803d827 (diff) | |
download | meta-virtualization-7c92c5263f2e8d3254825f7f6249b32b5074be16.tar.gz |
k3s: use cni-networking bbclass to install / package networking configuration
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/k3s/k3s_git.bb | 5 |
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-containers/k3s/k3s_git.bb b/recipes-containers/k3s/k3s_git.bb index f92521dd..6ac67acc 100644 --- a/recipes-containers/k3s/k3s_git.bb +++ b/recipes-containers/k3s/k3s_git.bb | |||
@@ -16,9 +16,12 @@ SRC_URI = "git://github.com/rancher/k3s.git;branch=release-1.18;name=k3s \ | |||
16 | SRC_URI[k3s.md5sum] = "363d3a08dc0b72ba6e6577964f6e94a5" | 16 | SRC_URI[k3s.md5sum] = "363d3a08dc0b72ba6e6577964f6e94a5" |
17 | SRCREV_k3s = "630bebf94b9dce6b8cd3d402644ed023b3af8f90" | 17 | SRCREV_k3s = "630bebf94b9dce6b8cd3d402644ed023b3af8f90" |
18 | 18 | ||
19 | CNI_NETWORKING_FILES ?= "${WORKDIR}/cni-containerd-net.conf" | ||
20 | |||
19 | inherit go | 21 | inherit go |
20 | inherit goarch | 22 | inherit goarch |
21 | inherit systemd | 23 | inherit systemd |
24 | inherit cni_networking | ||
22 | 25 | ||
23 | PACKAGECONFIG = "" | 26 | PACKAGECONFIG = "" |
24 | PACKAGECONFIG[upx] = ",,upx-native" | 27 | PACKAGECONFIG[upx] = ",,upx-native" |
@@ -46,7 +49,7 @@ do_install() { | |||
46 | ln -sr "${D}/${BIN_PREFIX}/bin/k3s" "${D}${BIN_PREFIX}/bin/crictl" | 49 | ln -sr "${D}/${BIN_PREFIX}/bin/k3s" "${D}${BIN_PREFIX}/bin/crictl" |
47 | ln -sr "${D}/${BIN_PREFIX}/bin/k3s" "${D}${BIN_PREFIX}/bin/kubectl" | 50 | ln -sr "${D}/${BIN_PREFIX}/bin/k3s" "${D}${BIN_PREFIX}/bin/kubectl" |
48 | install -m 755 "${WORKDIR}/k3s-clean" "${D}${BIN_PREFIX}/bin" | 51 | install -m 755 "${WORKDIR}/k3s-clean" "${D}${BIN_PREFIX}/bin" |
49 | install -D -m 0644 "${WORKDIR}/cni-containerd-net.conf" "${D}/${sysconfdir}/cni/net.d/10-containerd-net.conf" | 52 | |
50 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | 53 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
51 | install -D -m 0644 "${WORKDIR}/k3s.service" "${D}${systemd_system_unitdir}/k3s.service" | 54 | install -D -m 0644 "${WORKDIR}/k3s.service" "${D}${systemd_system_unitdir}/k3s.service" |
52 | install -D -m 0644 "${WORKDIR}/k3s-agent.service" "${D}${systemd_system_unitdir}/k3s-agent.service" | 55 | install -D -m 0644 "${WORKDIR}/k3s-agent.service" "${D}${systemd_system_unitdir}/k3s-agent.service" |