diff options
author | Jianchuan Wang <jianchuan.wang@windriver.com> | 2017-08-30 15:55:55 +0800 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2017-08-31 15:24:24 -0400 |
commit | 90c1046b58c50f127ea711d83874a1dc4b68f7ed (patch) | |
tree | 8d544e7a16a627cd97b533a35ac1363ed7594d9e | |
parent | 9b0c0178bac0bf0bfa4017e41fcf45e0baedcc0c (diff) | |
download | meta-virtualization-90c1046b58c50f127ea711d83874a1dc4b68f7ed.tar.gz |
criu: Correct the installation directory for python modules
Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r-- | recipes-containers/criu/criu_git.bb | 2 | ||||
-rw-r--r-- | recipes-containers/criu/files/0001-criu-Correct-the-installation-directory-for-python-m.patch | 29 |
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes-containers/criu/criu_git.bb b/recipes-containers/criu/criu_git.bb index 849a8328..2df203e2 100644 --- a/recipes-containers/criu/criu_git.bb +++ b/recipes-containers/criu/criu_git.bb | |||
@@ -21,6 +21,7 @@ SRC_URI = "git://github.com/xemul/criu.git;protocol=git \ | |||
21 | file://0001-criu-Fix-toolchain-hardcode.patch \ | 21 | file://0001-criu-Fix-toolchain-hardcode.patch \ |
22 | file://0002-criu-Skip-documentation-install.patch \ | 22 | file://0002-criu-Skip-documentation-install.patch \ |
23 | file://0001-criu-Change-libraries-install-directory.patch \ | 23 | file://0001-criu-Change-libraries-install-directory.patch \ |
24 | file://0001-criu-Correct-the-installation-directory-for-python-m.patch \ | ||
24 | ${@bb.utils.contains('PACKAGECONFIG', 'selinux', '', 'file://disable-selinux.patch', d)} \ | 25 | ${@bb.utils.contains('PACKAGECONFIG', 'selinux', '', 'file://disable-selinux.patch', d)} \ |
25 | file://lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch \ | 26 | file://lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch \ |
26 | " | 27 | " |
@@ -43,6 +44,7 @@ EXTRA_OEMAKE_aarch64 += "ARCH=arm64 WERROR=0" | |||
43 | 44 | ||
44 | EXTRA_OEMAKE_append += "SBINDIR=${sbindir} LIBDIR=${libdir} INCLUDEDIR=${includedir} PIEGEN=no" | 45 | EXTRA_OEMAKE_append += "SBINDIR=${sbindir} LIBDIR=${libdir} INCLUDEDIR=${includedir} PIEGEN=no" |
45 | EXTRA_OEMAKE_append += "LOGROTATEDIR=${sysconfdir} SYSTEMDUNITDIR=${systemd_unitdir}" | 46 | EXTRA_OEMAKE_append += "LOGROTATEDIR=${sysconfdir} SYSTEMDUNITDIR=${systemd_unitdir}" |
47 | EXTRA_OEMAKE_append += "PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}" | ||
46 | 48 | ||
47 | CFLAGS += "-D__USE_GNU -D_GNU_SOURCE " | 49 | CFLAGS += "-D__USE_GNU -D_GNU_SOURCE " |
48 | 50 | ||
diff --git a/recipes-containers/criu/files/0001-criu-Correct-the-installation-directory-for-python-m.patch b/recipes-containers/criu/files/0001-criu-Correct-the-installation-directory-for-python-m.patch new file mode 100644 index 00000000..0439b3c4 --- /dev/null +++ b/recipes-containers/criu/files/0001-criu-Correct-the-installation-directory-for-python-m.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 29865b7e9288a60aca151df323ee89c0952e8158 Mon Sep 17 00:00:00 2001 | ||
2 | From: Jianchuan Wang <jianchuan.wang@windriver.com> | ||
3 | Date: Thu, 3 Nov 2016 01:33:57 -0400 | ||
4 | Subject: [PATCH] criu: Correct the installation directory for python module | ||
5 | distributions | ||
6 | |||
7 | Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com> | ||
8 | --- | ||
9 | lib/Makefile | 4 ++-- | ||
10 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
11 | |||
12 | diff --git a/lib/Makefile b/lib/Makefile | ||
13 | index f1c0821..c3003a5 100644 | ||
14 | --- a/lib/Makefile | ||
15 | +++ b/lib/Makefile | ||
16 | @@ -55,8 +55,8 @@ install: lib-c lib-py ../crit/crit c/criu.pc.in | ||
17 | $(Q) mkdir -p $(DESTDIR)$(LIBDIR)/pkgconfig | ||
18 | $(Q) sed -e 's,@version@,$(CRIU_VERSION),' -e 's,@libdir@,$(LIBDIR),' -e 's,@includedir@,$(dir $(INCLUDEDIR)),' c/criu.pc.in > c/criu.pc | ||
19 | $(Q) install -m 644 c/criu.pc $(DESTDIR)$(LIBDIR)/pkgconfig | ||
20 | - $(E) " INSTALL " crit | ||
21 | - $(Q) python ../scripts/crit-setup.py install --root=$(DESTDIR) --prefix=$(PREFIX) --record $(CRIT_SETUP_FILES) | ||
22 | + $(E) " INSTALL " crit | ||
23 | + $(Q) python ../scripts/crit-setup.py install --root=$(DESTDIR) --prefix=$(PREFIX) --install-lib=$(PYTHON_SITEPACKAGES_DIR) --record $(CRIT_SETUP_FILES) | ||
24 | .PHONY: install | ||
25 | |||
26 | uninstall: | ||
27 | -- | ||
28 | 2.8.1 | ||
29 | |||