summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2020-01-09 15:15:33 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-17 16:29:15 -0500
commit91b8d9d9e4305a32f138106fa379f83ec8766243 (patch)
tree636e13e03bce2a0fce8e9fe40e5adc53c93d830d
parentf569d1bfd5b99a10a5f21a2da1e4f637f64d969b (diff)
downloadmeta-virtualization-91b8d9d9e4305a32f138106fa379f83ec8766243.tar.gz
docker-ce: update to v19.03.5
Bump the git hashes to Docker CE v19.03.5. This requires to get the docker daemon binary from a different location as the symlink from the latest/ subdirectory has been removed. See also commit deaac5d4b3fa ("hack/make.sh remove "latest" symlink") in the docker-ce repository. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/docker/docker-ce_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-containers/docker/docker-ce_git.bb b/recipes-containers/docker/docker-ce_git.bb
index 8b8136d5..ef840697 100644
--- a/recipes-containers/docker/docker-ce_git.bb
+++ b/recipes-containers/docker/docker-ce_git.bb
@@ -18,7 +18,7 @@ DESCRIPTION = "Linux container runtime \
18 subtle and/or glaring issues. \ 18 subtle and/or glaring issues. \
19 " 19 "
20 20
21SRCREV_docker = "6a30dfca03664a0b6bf0646a7d389ee7d0318e6e" 21SRCREV_docker = "633a0ea838f10e000b7c6d6eed1623e6e988b5bb"
22SRCREV_libnetwork = "5ac07abef4eee176423fdc1b870d435258e2d381" 22SRCREV_libnetwork = "5ac07abef4eee176423fdc1b870d435258e2d381"
23SRC_URI = "\ 23SRC_URI = "\
24 git://github.com/docker/docker-ce.git;branch=19.03;name=docker \ 24 git://github.com/docker/docker-ce.git;branch=19.03;name=docker \
@@ -38,7 +38,7 @@ GO_IMPORT = "import"
38 38
39S = "${WORKDIR}/git" 39S = "${WORKDIR}/git"
40 40
41DOCKER_VERSION = "19.03.2-ce" 41DOCKER_VERSION = "19.03.5-ce"
42PV = "${DOCKER_VERSION}+git${SRCREV_docker}" 42PV = "${DOCKER_VERSION}+git${SRCREV_docker}"
43 43
44PACKAGES =+ "${PN}-contrib" 44PACKAGES =+ "${PN}-contrib"
@@ -99,7 +99,7 @@ do_compile() {
99do_install() { 99do_install() {
100 mkdir -p ${D}/${bindir} 100 mkdir -p ${D}/${bindir}
101 cp ${S}/src/import/components/cli/build/docker ${D}/${bindir}/docker 101 cp ${S}/src/import/components/cli/build/docker ${D}/${bindir}/docker
102 cp ${S}/src/import/components/engine/bundles/latest/dynbinary-daemon/dockerd ${D}/${bindir}/dockerd 102 cp ${S}/src/import/components/engine/bundles/dynbinary-daemon/dockerd ${D}/${bindir}/dockerd
103 cp ${WORKDIR}/git/libnetwork/bin/docker-proxy* ${D}/${bindir}/docker-proxy 103 cp ${WORKDIR}/git/libnetwork/bin/docker-proxy* ${D}/${bindir}/docker-proxy
104 104
105 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 105 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then