diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2025-01-16 17:56:11 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2025-01-17 19:17:09 +0000 |
commit | 92f9277d27c1cac2fd88392eab59c6823ef79ee2 (patch) | |
tree | fcb7de82ab2d2fc232119fcb6d9d82e8d52b85b7 | |
parent | 4102296af9981c1b8f40bcadddf91d77d1029e28 (diff) | |
download | meta-virtualization-92f9277d27c1cac2fd88392eab59c6823ef79ee2.tar.gz |
cloud-init: update to 24.4.1
Bumping cloud-init to version 24.4.1, which comprises the following commits:
4b475ed36 Release 24.4.1
470f652da fix: Ensure _should_wait_via_user_data() handles all user data types (#5976)
e702638be fix: Don't log error in wait_for_url (#5972)
30232cfd4 feat(url_helper): Retry on 503 error (#5938)
b2cf0a6fd fix: Don't break modules that use get_meta_doc() (#5953)
07db0da44 refactor: Pass deprecation log args as tuple (#5953)
4d559e732 fix: uninstall custom signal handlers before shutdown (#5913)
c9b9eef30 Release 24.4
82f94812b test: Ensure unit ordering in ftp tests includes downstream units (#5892)
9f2cae7fa test: re-decrement expected webhook events (#5894)
ba04e4c41 test: allow relative path in apt-get test (#5891)
d3b7e121d Fix metric setting of nmconnection for rhel (#5878)
edaaeeabc chore: remove unused code(#5887)
1f520d93d feat(ephemeral): replace old has_url_connectivity() with new _check_connectivity_to_imds()
c0e3ecf20 feat(oracle): add true single stack ipv6 support
062a12b69 feat(ephemeral): refactor ephemeralIP and add ipv6 connectivity check
aedb7f97a test: Decrement expected webhook events (#5888)
1ef775162 chore: remove `--docs` option from `cloud-init schema` (#5857)
3c24560cb test: pytestify "tests/unittests/config/test_cc_timezone.py" (#5885)
dd448e0ac ci: bump integration tests to use plucky
7f5065e7d test: add grub_dpkg to inactive modules
892b59863 test: move default behavior tests into their own module
70c28373f test(apt): add plucky version for hello pkg (#5883)
6beb71f61 Docs: improved mermaid diagram for better visibility. Add "MaheshG11" as contributor (#5874)
df9e51ccc fix(ntp): Fix RockyLinux OS support (#5864)
368232532 chore(jsonschema): migrate from deprecated Validator.iter_errors (#5856)
7f9a34fd8 chore: remove deprecation warning getting jsonschema's version (#5856)
5950099a3 chore: use filter arg for tar.extractall (#5856)
cd74e9948 chore: remove __init__ from pytest test class (#5856)
f94256b04 chore: do not test element's truth value directly (#5856)
345043f56 chore: migrate from deprecated datetime.datetime.utcfromtimestamp (#5856)
d6efb3eb9 chore: migrate from deprecated datetime.datetime.utcnow() (#5856)
b3120f7fe chore: set recursive=False for ensure_dir if parent path is "/" (#5816)
fad947594 ci: fix broken daily dependencies (#5867)
e15b5d729 ci: fix packaging tests (#5865)
acbb26c1d feat(vultr): add override for network interface detection (#5847)
aeccf8991 feat(networkd): Support RequiredForOnline option (#5852)
2df49b652 Prevent NM from handling DNS when network interfaces have DNS config (#5846)
5e1a8cbeb fix(smartos): Add `addrconf` IPv6 support (#5831)
96a07fb75 freebsd: adjust to match the new pyyaml package name (#5844)
4b56c5cb5 fix: disable grub-dpkg by default (#5840)
a911b5e58 fix(openbsd): Enable sysv init scripts in OpenBSD build script (#5790)
4c156a803 test: Fix duplicate judgment conditions in password generation (#5835)
d1d7af662 chore: don't render non-templated unit files (#5830)
be88242be chore: simplify and standardize cloud-final.service (#5830)
cb0c08ded chore: simplify Conflicts=shutdown.target (#5830)
069efee7d chore: remove redundant Before=NetworkManager.service (#5830)
9bb0a882b chore: remove unnecessary systemd settings (#5830)
0680d0330 chore: eliminate redundant ordering dependencies (#5819)
df51941e2 fix: fix ordering cycle for distros with default deps (#5819)
7ff199ad7 test: unbreak pytest-xdist (#5829)
e30549e88 feat: Conditionally remove networkd online dependency on Ubuntu (#5772)
879945f56 feat: Ensure random passwords contain multiple character types (#5815)
5819c942a docs: split example page into example library (#5645)
1fc063a57 doc: clarify workarounds required for single process changes (#5817)
0c24aa29d chore: add 3.13 to PR CI runs, 3.14 to scheduled (#5825)
9554338e6 fix: Render v2 bridges correctly on network-manager with set-name (#5740)
5f90d9656 test: add no_thinpool unit test (#5802)
64a622b42 chore: split lxd init config into separate function (#5802)
11586cd46 test: pytestify test_cc_lxd.py (#5802)
296b296ee fix: Correctly handle missing thinpool in cc_lxd (#5802)
a8f69409e fix: Render bridges correctly for v2 on sysconfig with set-name (#5674)
39f2742b7 tests(minimal): rsyslog not in minimal images expect warning (#5811)
efcd4889d tests(lxd): avoid failure on multiple calls to --show-log (#5811)
40f9bae1f chore: update netplan import semantics and related tests (#5805)
5d2ff7335 lint: fix untyped-defs on /tests/unittest/cmd (#5800)
760ded95a test: actually use devel release and verify_clean_boot enhancements (#5801)
dba2dd3a3 feat(locale): locales install on minimal images when cfg requests (#5799)
90d905b7f feat(byobu): support byobu install on minimal images when cfg requests (#5799)
0f77b3c13 chore: Use devel release and no sbuild in integration CI (#5798)
4de61f395 test: Update integration tests from netplan backport (#5796)
e10b09be3 test: add get_syslog_or_console for minimal images without syslog (#5793)
beb08710a chore: Remove resize_root_tmp from cloud.cfg.tmpl (#5795)
dcfb2c93e docs: Fix field name from `contents` to `content` (#5787)
a57a565b8 chore: bump pycloudlib to required version (#5792)
55de797e4 fix: avoid deprecation logs for calling cli stages (#5770)
99f4ca4f9 tests: bump pycloudlib deps to include gce bug fix for id str (#5783)
9df99d82c fix(test): convert use p.gce.instance.id instead of instance_id (#5783)
2b15be199 fix(network-manager): bond properties and network schema (#5768)
a399f4b08 Fix metric setting for ifcfg network connections for rhel (#5777)
ce8078147 fix(akamai): handle non-string user data in base64 decoding (#5751)
545e9ac2f fix(ci): do not auto stale issues (#5775)
11298f41d Make pytest more verbose for easier debugging (#5778)
f9082bf85 ci: fix tox.ini pytest cmd to use cloudinit dir for coverage reporting (#5774)
2e866d38d tests: add OS_IMAGE_TYPE setting to allow for minimal tests (#5682)
dc3cfde68 test(hotplug): Simplify test_multi_nic_hotplug (#5763)
ff336d423 test(hotplug): increase nc timeout (#5763)
9dff1af8c test: pytestify test_main.py (#5758)
27f89c610 test(ec2-dual-stack): fix int-test (#5762)
178b0699b test: make verify_clean_boot really respect return code (#5761)
d5d6df590 test: bump timeout in test_order (#5759)
c9fa9067c docs: Properly document the cc_ubuntu_autoinstall module (#5757)
b15263e32 docs: fix WSL tutorial (#5752)
5133c838b test: make verify_clean_boot respect return code by environment (#5754)
e6183967e feat(integration_test): add CLOUD_INIT_PKG setting (#5739)
bbe6191ca fix(ci): fix packaging check merge operation (#5750)
9491566d8 doc: do not document user.meta-data key (#5745)
590fd3eeb test: avoid undocumented lxd key (#5748)
c9dce94d3 test: Refactor test_cc_set_hostname.py and test_cc_ntp.py (#5727)
7988b8189 chore: update docs URLs to cloud-init.io (#5741)
6725c0f89 test: fix timer logging change expected logs (#5734)
1dd685065 fix: type annotations for several modules (#5733)
70d4a5c25 chore: add timer to io and string manipulation code
71cc75cee feat: add log package and performance module
f114c6387 remove newline injected for cloud-init status --wait (#5700)
d1ce9b456 test: webhook require_deprecation msg on 24.3 (#5731)
869d624a5 test: fix test_nocloud message typo introduced by 313390f8 (#5731)
fc2147ad4 test: Fix test_log_message_on_missing_version_file (#5730)
3505c02e9 tests: assert info level warnings instead of require_deprecation
6113b0e0a tests: fix test to ignore_warnings not require Used fallback ds
c93c259d3 chore: clean up pytest warnings (#5721)
067a464e0 tests(pro): bump pycloudlib add noble release to pro tests (#5719)
b36ddb195 fix(hotplugd.socket): remove basic.target as dependency (#5722)
eef27eb19 ci: fix integration test positional argument (#5718)
53857c865 Create datasource for CloudCIX (#1351)
9d0fc5ae9 ci: colorize output (#5716)
ddb62cc09 fix(schema): Allow for locale: false in schema add tests (#5647)
0a021418d ci: fix packaging patch check (#5713)
c4847202f chore: clean up old pickle workaround (#5714)
436126b2b fix: force sftp cleanup when done with instance (#5698)
c62d7f22c test(hotplug): reenable vpc test in focal (#5492)
df75b526a chore: fix typing of userdata_raw (#5710)
bde913ae2 fix(NetworkManager): Fix network activator (#5620)
32f8554b8 fix: lxd do not check for thinpool kernel module (#5709)
654cb4414 docs: fix typo in docstring (#5708)
1c61f3f24 Scaleway: Force on-link: true for static networks (#5654)
2c80c5a0a fix: Invalid "seedfrom" in NoCloud system configuration (#5701)
aad528672 tests: pytestify test_nocloud.py (#5701)
a9c6b1407 test: make verify_clean_boot respect return code by series (#5695)
7a32eff8a fix: use cross-distro netcat name (#5696)
b88f91010 ci: fix labeler (#5697)
920e83112 chore(actions): add packaging label for any branches modifying debian/* (#5693)
313390f81 test: add verify_clean_boot() calls alongside verify_clean_log() (#5671)
10df0c173 test: add deprecation support to verify_clean_boot (#5671)
e1f05b732 doc: remove misleading warning (#5681)
7a0d957c2 chore: Prefer other methods over $INSTANCE_ID (#5661)
5d91e9639 ci: fix packaging test when no patches (#5680)
7a750e31a chore: fix tip-ruff and update to latest version (#5676)
8b9998035 chore: make ansible test serial (#5677)
1a6fd6fd3 feat(ec2): Bump url_max_timeout to 240s from 120s. (#5565)
d8fd56db0 chore: fix typo in requirements.txt (#5637)
f79471a60 feat: make pyserial an optional dependency (#5637)
82efd3ec5 chore: bump ci dependency versions (#5660)
eddfe02af chore: drop broken optimization (#5666)
b10d90503 Release 24.3.1 (#5375) (#5663)
30addd2f3 test: add test coverage for iproute2 commands (#5651)
3e74d5e67 fix(netops): fix ip addr flush command (#5651)
9cc458c7d fix(systemd): add Before=shutdown.target to cloud-init-main.service.tmpl (#5653)
60a856ae3 test: assert that schema is valid by default (#5657)
5a74d19d0 chore(azurelinux): update cloud.cfg.tmpl for azurelinux
e30ce6bf1 fix(scaleway): Don't override IPv6 routes when IPv4 not primary (#5640)
9faafb0df Release 24.3 (#5646)
5ff1a4a2b docs: Clarify v2 set-name behavior (#5639)
93f30bbfc fix: properly handle blank lines in fstab (#5643)
6d644e612 fix: cc_user_groups incorrectly assumes "useradd" never locks password field (#5355)
fa042b853 tests: assert cloud-init user-data cert is the only root cert (#5641)
8bc3e4254 feat: add automation for ubuntu/* branches asserting quilt patches apply (#5622)
bbdfe3663 fix(sources/wsl): no error with empty .cloud-init dir (SC-1862) (#5633)
a38d6da76 feat(azure): add PPS support for azure-proxy-agent (#5601)
6e4343eab fix(tests): use instance.clean/restart instead of clean --reboot (#5636)
8f741da4a test: fix cmd/test_schema int test (#5629)
c6ba0dfab test: fix test_honor_cloud_dir int test (#5627)
ca9ffac83 docs: alphabetize dsname lookup table. update comment to create the csv (#5624)
0411057e6 docs: new datasources should update reference/ds_dsname_map (#5624)
79e5d31ce test: fix ca_certs int test (#5626)
a2193da3e chore: update schema docs to use RST bold for config key names (#5562)
d85be37d2 fix(doc): italics around deprecation prefix, description bolds key names (#5562)
fdccc6113 feat(doc): add env vars to debug config module doc builds (#5562)
e14ce3d64 fix(doc): doc of nested objects under JSON schema items.oneOf (#5562)
24cdaa75a fix(doc): object type check if patternProperties or properties (#5562)
0a8bf72b9 doc(schema): schema descriptions should end with trailing stop (#5562)
56aa70636 fix(wsl): Properly assemble multipart data (#5538)
c28092fa6 feat: collect-logs improvements (#5619)
2e4c39b75 tests: fix test_ca_certs.py for gcp (#5621)
d79050d1b fix(nm): Ensure bond property name formatting matches schema definition (#5383)
90a319046 Update behavior of base bond interface with NetworkManager (#5385)
e1845be5d ci: Drop Python 3.6 and 3.7 (#5607)
56658ec5f chore(black): Bump version (#5607)
2bb49b4f8 chore(mypy): Fix failures on newer versions of mypy (#5607)
56dc23cbe chore(tox.ini): Simplify configuration, fix minor bugs (#5607)
19a9cca47 chore(mypy): Lint log module (#5607)
ac94539ab fix(systemd): Correct location of installed drop-in files(#5615)
dfcc2b867 fix(btrfs): Version parsing (#5618)
07d0384be docs: Remove unnecessary section, add feature flag page (#5617)
14edf67c2 docs: Drop Python 3.6 and 3.7 support (#5617)
8b11d99d4 chore: explain other use of oauth (#5616)
4c96055e5 chore(actions): add doc label for any doc related subdir file matches (#5602)
baeb35cc3 doc: Add misc links, improve wording (#5595)
001446706 doc(boot): Make first boot a dedicated page (#5595)
6ae8f6800 doc: Describe all stages in a single process (#5595)
bd6cd1fbe chore: Deprecate old commands in help output (#5595)
e3db1adbb chore: add comment explaining the NetworkManager may-fail setting (#5598)
65014b974 Revert "fix(vmware): Set IPv6 to dhcp when there is no IPv6 addr (#5471)" (#5596)
edd92b712 fix: read_optional_seed to set network-config when present (#5593)
0787d6299 feat(snap): avoid refresh on package_upgrade: true and refresh.hold (#5426)
acf04d616 fix: Fix tests which have outdated strings (#5585)
7532589f4 fix: Fix ftp failures (#5585)
f93a6b5a6 doc: improve integration testing configuration instructions (#5556)
b71f48f8f azure: check azure-proxy-agent status (#5138)
d396de1ad refactor: refactor and fix mypy in DataSourceIBMCloud.py (#5509)
c0ffdd4d0 fix: Update default LXD meta-data with user meta-data (#5584)
0aea65c20 chore: Fix log message in url_helper.py (#5583)
b7b11bc04 fix: nocloud no fail when network-config absent (#5580)
143bc9e40 feat: Single process optimization (#5489)
ca3e6bc3a chore: Add helper, refactor utilities into separate module (#5573)
d15a7704b refactor: update handle function of cc_mounts (#5498)
ea831d676 fix: Integration tests (#5576)
5322dca2f fix(NoCloudNet): Add network-config support (#5566)
e6b2e0fea feat: Eliminate redundant configuration reads (#5536)
b5d4f3fa1 fix(actions): correct typo in cloudinit/config/schemas/ match (#5570)
f8d8a0cd4 fix: add host template for AOSC (#5557)
00317d16d chore(debian): Remove vestigial postinst and preinst code (#5569)
f8c1b51f5 fix(actions): doc labeler needs all clause instead of default any (#5568)
f9ab856f4 docs: Overhaul user data formats documentation (#5551)
15200a002 chore: Deprecate ENI as an input configuration format (#5561)
914a3a8a4 doc: improve drop-in custom modules (#5548)
81ef45ef8 doc(NoCloud): Categorize the different configuration types (#5521)
779dd6b00 doc(autoinstall): Remove incorrect statements, be more direct (#5545)
25058e115 chore: remove unneeded doc-lint tox env config (#5547)
2ffd6528a fix(doc-spelling): config spelling_word_list_filename (#5547)
883d8e2f9 doc(modules): add section to wrap modules' doc (#5550)
e5e78c2ed doc: Update docs on boothooks (#5546)
c1760751e fix: doc auto label to consider schema json changes as doc PRs (#5543)
5f9372661 feat(schema): add chef_license schema enum (#5543)
8ceae8b7b doc: add diagram with boot stages (#5539)
02beb9ab4 docs: improve qemu command line (#5540)
bb4b7c0c6 fix: auto label doc PRs (#5542)
99ac8193f fix(wsl): Put back the "path" argument to wsl_path in ds-identify (#5537)
f90f0b8a6 test: fix test_kernel_command_line_match (#5529)
2d2385226 test: fix no ds cache tests (#5529)
2534432bf fix(azurelinux): Change default usr_lib_exec path (#5526)
7c2d4fd63 feat: Support URI sources in `write_files` module (#5505)
e1147bd02 add openeuler to distros in cc_spacewalk.py (#5530)
5532b4a69 feat(wsl): Special handling Landscape client config tags (#5460)
16a319812 chore: Deprecate partially supported system config (#5515)
7703634ec chore: Improve detection logging for user clarity (#5515)
23be88d00 fix(ds-identify): Detect nocloud when seedfrom url exists (#5515)
6e4153b34 refactor: logs.py add typing and small misc refactors (#5414)
19c86ffb4 refactor: logs.py pathlib changes (#5414)
8ec2f64ad refactor: replace verbosity with log levels in logs.py (#5414)
b0a673a53 feat: Add trace-level logger (#5414)
57d130eeb chore(formatting): fix squashed commit test formatting (#5524)
550c685c9 fix: Clean cache if no datasource fallback (#5499)
0b4084374 Support setting mirrorlist in yum repository config (#5522)
658d1841f doc(OFV): Document how to configure cloud-init (#5519)
311f72347 fix: Update DNS behavior for NetworkManager interfaces (#5496)
e0e6a427f Fix configuration of DNS servers via OpenStack (#5384)
8dbc5c23b test: Unconditionally skip test_multi_nic_hotplug_vpc (#5503)
18d76ac60 tests: revert expectation of exit 2 from cloud-init init --local (#5504)
a911d0795 fix(test): Fix ip printer for non-lxd (#5488)
75add5c72 feat(systemd): convert warning level message to deprecation (#5209)
8aa1c30dd test: allow verify_clean_boot to ignore all or specific tracebacks (#5209)
604d80eb6 test: Don't fail tests which call cloud-init as a command (#5209)
4abdd5a70 feat(systemd): Warn user of unexpected run mode (#5209)
7d35664ef fix: add schema rules for 'baseurl' and 'metalink' in yum repo config (#5501)
4c0468c57 Set MTU for bond parent interface (#5495)
0128716c2 refactor: util.mounts to handle errors (#5490)
188656b21 refactor: util.get_proc_env to work with strs (#5490)
db828d054 typing: fix check_untyped_defs in cloudinit.util (#5490)
7130bbbb1 test: Add missing assert to test_status.py (#5494)
8a582709a test: Ensure mkcert executable in ftp tests (#5493)
0af459eac test: pytestify and cleanup test_cc_mounts.py (#5459)
2b6fe6403 fix(vmware): Set IPv6 to dhcp when there is no IPv6 addr (#5471)
053331e5c fix(openbsd): fix mtu on newline in hostname files (#5412)
9357c3899 feat(aosc): Add 'AOSC OS' support (#5310)
fd6329755 Release 24.2 (#5481)
0a4c43d47 test: Fix no default user in test_status.py (#5478)
0a7036ed7 fix: correct deprecated_version=22.2 for users.sudo
b0d6c7ddc test: Add jsonschema guard in test_cc_ubuntu_pro.py (#5479)
291aabeb7 fix(test): Fix pycloudlib types in integration tests (#5350)
2bca69a9a fix(test): Fix ip printing for non-lxd instances (#5350)
c95ec1a4f chore(mypy): Drop unused missing import exclusions (#5350)
8ad0bbaf6 type: Add stub types for network v1/v2 config (#5350)
73a5c512a chore: Auto-format network jsonschema in ci (#5350)
e4c05e80b fix(tox): Update tox.ini (#5350)
97146b57f chore(typing): Remove type ignores and casts (#5350)
b26d388ce refactor(typing): Remove unused code paths (#5350)
a8cf24b7c fix(typing): Add / update type annotations (#5350)
555028524 fix(typing): Remove type annotation for unused variable (#5350)
16018b244 fix(typing): Remove invalid type annotations (#5350)
41c375c4f ci(mypy): Set default follow_imports value (#5350)
40e2eb4ae test: Update integration tests to pass on focal (#5476)
c45280e98 tests: update ubuntu_pro test to account for info-level deprecations (#5475)
ee1b25b73 tests: update nocloud deprecation test for boundary version (#5474)
681b7de1a fix(rh_subscription): add string type to org (#5453)
d59724a15 tests: integration tests aware of features.DEPRECATION_INFO_BOUNDARY
7693ee2a6 tests: update keyserver PPA key fur curtin-dev (#5472)
0a698a57f test: Fix deprecation test failures (#5466)
5ce2ee36e chore: fix schema.py formatting (#5465)
25669f736 fix: dont double-log deprecated INFOs (#5465)
726159b9a fix(test): Mock version boundary (#5464)
121539b0f fix(schema): Don't report changed keys as deprecated (#5464)
debafbc9b test: fix unit test openstack vlan mac_address (#5367)
371b2362b fix: Ensure properties for bonded interfaces are properly translated (#5367)
b3618d44a fix(schema): permit deprecated hyphenated keys under users key (#5456)
70f7e78ec fix: Do not add the vlan_mac_address field into the VLAN object (#5365)
bbcc67dda doc(refactor): Convert module docs to new system (#5427)
7f98af900 test: Add unit tests for features.DEPRECATION_INFO_BOUNDARY (#5411)
8906e17ef feat: Add deprecation boundary support to schema validator (#5411)
e80514b56 feat: Add deprecation boundary to logger (#5411)
bcc5920a7 fix: Gracefully handle missing files (#5397)
f8f9d1940 test(openstack): Test bond mac address (#5369)
12f1198e8 fix(openstack): Fix bond mac_address (#5369)
3851c5c89 test: Add ds-identify integration test coverage (#5394)
6ee007939 chore(cmdline): Update comments (#5458)
790d22918 fix: Add get_connection_with_tls_context() for requests 2.32.2+ (#5435)
2c09f6917 fix(net): klibc ipconfig PROTO compatibility (#5437)
525026061 Support metalink in yum repository config (#5444)
8470af001 tests: hard-code curtin-dev ppa instead of canonical-kernel-team (#5450)
eb388c72f ci: PR update checklist GH- anchors to align w/ later template (#5449)
8c396a4bb test: update validate error message in test_networking (#5436)
32f0400f8 ci: Add PR checklist (#5446)
ffe823661 chore: fix W0105 in t/u/s/h/test_netlink.py (#5409)
63f7237db chore(pyproject.toml): migrate to booleans (#5409)
355560312 typing: add check_untyped_defs (#5409)
2ea276548 fix(openstack): Append interface / scope_id for IPv6 link-local metadata address (#5419)
db8594512 test: Update validation error in test_cli.py test (#5430)
ccf5850cf test: Update schema validation error in integration test (#5429)
8fede42e3 test: bump pycloudlib to get azure oracular images (#5428)
1d9b22aa1 fix(azure): fix discrepancy for monotonic() vs time() (#5420)
2cc398b9b fix(pytest): Fix broken pytest gdb flag (#5415)
a60a705aa fix: Use monotonic time (#5423)
e9cfdb438 docs: Remove mention of resolv.conf (#5424)
d9ff2e391 perf(netplan): Improve network v1 -> network v2 performance (#5391)
4981ea9a5 perf(set_passwords): Run module in Network stage (#5395)
5a3dc932e fix(test): Remove temporary directory side effect (#5416)
9c3258f4c Improve schema validator warning messages (#5404)
1b8030e0c feat(sysconfig): Add DNS from interface config to resolv.conf (#5401)
92f187aca typing: add no_implicit_optional lint (#5408)
cbcb05349 doc: update examples to reflect alternative ways to provide `sudo` option (#5418)
b533fa51a fix(jsonschema): Add missing sudo definition (#5418)
f9352b946 chore(doc): migrate cc modules i through r to templates (#5313)
0976b43c1 chore(doc): migrate grub_dpkg to tmpl add changed/deprecation (#5313)
95f5fea20 chore(json): migrate cc_apt_configure and json schema indents (#5313)
997cbe9c4 chore(doc): migrate ca_certs/chef to template, flatten schema (#5313)
532746611 chore(doc): migrate cc_byobu to templates (#5313)
c17d9416e chore(doc): migrate cc_bootcmd to templates (#5313)
a01b8d31f fix(apt): Enable calling apt update multiple times (#5230)
fdc250587 chore(VMware): Modify section of instance-id in the customization config (#5356)
bbc72bfed fix(treewide): Remove dead code (#5332)
fc2134bed doc: network-config v2 ethernets are of type object (#5381)
227538547 Release 24.1.7 (#5375)
5f40426f0 fix(azure): url_helper: specify User-Agent when using headers_cb with readurl() (#5298)
325abf1c3 fix: Stop attempting to resize ZFS in cc_growpart on Linux (#5370)
fbec4d022 doc: update docs adding YAML 1.1 spec and jinja template references
28d66efb9 fix(final_message): do not warn on datasourcenone when single ds
15bce6474 fix(growpart): correct growpart log message to include value of mode
9a71ddd73 feat(hotplug): disable hotplugd.socket (#5058)
f80d165e6 feat(hotlug): trigger hotplug after cloud-init.service (#5058)
617f8aff5 test: add function to push and enable systemd units (#5058)
a061e81da test(util): fix wait_until_cloud_init exit code 2 (#5058)
7e4d293ff test(hotplug): fix race getting ipv6 (#5271)
e843f6a0c docs: Adjust CSS to increase font weight across the docs (#5363)
072711c63 fix(ec2): Correctly identify netplan renderer (#5361)
719679338 tests: fix expect logging from growpart on devent with partition (#5360)
f93514aae test: Add v2 test coverage to test_net.py (#5247)
3d69851a9 refactor: Simplify collect_logs() in logs.py (#5268)
60766db43 fix: Ensure no subp from logs.py import (#5268)
06eaa7a0e tests: fix integration tests for ubuntu pro 32.3 release (#5351)
226d4fb10 tests: add oracular's hello package for pkg upgrade test (#5354)
e520c944e growpart: Fix behaviour for ZFS datasets (#5169)
dff02125e device_part_info: do not recurse if we did not match anything (#5169)
bbb7f62c2 feat(alpine): add support for Busybox adduser/addgroup (#5176)
5fb0dfaee ci: Move lint tip and py3-dev jobs to daily (#5347)
4c47005aa fix(netplan): treat netplan warnings on stderr as debug for cloud-init (#5348)
4df641623 feat(disk_setup): Add support for nvme devices (#5263)
461fc1d91 fix(log): Do not warn when doing requested operation (#5263)
c76ad9cd2 Support sudoers in the "/usr/usr merge" location (#5161)
fa1b8688e doc(nocloud): Document network-config file (#5204)
2856f4c8a fix(netplan): Fix predictable interface rename issue (#5339)
2c992597c cleanup: Don't execute code on import (#5295)
e432a31d6 fix(net): Make duplicate route add succeed. (#5343)
00ab32835 fix(freebsd): correct configuration of IPv6 routes (#5291)
42930d845 fix(azure): disable use-dns for secondary nics (#5314)
01367a7c9 chore: fix lint failure (#5320)
5ad609ffd Update pylint version to support python 3.12 (#5338)
de1966eb1 fix(tests): use regex to avoid focal whitespace in jinja debug test (#5335)
0fdbeefe4 chore: Add docstrings and types to Version class (#5262)
6748913c1 ci(mypy): add type-jinja2 stubs (#5337)
19cb8cf92 tests(alpine): github trust lxc mounted source dir cloud-init-ro (#5329)
f7c6292d9 test: Add oracular release to integration tests (#5328)
e68c8c74c Release 24.1.6 (#5326)
bb4553b16 test: Fix failing test_ec2.py test (#5324)
825eb1e7b fix: Check renderer for netplan-specific code (#5321)
c80c9c711 docs: Removal of top-level --file breaking change (#5308)
3a6b53972 fix: typo correction of delaycompress (#5317)
3f4a2dd0a docs: Renderers/Activators have downstream overrides (#5322)
587ac9ca7 fix(ec2): Ensure metadata exists before configuring PBR (#5287)
699159e6e fix(lxd): Properly handle unicode from LXD socket (#5309)
739c5f63c docs: Prefer "artifact" over "artefact" (#5311)
3c8d02816 chore(doc): migrate cc_byobu to templates
371f02581 chore(doc): migrate cc_bootcmd to templates
3b7f4b393 chore(doc): migrate apt_pipelining and apk_configure to templates
074ad67f3 tests: in_place mount module-docs into lxd vm/container
48ddb3eb5 feat(docs): generate rtd module schema from rtd/module-docs
23136e6a9 feat: Set RH ssh key permissions when no 'ssh_keys' group (#5296)
120adcc19 test: Avoid circular import in Azure tests (#5280)
33f50185a test: Fix test_failing_userdata_modules_exit_codes (#5279)
63a0fcd86 chore: Remove CPY check from ruff (#5281)
81337eabc chore: Clean up docstrings
ce2dfbc8a chore(ruff): Bump to version 0.4.3
dce1d4c74 feat(systemd): Improve AlmaLinux OS and CloudLinux OS support (#5265)
9388cc1ad feat(ca_certs): Add AlmaLinux OS and CloudLinux OS support (#5264)
d5254aab0 docs: cc_apt_pipelining docstring typo fix (#5273)
e10b052c5 feat(azure): add request identifier to IMDS requests (#5218)
dd54327ca test: Fix TestFTP integration test (#5237)
44d0c13fe feat(ifconfig): prepare for CIDR output (#5272)
8e8947b8b fix: stop manually dropping dhcp6 key in integration test (#5267)
cf72d7f37 test: Remove some CiTestCase tests (#5256)
f24ecef8b fix: Warn when signal is handled (#5186)
51c6569f9 fix(snapd): ubuntu do not snap refresh when snap absent
aa357fa23 feat(landscape-client): handle already registered client (#4784)
370e680c0 doc: Show how to debug external services blocking cloud-init (#5255)
4ffde902b fix(pdb): Enable running cloud-init under pdb (#5217)
b5b4dd39a chore: Update systemd description (#5250)
9b1b29440 fix(time): Harden cloud-init to system clock changes
6530fa34f fix: Update analyze timestamp uptime
9454e2f53 fix(schema): no network validation on netplan systems without API
a3ed8e000 fix(mount): Don't run cloud-init.service if cloud-init disabled (#5226)
24584a055 fix(ntp): Fix AlmaLinux OS and CloudLinux OS support (#5235)
237d957c0 tests: force version of cloud-init from PPA regardless of version (#5251)
8b12a654f ci: Print isort diff (#5242)
a22d85333 test: Fix integration test dependencies (#5248)
c1a19d7b6 fix(ec2): Fix broken uuid match with other-endianness (#5236)
66a874bc2 fix(schema): allow networkv2 schema without top-level key (#5239)
efd37c0fa fix(cmd): Do not hardcode reboot command (#5208)
44ad8ac7e test: Run Alpine tests without network (#5220)
e41b71923 docs: Add base config reference from explanation (#5241)
e98e62373 docs: Remove preview from WSL tutorial (#5225)
7eb5a1df0 chore: Remove broken maas code (#5219)
70e87f7f8 feat(WSL): Add support for Ubuntu Pro configs (#5116)
3671caa2a chore: sync ChangeLog and version.py from 24.1.x (#5228)
a6f7577d5 bug(package_update): avoid snap refresh in images without snap command
acc68de05 ci: Skip package build on tox runs (#5210)
8e7f98380 chore: Fix test skip message
b028368ca test(ec2): adopt pycloudlib public ip creation while launching instances
2e96ac844 test(ec2): add ipv6 testing for multi-nic instances
234f9a38d test(ec2): adopt pycloudlib enable_ipv6 while launching instances
22f4ff870 feat: tool to print diff between netplan and networkv2 schema (#5200)
aeafb83c7 test: mock internet access in test_upgrade (#5212)
725f5fb2c ci: Add timezone for alpine unit tests (#5216)
ddde8dddc fix: Ensure dump timestamps parsed as UTC (#5214)
90c15a60f docs: Add WSL tutorial (#5206)
8854179d6 feature(schema): add networkv2 schema (#4892)
641b107a2 Add alpine unittests to ci (#5121)
2e58770ce test: Fix invalid openstack datasource name (#4905)
70b03a9df test: Fix MAAS test and mark xfail (#4905)
17d477554 chore(ds-identify): Update shellcheck ignores (#4905)
84231d9b6 fix(ds-identify): Prevent various false positives and false negatives (#4905)
509ed36a9 Use grep for faster parsing of cloud config in ds-identify (#4905)
7268003a9 tests: validate netplan API YAML instead of strict content (#5195)
31039d05e chore(templates): update ubuntu universe wording (#5199)
5205b4dd7 Deprecate the users ssh-authorized-keys property (#5162)
ac9821217 doc(nocloud): Describe ftp and ftp over tls implementation (#5193)
c465de827 feat(net): provide network config to netplan.State for render (#4981)
47e9ad74c docs: Add breaking datasource identification changes (#5171)
8fe149449 fix(openbsd): Update build-on-openbsd python dependencies (#5172)
0b1ca1740 fix: Add subnet ipv4/ipv6 to network schema (#5191)
7c67f7732 docs: Add deprecated system_info to schema (#5168)
5a40b3bc9 docs: Add DataSourceNone documentation (#5165)
70581bb08 test: Skip test if console log is None (#5188)
ea54139a0 fix(dhcp): Enable interactively running cloud-init init --local (#5166)
9bcb3dce9 test: Update message for netplan apply dbus issue
d1351890f test: install software-properties-common if absent during PPA setup
bc18820a6 test: bump pycloudlib to use latest version
edec7dcf7 test: Update version of hello package installed on noble
5d587ecd0 test: universally ignore netplan apply dbus issue (#5178)
b86f4066f chore: Remove obsolete nose workaround
b9aff9474 feat: Add support for FTP and FTP over TLS (#4834)
197409efd feat(opennebula): Add support for posix shell
d01c9ed80 test: Make analyze tests not depend on GNU date
ff06c1054 test: Eliminate bash dependency from subp tests
8778506ad docs: Add breaking changes section to reference docs (#5147)
93f5a0165 util: add log_level kwarg for logexc() (#5125)
5c200af23 refactor: Make device info part of distro definition (#5067)
1aa5c7031 refactor: Distro-specific growpart code (#5067)
596266ac1 test(ec2): fix mocking with responses==0.9.0 (focal) (#5163)
d075d43a4 chore(safeyaml): Remove unicode helper for Python2 (#5142)
6d5978bb6 Revert "test: fix upgrade dhcp6 on ec2 (#5131)" (#5148)
01027e5a0 refactor(net): Reuse netops code
1763e1d35 refactor(iproute2): Make expressions multi-line for legibility
42becf13d feat(freebsd): support freebsd find part by gptid and ufsid (#5122)
0a3a5e250 feat: Determining route metric based on NIC name (#5070)
ec384da45 test: Enable profiling in integration tests (#5130)
414c310eb dhcp: support configuring static routes for dhclient's unknown-121 option (#5146)
ffacae61a feat(azure): parse ProvisionGuestProxyAgent as bool (#5126)
516fad6d9 fix(url_helper): fix TCP connection leak on readurl() retries (#5144)
da9b22296 test: pytest-ify t/u/sources/test_ec2.py
1feb32947 Revert "ec2: Do not enable dhcp6 on EC2 (#5104)" (#5145)
2f9812e80 fix: Logging sensitive data
4a134bf7f test: Mock ds-identify systemd path (#5119)
f6ac6ee8a fix(dhcpcd): Make lease parsing more robust (#5129)
9758673f6 test: fix upgrade dhcp6 on ec2 (#5131)
77771023a net/dhcp: raise InvalidDHCPLeaseFileError on error parsing dhcpcd lease (#5128)
a6e09d9bf fix: Fix runtime file locations for cloud-init (#4820)
2c7ca5e92 ci: fix linkcheck.yml invalid yaml (#5123)
372e80f8e net/dhcp: bump dhcpcd timeout to 300s (#5127)
f0fb84188 ec2: Do not enable dhcp6 on EC2 (#5104)
9929a0058 fix: Fall back to cached local ds if no valid ds found (#4997)
9d598f238 ci: Make linkcheck a scheduled job (#5118)
8f806e20b net: Warn when interface rename fails
f74b61eae ephemeral(dhcpcd): Set dhcpcd interface down
4de8dc2a2 Release 24.1.3
e1c19a596 chore: Handle all level 1 TiCS security violations (#5103)
cdbbd17ae fix: Always use single datasource if specified (#5098)
9a7674af7 fix(rhel): Fix network ordering in sysconfig
97537494d feat: Use NetworkManager renderer by default in RHEL family
180a62313 fix: Allow caret at the end of apt package (#5099)
1c64ee1b8 test: Add missing mocks to prevent bleed through (#5082)
9633a7b0f fix: Ensure network config in DataSourceOracle can be unpickled (#5073)
0aa17cd10 docs: set the home directory using homedir, not home (#5101)
b97227406 fix(cacerts): Correct configuration customizations for Photon (#5077)
7672a1681 fix(test): Mock systemd fs path for non-systemd distros
6a2cd02fc fix(tests): Leaked subp.which mock
45a9b7ca0 fix(networkd): add GatewayOnLink flag when necessary (#4996)
1dfffd066 Release 24.1.2
dc0eafbc7 test: fix `disable_sysfs_net` mock (#5065)
5062bee05 refactor: don't import subp function directly (#5065)
144782a83 test: Remove side effects from tests (#5074)
accdfe6a8 refactor: Import log module rather than functions (#5074)
cbe5f3a11 fix: Fix breaking changes in package install (#5069)
ff40d1af8 fix: Undeprecate 'network' in schema route definition (#5072)
02515b804 refactor(ec2): simplify convert_ec2_metadata_network_config
a3aa44f16 fix(ec2): fix ipv6 policy routing
cacf452bd fix: document and add 'accept-ra' to network schema (#5060)
dbe67393b bug(maas): register the correct DatasourceMAASLocal in init-local (#5068)
d8e3a4b4d ds-identify: Improve ds-identify testing flexibility (#5047)
b1bfa594b fix(ansible): Add verify_commit and inventory to ansible.pull schema (#5032)
e517f5abd doc: Explain breaking change in status code (#5049)
18daab5ca gpg: Handle temp directory containing files (#5063)
82a5fb358 distro(freebsd): add_user: respect homedir (#5061)
3ad7f2876 doc: Install required dependencies (#5054)
1f19c5cde networkd: Always respect accept-ra if set (#4928)
c461cc152 chore: ignore all cloud-init_*.tar.gz in .gitignore (#5059)
f7c1c7610 test: Don't assume ordering of ThreadPoolExecutor submissions (#5052)
9c001cf3f feat: Add new distro 'azurelinux' for Microsoft Azure Linux. (#4931)
7281055f8 fix(gpg): Make gpg resilient to host configuration changes (#5026)
79ee65623 Sync 24.1.1 changelog and version
e544a0db8 DS VMware: Fix ipv6 addr converter from netinfo to netifaces (#5029)
586ff2d83 packages/debian: remove dependency on isc-dhcp-client (#5041)
94609bcb6 test: Allow fake_filesystem to work with TemporaryDirectory (#5035)
4ece79d62 tests: Don't wait for GCE instance teardown (#5037)
9c64aba29 fix: Include DataSourceCloudStack attribute in unpickle test (#5039)
df522fdad bug(vmware): initialize new DataSourceVMware attributes at unpickle (#5021)
52c6abdd0 fix(apt): Don't warn on apt 822 source format (#5028)
ccd438eec fix(atomic_helper.py): ensure presence of parent directories (#4938)
c6f1e61f4 fix: Add "broadcast" to network v1 schema (#5034)
3fd0e4398 pro: honor but warn on custom ubuntu_advantage in /etc/cloud/cloud.cfg (#5030)
faeca647f net/dhcp: handle timeouts for dhcpcd (#5022)
9c77b3896 fix: Make wait_for_url respect explicit arguments
29edefe78 test: Fix scaleway retry assumptions
eadaaf095 fix: Make DataSourceOracle more resilient to early network issues (#5025)
621c522cc chore(cmd-modules): fix exit code when --mode init (#5017)
d9204fcf1 feat: pylint: enable W0201 - attribute-defined-outside-init
1488c7402 refactor: Ensure no attributes defined outside __init__
8bfad0ca1 chore: disable attribute-defined-outside-init check in tests
30d5e9a33 refactor: Use _unpickle rather than hasattr() in sources
0579f61f7 chore: remove unused vendordata "_pure" variables
0c8056992 chore(cmd-modules): deprecate --mode init (#5005)
9baf31c71 tests: drop CiTestCase and convert to pytest
463d36cc2 bug(tests): mock reads of host's /sys/class/net via get_sys_class_path
67685d65f fix: log correct disabled path in ds-identify (#5016)
3462445b5 tests: ec2 dont spend > 1 second retrying 19 times when 3 times will do
bee1d8372 tests: openstack mock expected ipv6 IMDS
e4bd2fc30 bug(wait_for_url): when exceptions occur url is unset, use url_exc
b7d442fb0 feat(run-container): Run from arbitrary commitish (#5015)
538412a54 tests: Fix wsl test (#5008)
69da05cda feat(ds-identify): Don't run unnecessary systemd-detect-virt (#4633)
d86f35a80 chore(ephemeral): add debug log when bringing up ephemeral network (#5010)
5b80ba180 release: sync changelog and version (#5011)
a576d11ef Cleanup test_net.py (#4840)
2ba7fdf0e refactor: remove dependency on netifaces (#4634)
d15779535 feat: make lxc binary configurable (#5000)
f8ac76e40 docs: update 404 page for new doc site and bug link
4a0534f89 test(aws): local network connectivity on multi-nics (#4982)
b538549d8 test: Make integration test output more useful (#4984)
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-extended/cloud-init/cloud-init_git.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-extended/cloud-init/cloud-init_git.bb b/recipes-extended/cloud-init/cloud-init_git.bb index 6cb3d3b5..a31fd591 100644 --- a/recipes-extended/cloud-init/cloud-init_git.bb +++ b/recipes-extended/cloud-init/cloud-init_git.bb | |||
@@ -7,13 +7,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c6dd79b6ec2130a3364f6fa9d6380408 \ | |||
7 | file://LICENSE-Apache2.0;md5=3b83ef96387f14655fc854ddc3c6bd57 \ | 7 | file://LICENSE-Apache2.0;md5=3b83ef96387f14655fc854ddc3c6bd57 \ |
8 | " | 8 | " |
9 | 9 | ||
10 | SRCREV = "e982c20875db3750c8dfc1915e7a4cee37376924" | 10 | SRCREV = "4b475ed36ad99819f64eee7966ec9f5da41cb638" |
11 | SRC_URI = "git://github.com/canonical/cloud-init;branch=24.1.x;protocol=https \ | 11 | SRC_URI = "git://github.com/canonical/cloud-init;branch=24.4.x;protocol=https \ |
12 | file://cloud-init-source-local-lsb-functions.patch \ | 12 | file://cloud-init-source-local-lsb-functions.patch \ |
13 | file://0001-setup.py-check-for-install-anywhere-in-args.patch \ | 13 | file://0001-setup.py-check-for-install-anywhere-in-args.patch \ |
14 | " | 14 | " |
15 | 15 | ||
16 | PV = "v23.4.1+git" | 16 | PV = "v24.4.1+git" |
17 | 17 | ||
18 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
19 | 19 | ||