diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-06-19 15:10:08 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-07-10 15:59:26 +0000 |
commit | 93113db99cb4f05dd2bd391a3e10b7600dba3d28 (patch) | |
tree | 2a1e30fae117c1fecabc53f238b38931822fbe40 | |
parent | 59a433c1f28657e0364432dcae29db4d5bb2f05f (diff) | |
download | meta-virtualization-93113db99cb4f05dd2bd391a3e10b7600dba3d28.tar.gz |
moby: update to v26.1.4
Bumping moby to version v26.1.4-4-gf5334644ec, which comprises the following commits:
c1d4587d76 builder/mobyexporter: Add missing nil check
daba2462f5 docs: api: image inspect: remove Container and ContainerConfig
17315a20ee vendor: github.com/containerd/containerd v1.7.18
cbd94183ab update containerd binary to v1.7.18
3115daaa91 update to go1.21.11
12072173df Update containerd to v1.7.17
92f00d41ba vendor: github.com/Microsoft/go-winio v0.6.2
a046857fbf vendor: golang.org/x/tools v0.16.0
476d9314d0 vendor: golang.org/x/mod v0.17.0
4021fa775e update docker-py to 7.1.0
0fd5efe64a docs/api: add Scope, ConfigOnly, ConfigFrom, Peers (v1.41 - v1.45)
1017246d24 api: swagger: Network: add Peers
fbfa1bcc96 api: swagger: POST /networks/create: document Scope, ConfigOnly, ConfigFrom
e12db89eef api: swagger: Network: inline examples, and add ConfigOnly, ConfigFrom
5838467405 docs/api: POST /networks/create: inline examples per-field (v1.41 - v1.45)
1033f561af api: swagger: POST /networks/create: inline examples per-field
0fa6816991 api/types: NetworkCreate: add GoDoc
eaad6f503d don't depend on containerd platform.Parse to return a typed error
fda7b48363 Fix issue where node promotion could fail
dbec963cee integration/TestDiskUsage: Make 4096 also a 'empty' value
e35c6f5625 Dockerfile: update containerd binary to v1.7.17 (static binaries and CI only)
06e19ec444 Explicity write http headers on streaming endpoints
c21fe3efa3 Forward DNS requests into --internal networks
9326cda7bf Do not forward DNS requests to self.
76fcf9a8e0 apparmor: Allow confined runc to kill containers
10739af81a update to go1.21.10
2f5bbbe16b Option to avoid deleting the kernel_ll address from bridges.
40618081f1 Allow for a read-only "/proc/sys/net".
2c91196921 Update containerd to v1.7.16
c9689eccf5 vendor: update buildkit to v0.13.2
7d95fe8db5 c8d/list: Ignore unexpected image target
6667e96dad Include more details in errnotManifestOrIndex
ab570ab3d6 nil dereference fix on image history Created value
7532420f3b container/SetupWorkingDirectory: Don't mutate config
a4d5b6b4d0 builder/normalizeWorkdir: Always return cleaned path
6c68be24a2 Windows DNS resolver forwarding
745e2356ab Update tags.cncf.io/container-device-interface to v0.7.1
0d6a1a212b vendor: github.com/opencontainers/runtime-spec v1.2.0
f5209d23a8 daemon: add nolint-comments for deprecated kernel-memory options, hooks
f07644e17e Add netiputil.AddrPortFromNet()
d3c051318f daemon/cluster/executor: Add volume `Subpath`
5368c3a04f vendor: github.com/moby/swarmkit/v2 master (f3ffc0881d0e)
f51e18f58e Fix typo
57dd56726a Disable IPv6 for endpoints in '--ipv6=false' networks.
9954d7c6bd Run ipvlan tests even if 'modprobe ipvlan' fails
cd7240f6d9 Stop macvlan with no parent from using ext-dns
17b8631545 Enable DNS proxying for ipvlan-l3
5ae5969739 vendor: github.com/containerd/containerd v1.7.15
3485cfbb1e update containerd binary to v1.7.15
fb92caf2aa ci/validate-pr: Use `::error::` command to print errors
61269e718f github/ci: Check if backport is opened against the expected branch
d8b768149b Move dummy DNS server to integration/internal/network
329d403e20 update to go1.21.9
d66589496e vendor: golang.org/x/net v0.23.0
e1ca74361b vendor: golang.org/x/net v0.22.0, golang.org/x/crypto v0.21.0
cf933115b6 Minor fix for illumos support
9160b9fda6 save: Remove platform from config descriptor
0a48d26fbc Fix cases where we are wrapping a nil error
c4689034fd daemon: don't call NetworkMode.IsDefault()
4eed3dcdfe api: normalize the default NetworkMode
c187f95fe1 CONTRIBUTING.md: update Slack link
aff003139c ci: update workflow artifacts retention
1014f481de Restore the SetKey prestart hook.
fde80fe2e7 Restore the SetKey prestart hook.
14a8fac092 chore: fix mismatched function names in godoc
61e2199b78 AUTHORS,.mailmap: update with recent contributors
ea72f9f72c Dockerfile: update docker CLI to v26.0.0
22726fb63b api: document changed behavior of the `Aliases` field in v1.45
3312b82515 c8d/list: Add a test case for images sharing a top layer
ad8a5a5732 c8d/list: Fix diffIDs being outputted instead of chainIDs
0c2d83b5fb c8d/list: Handle unpacked layers when calculating shared size
f696e0d2a7 Dockerfile: avoid hardcoding arch combinations for delve
3d2a56e7cf docs/api: add documentation for API v1.45
731a64069f c8d/list: Generate image summary concurrently
dade279565 c8d/list: Add `Images` benchmark
e7c60a30e6 vendor: github.com/moby/buildkit v0.13.1
2e4ebf032a c8d/list: Pass ctx to setupLabelFilter
153de36b3f c8d/list: Add empty index test case
4ff655f4b8 resolvconf: add //go:build directives to prevent downgrading to go1.16 language
1c03312378 integration: Remove Parallel from TestDiskUsage
f512dba037 c8d/list: Fix premature `Images` return
89dc2860ba c8d/list: Handle missing configs in label filter
6f3892dc99 c8d/list: Don't setup label filter if it's not specified
fe8fb9b9a1 Dockerfile: update mvdan/shfmt to v3.8.0
4bd30829d1 Dockerfile: update docker compose to v2.25.0
971562b005 Dockerfile: update docker CLI to v26.0.0-rc2
d742659877 rootless: fix `open /etc/docker/plugins: permission denied`
4f46c44725 Dockerfile: update xx to v1.4.0
25c9e6e8df Makefile: generate-files: fix check for empty TMP_OUT
762ec4b60c plugin: fix mounting /etc/hosts when running in UserNS
7b414f5703 daemon: move getUnprivilegedMountFlags to internal package
790c3039d0 libnet: Don't forward to upstream resolvers on internal nw
10bdc7136c builder-next: Add env-var to override runc used by buildkit
1ca89d7eae vendor: google.golang.org/protobuf v1.33.0, github.com/golang/protobuf v1.5.4
f40bdf5f63 Dockerfile: update compose to v2.24.7
3f73d23ea0 Dockerfile: update buildx to v0.13.1
388ecf65bc c8d: Send push metrics to prom
bb3ab1edb7 c8d: Send pull metrics to prom
da245cab15 c8d: Send history metrics to prometheus
1cfd763214 c8d: Send image delete metrics to prometheus
0ce714a085 images: Export the image actions prometheus counter
bcb4794eea Be more explicit about non-TLS TCP access deprecation
0d5ef431a1 docker-py: Temporarily skip `test_commit` and `test_commit_with_changes`
03cddc62f4 api/image-inspect: Remove Container and ContainerConfig
ec19fd6fed vendor: github.com/containerd/containerd v1.7.14
d19f6d4b6d vendor: github.com/containerd/ttrpc v1.2.3
a6a445d86b set-up-git.md: clarify URL in git clone command
294fc9762e volume: Don't decrement refcount below 0
eef352b565 devcontainer: Use a separate devcontainer target
5a009cdd5b inte/networking: add isIPv6 flag
2f1a32e3e5 c8d/list: Skip images with non matching platform
72f1f82f28 c8d/list: Remove outdated TODO
52a80b40e2 c8d/list: Extract imageSummary function
288a14e264 c8d/list: Simplify "best" image selection
b37ced2551 c8d/list: Count containers by their manifest
a535a65c4b c8d/list: Combine size
582de4bc3c c8d/list: Add TestImageList
a6e7e67d3a specialimage: Return optional ocispec.Index
1b108bdfeb daemon/c8d: Cache SnapshotService
74e2f23e1a daemon/c8d: Use i.images and i.content
e8496b1ee4 imageService: Extract common code from `MakeImageCache`
d66177591e c8d/cache: Use the same cache logic as graphdrivers
bf30fee58a image/cache: Refactor backend specific code
f5a5e3f203 golangci-lint: enable dupword linter
4adc40ac40 fix duplicate words (dupwords)
8921897e3b Ignore bad ndots in host resolv.conf
37545cc644 builder-next: fix missing lock in ensurelayer
ef5295cda4 Don't configure IPv6 addr/gw when IPv6 disabled.
49b77753cb builder-next/export: Use leaseutil for descref lease
c4fc6c3371 builder-next/executor: Replace removed network.Sample
0f30791a0d vendor: github.com/moby/buildkit v0.13.0
4e8d9a4522 Add IPv6 nameserver to the internal DNS's upstreams.
06628e383a remove repetitive words
21835a5696 inte/networking: rename linkLocal flag into isLinkLocal
b32cfc3b3a dockerd-rootless-setuptool.sh: check RootlessKit functionality
49fd8df9b9 Dockerfile: update RootlessKit to v2.0.2
72ec187dfe go.mod: github.com/rootless-containers/rootlesskit/v2 v2.0.2
83cda67f73 go.mod: golang.org/x/sys v0.18.0
57b7ffa7f6 update to go1.21.8
cadb124ab6 daemon: overlay2: remove world writable permission from the lower file
b2921509e5 api/search: Reset `is_automated` field to `false`
f04f69e366 Accumulate resolv.conf options
7f69142aa0 resolv.conf comments have '#' or ';' in the first column
91d9307738 Replace uses of slices.Clone()
12dea3fa9e devcontainer: Add Golang extension automatically
9f4e824a6e vendor: github.com/miekg/dns v1.1.57
ef681124ca fix typo in error message
7ebd88d2d9 hack: block imports of vendored testify packages
4f30a930ad libn/cnmallocator: migrate tests to gotest.tools/v3
a580544d82 Don't create endpoint config for MAC addr config migration
ebf3f8c7fe distribution/xfer: fix pull progress message
2af2496c8c Dockerfile: Update dev cli to v26.0.0-rc1
fc0e5401f2 ci: Update `teststat` to v0.1.25
7b0ab1011c Vendor dependency cycle-free swarmkit
62b33a2604 disable pulling legacy image formats by default
5fe96e234d integration: Reset `OTEL_EXPORTER_OTLP_ENDPOINT` for sub-daemons
84eecc4a30 Revert "integration/TestDaemonProxy: Remove OTEL span"
261dccc98a builder-next: Add `Info` to `emptyProvider`
2c9c5e1c03 vendor: github.com/moby/buildkit v0.13.0-rc3
b649e272bb Allow to enable host loopback and use 10.0.2.2 to connect to the host (OPTIONALLY)
e4de4dea5c ci: Make `find` for test reports more specific
9be820d8ca vendor: go.etcd.io/bbolt v1.3.9
da643c0b8a libcontainerd: change the digest used when restoring
9083c2f10d Test DNS on Windows 'nat' networks
44167988c3 c8d/windows: Temporarily skip two failing tests
2d31532a00 otel: Default metrics protocol to http/protobuf
60358bfcab ci(buildkit): dedicated step to build test image
f5722da5e0 mobyexporter: Store temporary config descriptor
951e42cd60 builder-next: Replace ResolveImageConfig with ResolveSourceMetadata
e01a1c5d09 builder/mobyexporter: Set `image.name` response key
fa467caf4d builder-next/mobyexporter: Use OptKeyName const
59ad1690f7 builder-next: Adjust to source changes
b04a2dad6b builder/controller: Adjust NewWorkerOpt call
bc6d88c09a cmd/dockerd: Fix overriding OTEL resource
a79bb1e832 builder-next/exporter: Sync with new signature
e68f71259a integration/build: Use fsutil.NewFS
dd6992617e integration/build: Use new buildkit progressui
31545c3b67 vendor: github.com/moby/buildkit v0.13.0-rc2
f90b03ee5d go.mod: bump to go 1.21 and use local toolchain when vendoring
16aa7dd67f c8d/pull: Output truncated id for `Pulling fs layer`
881260148f api: omit missing Created field from ImageInspect response
432390320e api/pre-1.44: Default `ReadOnlyNonRecursive` to true
6aea26b431 client: fix connection-errors being shadowed by API version mismatch errors
913478b428 client: doRequest: make sure we return a connection-error
901b90593d client: NegotiateAPIVersion: do not ignore (connection) errors from Ping
349abc64ed client: fix TestPingWithError
05b883bdc8 mounts/validate: Don't check source exists with CreateMountpoint
c516804d6f vendor: OTEL v0.46.1 / v1.21.0
83c02f7a11 libnet/ds: remove extra space in error msg
14df52b709 c8d/pull: Don't emit `Downloading` with 0 progress
ff5f780f2b c8d/pull: Emit `Pulling fs layer`
5689dabfb3 pkg/streamformatter: Make `progressOutput` concurrency safe
1d473549e8 ci: Require changelog description
b2aaf5c2b0 vendor: github.com/containerd/continuity v0.4.3
cbd45e83cf libnet: Replace DeleteAtomic in retry loops with DeleteIdempotent
d9e082ff54 libnetwork: resolve: use structured logs for DNS error
8761bffcaf Makefile: Pass PAGER/GIT_PAGER variable
56aeb548b2 integration/TestDaemonProxy: Remove OTEL span
38827ba290 ci: set codecov token
bddd892e91 c8d: Adjust "image list" to return only a single item for each image store entry
2aa13e950d awslogs: Replace depreacted WithEndpointResolver usage
70a4a9c969 vendor: bump github.com/aws/aws-sdk-go-v2/service/cloudwatchlogs to v1.32.0
9faf4855d5 Simplify macvlan/ipvlan integration test structure
4eb95d01bc Run the macvlan/ipvlan integration tests
7c2975d2df update to go1.21.7
903412d0fc api/history: Mention empty `Created`
443f56efb0 Set up DNS names for Windows default network
b4fbe226e8 Set `Created` to `0001-01-01T00:00:00Z` on older API versions
5bcd2f6860 builder/dockerfile: ADD with best-effort xattrs
999f90ac1c vendor: bump github.com/aws/aws-sdk-go-v2 to v1.24.1
ef7766304c vendor: github.com/containerd/nydus-snapshotter v0.13.7
6932939326 vendor: google.golang.org/genproto/googleapis/rpc 49dd2c1f3d0b
10a72f2504 vendor: cloud.google.com/go/logging v1.8.1
a60fef0c41 vendor: golang.org/x/exp v0.0.0-20231006140011-7918f672742d
03a17a2887 migrate image spec to github.com/moby/docker-image-spec
a26c953b94 Add comment explaining network-create flow for Swarm
571af915d5 Don't enforce new validation rules for existing networks
b71c2792d2 image/spec: remove link to docs.docker.com "registry" specification
4ab11a1148 vendor: github.com/containerd/containerd v1.7.13
419f5a6372 Make 'internal' bridge networks accessible from host
475019d70a vendor: github.com/prometheus/procfs v0.12.0
63c354aae2 vendor: github.com/prometheus/client_golang v1.17.0
beb97f7fdf Refactor 'resolv.conf' generation.
14503ccebd api/server/middleware: NewVersionMiddleware: add validation
e1897cbde4 api/server/middleware:use API-consts in tests
0fef6e1c99 api/server/middleware: VersionMiddleware: improve docs
6b01719ffb api: add MinSupportedAPIVersion const
19a04efa2f api: remove API < v1.24
8758d08bb4 api: remove handling of HostConfig on POST /containers/{id}/start (api < v1.24)
ffd877f948 api: remove plain-text error-responses (api < v1.24)
b3a0ff9944 api: remove POST /containers/{id}/copy endpoint (api < v1.23)
83f790cccc api: POST /exec/{id}/start: remove support for API < v1.21
d1974aa492 api: remove code for container stats on api < v1.21
ed93110e11 api: update test to reflect reality on Windows
570d5a9645 api: remove code for ContainerInspect on api v1.20
f0dd554e3c api: remove code for ContainerInspect on api < v1.20
dfdf2adf0c api: POST /containers/{id}/kill: remove handling for api < 1.20
2970b320aa api: remove code for adjusting CPU shares (api < v1.19)
ef25f0aa52 api: POST /build: remove version-gate for "pull" (api < v1.16)
7fa116830b api: POST /build: remove version-gate for "rm", "force-rm" (api < v1.16)
1b1147e46b api: POST /commit: remove version-gate for "pause" (api < v1.16)
d26bdfe226 runconfig: remove fixtures for api < v1.19
f1e6958295 c8d: Use the same logic to get the present images
2c01d53d96 image/cache: Use Platform from ocispec
d69729e053 seccomp: add futex_wake syscall (kernel v6.7, libseccomp v2.5.5)
10d344d176 seccomp: add futex_wait syscall (kernel v6.7, libseccomp v2.5.5)
df57a080b6 seccomp: add futex_requeue syscall (kernel v6.7, libseccomp v2.5.5)
8826f402f9 seccomp: add map_shadow_stack syscall (kernel v6.6, libseccomp v2.5.5)
6f242f1a28 seccomp: add fchmodat2 syscall (kernel v6.6, libseccomp v2.5.5)
4d0d5ee10d seccomp: add cachestat syscall (kernel v6.5, libseccomp v2.5.5)
1251982cf7 seccomp: add set_mempolicy_home_node syscall (kernel v5.17, libseccomp v2.5.4)
7f1b700227 Dockerfile: update RootlessKit to v2.0.1
f1730a6512 go.mod: github.com/rootless-containers/rootlesskit/v2 v2.0.1
f7192bb0b4 vendor.mod: github.com/google/uuid v1.6.0
91ea04089b image/cache: Ignore Build and Revision on Windows
2ef0b53e51 integration/save: Add tests checking OCI archive output
74d51e8553 plugins: fix panic installing from repo w/ digest
e910a79e2b Remove 'VERSION' from the text
9fcea5b933 Fix broken links in project/README.md
10d6f5213a Dockerfile: update docker compose to v2.24.5
9c92c07acf Dockerfile: update dev-shell version of the cli to v25.0.2
89470a7114 libnet: bridge: ignore EINVAL when configuring bridge MTU
e37172c613 api/t/network: ValidateIPAM: ignore v6 subnet when IPv6 is disabled
c59e93a67b Revert "daemon: automatically set network EnableIPv6 if needed"
83af50aee3 libnet: boltdb: inline getDBhandle()
4d7c11c208 libnet: boltdb: remove PersistConnection
8070a9aa66 libnet: drop TestMultipleControllersWithSameStore
82dda18898 tests: add plugin install test w/ digest
dd20bf4862 libcontainerd/supervisor: fix data race
0c3b8ccda7 api: Document `version` in `/build`
2cc627932a Add internal n/w bridge to firewalld docker zone
8c64b85fb9 No inspect 'Config.MacAddress' unless configured.
dae33031e0 Only restore a configured MAC addr on restart.
a2026ee442 ci: update to docker/bake-action@v4
5a3c463a37 ci: update to codecov/codecov-action@v4
9babc02283 ci: update to actions/download-artifact@v4 and actions/upload-artifact@v4
a83557d747 ci: update to actions/cache@v3
2200c0137f libnetwork/datastore: don't parse file path
d21d0884ae libnetwork: share a single datastore with drivers
835cdcac95 update containerd binary to v1.7.13
f4a93b6993 vendor: github.com/moby/buildkit v0.12.5
b20dccba5e vendor: github.com/opencontainers/runc v1.1.12
44bf407d4d update runc binary to v1.1.12
ecb217cf69 hack/make.ps1: Fix go list pattern
3a8191225a gha: update to crazy-max/ghaction-github-runtime@v3
08251978a8 gha: update to docker/login-action@v3
5d396e0533 gha: update to docker/setup-qemu-action@v3
4a1839ef1d gha: update to docker/bake-action@v4
b7fd571b0a gha: update to docker/setup-buildx-action@v3
00a2626b56 gha: update to docker/metadata-action@v5
e27a785f43 gha: update to actions/setup-go@v5
fb53ee6ba3 gha: update to actions/github-script@v7
0ffddc6bb8 gha: update to actions/checkout@v4
987fe37ed1 d/logger/journald: quit waiting when logger closes
d53b7d7e46 d/logger/journald: sync logger on close in tests
39c5c16521 d/logger/loggertest: improve TestConcurrent
5792bf7ab3 d/logger/journald: log journal-remote cmd output
982e777d49 d/logger/journald: fix data race in test harness
ca40ac030c vendor: google.golang.org/grpc v1.59.0
0818a476e5 vendor: github.com/go-logr/logr v1.3.0
a0b53f6fd2 vendor: golang.org/x/net v0.18.0
2ddec74d59 Remove unused params from etchosts.Build()
5e13f54f57 c8d/save: Handle digested reference same as ID
d131f00fff image/save: Fix untagged images not present in index.json
21136865ac libnet: remove arg `options` from (*Endpoint).Leave()
a8e8a4cdad libn/d/overlay: drop miss flags from peerAddOp
6ee58c2d29 libnetwork/d/overlay: drop miss flags from peerAdd
905477c8ae logger/journald: drop errDrainDone sentinel
d70fe8803c logger/journald: wait no longer than the deadline
e94ec8068d logger/journald: use deadline for drain timeout
71bfffdad1 l/journald: make tests compatible with systemd 255
931568032a daemon/logger/loggertest: expand log-follow tests
388ba9a69c Dockerfile: update docker compose to v2.24.3
3eb1527fdb Dockerfile: update dev-shell version of the cli to v25.0.1
7f94acb6ab docs: remove dead links from api verison history
5c2eda6f71 vendor swarmkit v2.0.0-20240125134710-dcda100a8261
96d461d27e builder/windows: Don't set ArgsEscaped for RUN cache probe
877ebbe038 image/cache: Check image platform
96ac22768a image/cache: Restrict cache candidates to locally built images
c6156dc51b daemon/imageStore: Mark images built locally
537348763f image/cache: Compare all config fields
bd4ff31775 add more //go:build directives to prevent downgrading to go1.16 language
e245fb76de internal/sliceutil: add utilities to map values
3147a013fb libnet/ds: remove unused param `key` from List
f7ef0e9fc7 libnet/ds: remove unused param `key` from GetObject
3a617e5463 c8d: Use a specific containerd namespace when userns are remapped
f7e2357745 image: remove deprecated IDFromDigest
13f46948dd api/types: remove deprecated container-types
4b09bc2145 api/types: remove deprecated service-types
49637d0206 api/types: remove deprecated image-types
eccb1a3eb8 api/types: remove deprecated checkpoint-types
0b1921649f api/types: remove deprecated system info types and functions
6f44138269 libnetwork: fix tiny grammar mistake on design.md
9a41cc58d9 libnetwork: fix typo in iptables.go
ac2a028dcc api/types: move image options to api/types/image
80c44b4b2e daemon: rename: don't reload endpoint from datastore
250886741b volume/local: Fix cifs url containing spaces
f4beb130b0 volume/local: Add tests for parsing nfs/cifs mounts
df43311f3d volume/local: Break early if `addr` was specified
9f37672ca8 daemon: only add short cid to aliases for custom networks
c25773ecbf cmd/dockerd: newRouterOptions: pass cluster as argument, and slight cleanup
00c9785e2e fix "host-gateway-ip" label not set for builder workers
0d51cf9db8 volume/local: Make host resolution backwards compatible
05d952b246 Dockerfile: update docker compose to v2.24.2
20bd690844 integration-cli: simplify test-file creation
34668a5945 pkg/archive: fixe some unclosed file-handles in tests
1090aaaedd libnetwork: fix some unclosed file-handles in tests
c482383458 fix some leaking mounts in tests
43bf65c174 pkg/system: return even richer xattr errors
a3a42c459e api/types/image: move GetImageOpts to api/types/backend
cd53b7380c Remove generated MAC addresses on restart.
fb19f1fc20 c8d/snapshot: Create any platform if not specified
6100190e5c daemon/cluster/executer: Add missing `StartInterval`
17fd6562bf image/save: Fix layers order in OCI manifest
4979605212 image/save: Change layers type to DiffID
fcc651972e daemon: return an InvalidParameter error when ep settings are wrong
a0466ca8e1 integration-cli: TestInspectAPIMultipleNetworks: use current version
13a384a6fa integration-cli: TestInspectAPIBridgeNetworkSettings121: use current version
52e3fff828 integration-cli: TestPutContainerArchiveErrSymlinkInVolumeToReadOnlyRootfs: use current API
521123944a docs/api: remove version matrices from swagger files
d54be2ee6d docs: remove documentation for deprecated API versions < v1.23
64a6cc3afd integration/build: improve some asserts, and add asserts for unhandled errs
a88cd68d3e integration/images: improve some asserts, and add asserts for unhandled errs
a404017a86 vendor: golang.org/x/tools v0.14.0
41a2aa2ee2 vendor: golang.org/x/oauth2 v0.11.0
2799417da1 vendor: golang.org/x/mod v0.13.0, golang.org/x/tools v0.13.0
407ad89ff0 vendor: golang.org/x/sync v0.5.0
94b4765363 pkg/platforms: internalize in daemon/containerd
0a9bc3b507 libnetwork: Sandbox.ResolveName: refactor ordering of endpoints
058b30023f libnetwork: loosen container IPAM validation
844ca49743 pkg/containerfs: remove deprecated ResolveScopedPath
2767d9ba05 pkg/homedir: remove deprecated Key() and GetShortcutString()
f16a2179a6 pkg/system: remove deprecated ErrNotSupportedOperatingSystem, IsOSSupported
e2086b941f remove deprecated pkg/loopback (utility package for devicemapper)
f07c45e4f2 daemon: remove --oom-score-adjust flag
307fe9c716 Dockerfile: update docker compose to v2.24.1
dfced4b557 Dockerfile: update dev-shell version of the cli to v25.0.0
c655b7dc78 Assert temp output directory is not an empty string
a8f7c5ee48 Detect IPv6 support in containers.
0046b16d87 daemon: set libnetwork sandbox key w/o OCI hook
5bbcc41c20 volumes/subpath: Plumb context
cb1af229f2 daemon/populateVolumes: Support volume subpath
349a52b279 container: Change comment into debug log
42afac91d7 internal/safepath: Add windows implementation
5841ed4e5e internal/safepath: Adapt k8s openat2 fallback
56bb143a4d internal/safepath: Import k8s safeopen function
3784316d46 internal/safepath: Handle EINTR in unix syscalls
9a0cde66ba internal/safepath: Add linux implementation
bfb810445c volumes: Implement subpath mount
f2e1105056 Introduce a helper that collects cleanup functions
f07387466a daemon/oci: Extract side effects from withMounts
9c8752505f volume/mounts: Rename errors in defer block
5bcbedb7ee API: bump version to 1.45
35789fce99 daemon.images: ImageService.getImage: use named fields in struct literals
7c1914411f daemon/images: ImageService.manifestMatchesPlatform: optimize logger
5581efe7cd rename "ociimage" var to be proper camelCase
66cf6e3a7a rename "image" vars to prevent conflicts with imports
c72e458a72 Fix libnetwork/osl test TestAddRemoveInterface
768146b1b0 Fix isGitURL regular expression
585d74bad1 pkg/ioutils: Make subsequent Close attempts noop
fbdc02534a De-flake TestSwarmClusterRotateUnlockKey... again... maybe?
Bumping docker-cli to version v26.1.4-2-g6eb67bf57, which comprises the following commits:
5bab750c2 cli/command: more go1.19 ("predeclared any")
e8bc27d4c vendor: github.com/docker/docker de5c9cf0b96e (v26.1.4-dev)
2acb9c2e8 vendor: github.com/containerd/containerd v1.7.18
230d4d0ba vendor: github.com/containerd/containerd v1.7.17
6d47c06b0 vendor: tags.cncf.io/container-device-interface v0.7.2
a6d757c0e vendor: github.com/Microsoft/hcsshim v0.11.5
c463d968f vendor: github.com/opencontainers/image-spec v1.1.0
0576b3dad update to go1.21.11
60b13f1f8 Dockerfile: update ALPINE_VERSION to 3.20
b600054c5 migrate to new github.com/containerd/platforms package
dafe63b08 gha: update to actions/upload-artifact@v4
079107e1b [26.1] vendor: github.com/docker/docker v26.1.3
14d7485d9 vendor: github.com/Microsoft/go-winio v0.6.2
50bb59277 docs: tidy up CDI docs
c4767b314 docs: fix json syntax error
258e27438 context list: temporarily add ContextType to JSON output
29cd8591e cli/command/context: list: add test for JSON output
e23a63eb4 cli/command/context: test inspecting context with custom metadata
1e52a86d4 cli/command/context: add test-utility to create multiple contexts
e382a5f22 plugins/hooks: Don't show empty hooks
26e9ff49c vendor: github.com/docker/docker v26.1.3-dev (8e96db1c328d)
326c7138b OTel: implement missing MeterProvider `ForceFlush`
ee359a394 OTel: add `command.time` metric to plugin commands
669108501 Use funcs on DockerCli to return Meter/TracerProviders, not initialize them. Initialize them during DockerCli struct init
81b482ea5 docs: clarify that --data-path-addr doesn't restrict access
e64914c89 vendor: github.com/docker/docker v26.1.2-dev (ef1912d8b6ae)
c1d70d1fb update to go1.21.10
4add46d68 Add e2e tests for run w/ bad entrypoint
ccea7d8a3 Fix hang when container fails to start
1c6a8ecf2 cli-plugins: PluginRunCommand: use cmd.Environ instead of os.Environ
6d1c387af vendor: github.com/docker/docker ac2de55998d4 (v26.1.1)
840016ea0 waitExitOrRemoved: Handle context cancellation
aec1d364b vendor: github.com/docker/docker v26.1.0-dev (c8af8ebe4a89)
43cb06e1a hooks: pass command execution error to plugins
9d8320de9 hooks: include full configured command
6ad512068 vendor: github.com/docker/docker v26.1.0-dev (ee8b788538ea)
c3243a8cc ci/validate-pr: Use `::error::` command to print errors
f92fcdef1 github/ci: Check if backport is opened against the expected branch
745704d7b ci: Require changelog description
762a85a10 Warn about deprecation of windows-dns-proxy flag
501175905 hooks: set expected environment when executing
d6796c002 Fix OTLP env var overriding
c449c1a49 plugins/hooks: run hooks when exit code != 0
287f482e3 Feature option 'windows-dns-proxy'
867061b00 plugins/templates: break on newlines when printing hooks
718203d50 cli-bin/windows: Add .exe extension
5515b8651 vendor: github.com/docker/docker v26.0.1-0.20240410103514-f9dfd139ec0d+incompatible (master)
c1053bf9d vendor: github.com/moby/swarmkit/v2 v2.0.0-20240227173239-911c97650f2e
8a3a7b945 vendor: github.com/containerd/containerd v1.7.15
458580984 docs: add systempaths=unconfined security-opt
5fcbbde4b vendor: golang.org/x/net v0.23.0
4745b957d vendor: golang.org/x/net v0.22.0, golang.org/x/crypto v0.21.0
c7a50ebb9 vendor: golang.org/x/term v0.18.0
9a2133f2d vendor: golang.org/x/sys v0.18.0
0a5bd6c75 update to go1.21.9
cefcba987 otel: capture exit code as int64
ee1b2836a otel: capture whether process was invoked from a terminal
8f45f1495 command: include default otel error handler for the cli
910d5d024 chore: remove backticks and resolve linting issues
2a3b6c03f cli: add go:build tag to the docker telemetry
efd82e1e3 Initial otel impl using our utils
b6e2eca4b Enable overriding of the otel exporter otlp endpoint via env var for testing purposes
160f65d9d Added some telemetry utils
9a1b0f8bb CONTRIBUTING.md: update Slack link
7c722c08d feat: standardize error for prompt
7ea10d5ce refactor: prompt tests
89db01ef9 cli: add otel sdk tracing and metric providers to the core cli
c5016c6d5 cli-plugins: Introduce support for hooks
509123f93 plugin: drop explicit unlink
fdb48a066 vendor: github.com/docker/docker v26.0.0
542e82cae plugin: update/improve process lifecycle documentation
d68cc0e8d plugin: closer-based plugin notification socket
d2ea5adfe fix: flaky prompt termination on reader close test
ccfd0b2cc test/ Improve test coverage in volume.go
69575f617 vendor: github.com/docker/docker 8b79278316b5 (master)
b70a26dea vendor: github.com/docker/docker 330d777c53fb (v26.0.0-rc3-dev)
f96d8e78c docs/deprecated: update status of short cid alias deprecation
b120b96ac ci: set DISABLE_WARN_OUTSIDE_CONTAINER=1 for CodeQL action
24186d800 ci: fix CodeQL 2.16.4 autobuild
48b5efee0 Dockerfile: update mvdan/gofumpt to v0.6.0
38c3ff67a vendor: github.com/docker/docker 70e46f2c7c2d (v26.0.0-rc3-dev)
f8fc5b6bc scripts/vendor: remove -compat=1.19
a4a79d75c vendor: google.golang.org/protobuf v1.33.0, github.com/golang/protobuf v1.5.4
115c8d56e vendor: github.com/containerd/containerd v1.7.14
939283181 builder: correct the command path for docker build
dc4163fb1 docs/deprecated: Deprecate Container fields in image inspect
3da26a5e7 docs: add description and link for --userns flag
4bb2abaa5 docs: typo fixes and other corrections
90c33dbfd deprecate legacy image formats
800a51d6c Set CGO_ENABLED=1 on riscv64
9349f58b8 docs: clarify what the --privileged flag does
adb018084 Dockerfile: update to xx 1.4.0
46afd26c4 cli/command: deprecate EventHandler and InitEventHandler
5c54f75f2 cli/command/container: use ping-result for OS-version
617377c04 Describe an 'internal' network.
860b4f3a7 'docker daemon' flags refer to the default bridge
645b97352 vendor: github.com/docker/docker v26.0.0-rc2
3cf2fe0ff docs: deprecate TCP connection without TLS
a8379092a vendor: github.com/docker/docker f4c696eef17d62a42
ab9d56057 bake: Add `windows/arm64` target to bin-image-cross
3b7747794 update to go1.21.8
10bf91a02 fix: cli prompt termination exit code
238d659ff Add support for --detach/-d flag in stack rm
b086d7276 Add support for --detach flag in stack deploy
5e8023239 vendor: github.com/docker/docker v26.0.0-rc1
d51ba4179 docs: prefer -it over -ti
a5b82e9f8 docs: fix typo in tty example
abe78b79d chore: `docker help` should not show plugin vendor and version
5786f2068 plugins: fix encoding for OTEL env var passed to plugin
85dcacd78 plugins: set OTEL_RESOURCE_ATTRIBUTES when invoking a plugin
acc675014 vendor: github.com/docker/docker c70d7905fbd9 (v26.0.0-dev)
79541b7e2 vendor: google.golang.org/grpc v1.59.0
096ced089 vendor: OTEL v0.46.1 / v1.21.0
f3c77df31 vendor: github.com/prometheus/client_golang v1.17.0
1b42d04d6 vendor: github.com/go-logr/logr v1.3.0
f5a29ff8e vendor: github.com/containerd/containerd v1.7.13
2663c1057 ci: set codecov token
48a670f26 docs: fix invalid daemon.json examples
f2e98f9a9 docs: regenerate markdown
caf72655f docs: update url scheme for reference docs
e24404494 deps: update cli-docs-tool version (v0.7.0)
20b9d489e update to go1.21.7
c514003e6 Fixed typo in bash completion functions
ff5b0d18f man/docker-build.1: typo in parameter variable: CID => IID
3b5e81424 cli-plugins/socket: remove use of deprecated distribution uuid package
69ed6588a Cleanup of dockerfiles, compose files and env vars
6b67b9549 Update gha runners and engines used in e2e tests
edc09e603 mount: Add `volume-subpath` option
9831fea4d testenv: Add DaemonAPIVersion helper
8bae66271 cli/connhelper/commandconn: inline variables
df6220d43 vendor: github.com/docker/docker 86b86412a1b7 (v26.0-dev)
30dd7c131 Minor test fixes necessary for eventually upgrading ci runners and engine version
2c214241f Avoid keeping @docker_cli_[UUID] files
c986d09bc docker stack: allow '=' separator in extra_hosts
324309b08 vendor: github.com/docker/docker 9e075f3808a5 (master, v26.0.0-dev)
93ad9fbdf vendor: github.com/moby/swarmkit/v2 v2.0.0-20240125134710-dcda100a8261
69e0f53a0 Uniform volume prune output msg with other prune commands
809eb8cde images: print hint when invoking "docker images" with ambiguous argument
b158181a1 cli/command/images: runImages: use proper camel-case for dockerCLI
1328bb338 cli/command/images: runImages: inline intermediate var
b123ce652 build(deps): Bump codecov/codecov-action from 3 to 4
1587b70ee Remove dummy circleci config
cfa9fef77 tests: add plugin-socket-compatibility tests
dfdff11a2 cli/command: don't use pflags.XXXVarP for flags without shorthand
690f63e6d cli/command/container: minor cleanup in attach
53e2e54c2 Dockerfile: update docker compose to v2.24.3
1c4d6d85d scripts: don't hardcode architecture in e2e script
4fa2fe9b9 Replace deprecated types.Image* usage
68dac842a vendor: github.com/docker/docker 43ffb1ee9d5a (v26.0.0-dev)
4b1ed1f44 vendor: github.com/docker/docker v25.0.1
d9294f06b info: remove printSecurityOptionsWarnings, printServerWarnings
ec0a62436 docs: update host-gateway-ip to use daemon.json instead of cli flag
469bfc05e tests: add tests for `cli-plugins/socket`
091af560c Dockerfile: update docker compose to v2.24.2
2402dac81 cli/command/container: remove deprecated NewStartOptions
b43377a38 cli/command: remove deprecated DockerCliOption, InitializeOpt
a71d39bca info: remove printServerWarningsLegacy
8cd3b0042 socket: return from loop after EOF
337dd82d8 vendor: github.com/docker/docker v25.0.0
d633890f9 docs: move base command to docker.md
aff4649cb docs: fix broken links to alias pages
852d198bb docs: add documentation for CDI
1f9573bb0 Add Linode docker volume plugin
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/docker/docker-moby_git.bb | 10 |
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-containers/docker/docker-moby_git.bb b/recipes-containers/docker/docker-moby_git.bb index 41a6823d..40802353 100644 --- a/recipes-containers/docker/docker-moby_git.bb +++ b/recipes-containers/docker/docker-moby_git.bb | |||
@@ -44,14 +44,14 @@ DESCRIPTION = "Linux container runtime \ | |||
44 | # so we get that tag, and make it our SRCREVS: | 44 | # so we get that tag, and make it our SRCREVS: |
45 | # | 45 | # |
46 | 46 | ||
47 | SRCREV_moby = "f417435e5f6216828dec57958c490c4f8bae4f98" | 47 | SRCREV_moby = "f5334644ecc787861fef75c7f6d08756ffe8bbd7" |
48 | SRCREV_libnetwork = "67e0588f1ddfaf2faf4c8cae8b7ea2876434d91c" | 48 | SRCREV_libnetwork = "67e0588f1ddfaf2faf4c8cae8b7ea2876434d91c" |
49 | SRCREV_cli = "01f933261885c0126edb3f47fd56d048ae31265a" | 49 | SRCREV_cli = "6eb67bf57280491a7e03d0a499e890fe0b89c979" |
50 | SRCREV_FORMAT = "moby_libnetwork" | 50 | SRCREV_FORMAT = "moby_libnetwork" |
51 | SRC_URI = "\ | 51 | SRC_URI = "\ |
52 | git://github.com/moby/moby.git;branch=25.0;name=moby;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX} \ | 52 | git://github.com/moby/moby.git;branch=26.1;name=moby;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX} \ |
53 | git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork;protocol=https \ | 53 | git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork;protocol=https \ |
54 | git://github.com/docker/cli;branch=25.0;name=cli;destsuffix=git/cli;protocol=https \ | 54 | git://github.com/docker/cli;branch=26.1;name=cli;destsuffix=git/cli;protocol=https \ |
55 | file://docker.init \ | 55 | file://docker.init \ |
56 | file://0001-libnetwork-use-GO-instead-of-go.patch \ | 56 | file://0001-libnetwork-use-GO-instead-of-go.patch \ |
57 | file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \ | 57 | file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \ |
@@ -66,7 +66,7 @@ require docker.inc | |||
66 | LICENSE = "Apache-2.0" | 66 | LICENSE = "Apache-2.0" |
67 | LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" | 67 | LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" |
68 | 68 | ||
69 | DOCKER_VERSION = "25.0.3" | 69 | DOCKER_VERSION = "26.1.4" |
70 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" | 70 | PV = "${DOCKER_VERSION}+git${SRCREV_moby}" |
71 | 71 | ||
72 | CVE_PRODUCT = "docker mobyproject:moby" | 72 | CVE_PRODUCT = "docker mobyproject:moby" |